Ability to disable "Smooth scrolling"

Discussion in 'Parallels Desktop for Mac Feature Suggestions' started by SirCodesALot, Aug 17, 2020.

  1. SirCodesALot

    SirCodesALot Bit Poster

    Messages:
    24
    Hello,
    I primarily use Windows for development on my MacBook Pro and the smooth scrolling is really jarring when looking at code, between what ever Parallels is trying to do on top of what VS Code/VS etc etc are doing creates a jarring effect. I personally would prefer it to be disabled but now I have no choice because "mob rule" won and it was removed arbitrarily, what ever happened to pushing a customer feedback survey?

    I'm incredibly frustrated by this, is there still a way to disable this madness?
     
  2. AlexW8

    AlexW8 Bit Poster

    Messages:
    13
    Smooth scrolling breaks Altium Designer's shift+scroll and ctrl+scroll panning controls (and always has). It works well, except when it doesn't, which is the point of the option.
     
  3. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    588
    Hi @AlexW8, sorry for this inconvenience. When you have Altium Designer running, please send us a technical data report via the Help menu > Send Technical Data > please post the report ID here.

    Am I right that you used to toggle smooth scrolling on/off depending on the virtual machine usage? If yes, how frequently did you use this option?
    To disable smooth scrolling manually, please shutdown the VM > locate in Finder > right-click and select "Show Package Contents" > open config.pvs in TextEdit > locate this key and change the value to 0:

    <SmoothScrolling dyn_lists="">
    <Enabled>10</Enabled>
    </SmoothScrolling>

    Then press Cmd+S to save the file > close it and start the VM.
     
  4. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    588
    Hello @_Micah, sorry for this inconvenience. Am I right that you use Visual Studio and you used to toggle smooth scrolling on/off depending on the virtual machine usage? If yes, how frequently did you use this option? To disable smooth scrolling manually, please shutdown the VM > locate in Finder > right-click and select "Show Package Contents" > open config.pvs in TextEdit > locate this key and change the value to 0:

    <SmoothScrolling dyn_lists="">
    <Enabled>10</Enabled>
    </SmoothScrolling>

    Then press Cmd+S to save the file > close it and start the VM.
     
    SirCodesALot likes this.
  5. AlexW8

    AlexW8 Bit Poster

    Messages:
    13
    I'm not sure if it would do any good - smooth scrolling has ALWAYS broken those two particular controls. The behavior is that normal scrolling zooms in and out, and ctrl+scroll or shift+scroll pan left and right. With smooth scrolling off, no problem - these work as expected. With smooth scrolling on, Altium does a little bit of scrolling and a little bit of zooming - like scroll events are coming in too fast that some process with the modifier key, some process without it.

    And I have to admit - smooth scrolling DOES generally work pretty well, and I do certainly prefer it, so I almost always leave it on. And panning in Altium that way is a huge pain, but Altium stinks with a trackpad under the best of circumstances, so I USUALLY use a mouse with more scroll options, and a dedicated right-click button to pan by right-click-drag. It's only under the most dire of circumstances I actually resort to those shortcuts, but then under those already-annoying circumstances, that's when an easy quick checkbox is most valuable, compared to editing a plist and restarting the VM (which, indeed, may not be an option).

    Good to know there IS a workaround to reenable it though.
     
  6. JayD2

    JayD2

    Messages:
    1
    Hi Dmitry
    I have Parallels 16 and I just looked in my config.pvs and the value is already 0. However it looks like smooth scrolling is still on as it my Delphi 10.4 scrolling is still a real problem. Does that sound right?
    Jay
     
  7. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    588
    Thank you for the details! There root cause of this might be in keyboard settings, please do the following to check this hypothesis:
    1. Open VM configuration > Hardware > Mouse & Keyboard
    2. Under the "Keyboard" dropdown select "Optimize for games"
    3. Return/open Altium Designer and check scrolling with Ctrl and Shift keys.

    Let me know the results, please.
     
  8. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    588
    Hello Jay, if the VM config has smooth scrolling value 0, then it's definitely disabled. I bet you already tried to enable smooth scrolling (value 1) and check scrolling experience with Delphi 10.4? Please provide more details about this issue and generate a tech report so we can investigate on our side (Help menu > Send Technical Data... > generate and send a report > post the report ID in reply). Thank you!
     
  9. AlexW8

    AlexW8 Bit Poster

    Messages:
    13
    No such luck - behavior unchanged.
     
  10. AlexW8

    AlexW8 Bit Poster

    Messages:
    13
    I should add - this is specifically using the touch pad. Using the scroll wheel on a mouse, ctrl-scroll works regardless of the setting above. Interestingly, shift-scroll doesn't do anything at all, regardless of setting above.
     
  11. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    588
    Sorry for the delay in my reply, @AlexW8. Is it okay if I connect you with our Suppor Team to investigate this further?
     
  12. AlexW8

    AlexW8 Bit Poster

    Messages:
    13
    Sure, I can try to offer some better insight I suppose.
     
  13. SirCodesALot

    SirCodesALot Bit Poster

    Messages:
    24
    Hi Dmitry, I somehow missed all this activity on my post :-/ Anyway, it looks like it was already previously set before I upgraded to PD16. I wonder as the feature had been removed, it may no longer be even reading that configuration value as well. In any case, the sooner we can bring that feature back the better IMO. When I'm coding I prefer precision over "glide" %.
     

    Attached Files:

  14. WagnerL

    WagnerL Bit Poster

    Messages:
    6
    Any solution to this? I have the same problem.
     
  15. GuyS3

    GuyS3

    Messages:
    1
    I am experiencing the same issue, with uncontrollable scrolling in Visio 32 bit (previous advice was to disable it), in Parallels 16.3.0 (50385) Technical Preview. it appears that this setting to disable smooth scrolling has been removed.
     

    Attached Files:

  16. Boolean

    Boolean Bit Poster

    Messages:
    2
    Dear Dmitri from Parallels: Thank you for that solution. The '0' did the trick for me. Over five years now i use some programs, where i need one "mouse wheel notch click" to be exactly one line forward. With SmoothScrolling enabled this is unfortunate. Old VMs behaved well, but in a new one i could not find the solution for a long time now. Please re-insert that "Enable smooth scrolling" checkbox into the VM configuration again! I feel sad for all that other users that need to cope with that problem in some way. It took me quite a lot of time to find your valuable solution. Please keep and interpret at least this SmoothScrolling-key in config.pvs forever. Remember the Open/Closed SOLID Principle: open for extension, but compatible for the old VMs. Thanks again!
     
  17. SirCodesALot

    SirCodesALot Bit Poster

    Messages:
    24
    So why again can't this be restored as an option in the Settings UI for a Windows VM? This was arbitrarily taken away, and even setting it manually has made no change in smooth scrolling for me - to me it's very jarring and annoying. Can we please for the love of all that's good restore the UI and functionality to disable smooth scrolling. What does it have to take to get something that WAS there back again after it was removed by some unknown royal decree?

    Still not a happy camper about this...
     
  18. Boolean

    Boolean Bit Poster

    Messages:
    2
    Dear Parallels,
    is in the new Parallels 17 the function to disable smooth scrolling available again in the VM configuration window?
    Best Regards
     

Share This Page