Applications/games not working on Windows on ARM

Discussion in 'Parallels Desktop for M Series Mac' started by Mikhail Ushakov, Feb 10, 2022.

  1. MichaelH63

    MichaelH63 Kilo Poster

    Yep. It's basically the same kind of stupid programming that prevents some programs from being installed because the installer checks for an Intel CPU. The app would run fine with Microsoft's emulation otherwise.
    I suppose Diablo IV wouldn't work anyway, though. It requires DirectX 12.
  2. takepoint

    takepoint Bit Poster

    I just installed Diablo 4 (Open Beta) on Parallels Desktop 18 Pro running on Windows 11 Pro 22h2. The game does not launch due to the "No GPUs found!" error. Parallels Desktop was configured for games only. I tried to update and restart and then "Scan and Repair" game files to no avail. Error message as follows: No GPUs found! A GPU is required to play Diablo IV. This might occur if you are currently installing GPU drivers.
    I also tried updating to beta then rebooted both Windows 11 & Ventura - the same result. I guess Diablo 4 can't detect "Parallels Display Adapter (WDDM)" as GPU although the M1 chip had 8 core GPU. My other games Diablo II LoD and Call of Duty Modern Warfare 3 worked fine.

Share This Page