ARM64 Windows doesn't seem to seen my dictation microphone

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by JerryG, Apr 29, 2021.

  1. JerryG

    JerryG Bit Poster

    Messages:
    11
    Just signed up for the Insider Preview for the Windows 10 ARM64 and installed it in Parallels on my M1 mini. This is build 21354. Unfortunately, I'm having a problem with microphone input, using a Phillips Speech Mike Pro.

    In addition to the microphone, the device also also buttons to perform functions in the program and to move the curser and select fields using cursor buttons on the microphone. The microphone itself appears to be active, but the buttons don't work.

    I do see the Speech Mike listed in the Parallels desktop app, not within Windows Device Manager. I don't even see the Parallels audio driver.
    Any ideas as to the nature of this problem and how to fix it. Is the problem with the Windows 10 for ARM build?

    As an aside, how do I get the newer Windows ARM updates?

    Thanks so much for any help.

    Jerry
     
  2. MichaelH63

    MichaelH63 Kilo Poster

    Messages:
    190
    Getting Windows updates is easy. Go to your Insider settings and switch from the default Beta Channel to the Dev Channel. Then run Windows Update.

    is it possible that your microphone needs a driver? If that is the case, check if the manufacturer offers drivers for ARM.
     
  3. JerryG

    JerryG Bit Poster

    Messages:
    11
    Thanks for the reply. I can't find any ARM drivers for this Phillips SpeechMike.
    I've noticed snapshots of the Device Manager in windows on Parallels shows "Parallels Audio Controller" under Sound. I don't see that on my installation. The only driver listed is the generic windows driver. I wonder if the problem is that the Parallels Audio Controller wasn't installed. I've reinstalled the Parallels tool, but nothing changes.
     
  4. JerryG

    JerryG Bit Poster

    Messages:
    11
    I'm running the arm64 preview version 213541. I believe there are later versions. I've set the channel to Dev. But no updates appear. Am I doing something wrong?
     
  5. MichaelH63

    MichaelH63 Kilo Poster

    Messages:
    190
    No, if you're in the Dev Channel the updates should appear when you run Windows Update. The latest build is 21370.
     
  6. JerryG

    JerryG Bit Poster

    Messages:
    11
    I think something may be amiss. Windows indicates I have the dev channel selected. But if I try to change to one of the other channels, it doesn't seem to stick. And running the update doesn't indicate any new updates.
     
  7. MichaelH63

    MichaelH63 Kilo Poster

    Messages:
    190
    Yeah, something definitely isn't right.
    In case you haven't tried that before, check that the internet connection is working in Windows. If it is working, try creating a new VM and see if that fixes the problem.
     

Share This Page