Bad performance in Coherence Mode

Discussion in 'Windows Guest OS Discussion' started by JohnNash, Sep 7, 2017.

  1. StanislavZ

    StanislavZ Parallels Developers

    Messages:
    102
  2. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    563
    Hi, we're investigating with issue at the moment. I will update the thread once there are any news.
     
  3. HernanV

    HernanV Bit Poster

    Messages:
    3
    It's a constant in the last PD versions that with a new version the coherence mode crash
     
  4. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    563
    Hi @HernanV, this is a different case. Can you please send a technical report via Help menu after the next crash happens? Please post the report ID here.
     
  5. StanislavZ

    StanislavZ Parallels Developers

    Messages:
    102
    Preliminary investigation shows that on some hardware (5K iMac in particular) Coherence can be slowed down if used in Scaled mode due to the problems with video driver processing high quality upscaling shader.

    If you're using Coherence in Scaled mode and experiencing slowdowns, try executing this command as is from Terminal:
    defaults write "com.parallels.Parallels Desktop" "Application preferences.CoherenceOsScaling" 1
    And restarting Coherence.

    Please report if this does resolve the issue. Thank you very much and sorry for the trouble.
     
  6. HernanV

    HernanV Bit Poster

    Messages:
    3
    You are a genius! That was totally the issue and that command solves everything.
    I also tested changing the resolution to Best for Retina display and also worked (but I don't like how I see some Eclipse IDE).
    Once again thanks
    PD: this would possible been release in a future update as a fix?
     
    BorjaA likes this.
  7. LarryR3

    LarryR3 Bit Poster

    Messages:
    5
    I'm experiencing a similar issue. Performance is good in windowed mode but the minute I go to coherence everything starts lagging. After some restarts I may be able to get it to run normally for a little bit but it will eventually go back to a lagging mess. Parallels Desktop 12 did not have this issue it only started when I updated to v.13. Tried the command above and see no difference. Deleted and the display drivers in the vm and parallels reinstalled still experiencing the issue.

    Running macOs 10.13.1, parallels 13.2, in the vm windows 10. I've already reinstalled the parallels tools in the vm.
     
    Last edited: Nov 24, 2017
  8. LarryR3

    LarryR3 Bit Poster

    Messages:
    5
    UPDATE: I can now get the slowdown to happen by launching the VM running Windows 10 and launching a twitch stream or youtube video on the host. If I'm not doing anything in the windowed VM everything's cool (even when it is visible). If I start clicking the desktop in the Windowed VM like crazy frames start dropping on the stream in the host OS. Sound does not skip a beat. This is the same issue I experience constantly while in coherence. This never happened in v.12. I'm about to try and downgrade to v.12 to confirm.

    UPDATE 2: Downgraded to v.12 issue persisted. Unplugged second monitor and went into coherence and had no slowdown what so ever. Plugged thunderbolt display into different thunderbolt port and still no slowdown now. I'm at a loss. Upgraded back to v.13 and still no slowdown. This could just be an issue with my macbook or a recent update from Apple. Possibly the different thunderbolt ports on the side of my macbook have different speeds? I'll repost if the issue crops back up again.
     
    Last edited: Nov 25, 2017
  9. TinoB

    TinoB Bit Poster

    Messages:
    9
    I had the same problems and have no idea what the problem is. I use a thunderbolt as a second display with my macbook. On some time (I don't know why) the vm machine with windows 10 will be very slowly. I mean that when I remove Thunderbolt Display the problem is "removed" too.
     
  10. LarryR3

    LarryR3 Bit Poster

    Messages:
    5
    Experienced the problem again today. Unplugging the thunderbolt display and plugging it in again into another port fixed it. Seems like a macos issue.
     
  11. TinoB

    TinoB Bit Poster

    Messages:
    9
    Yes, You're right! I change the thunderbolt port and plugging my display to the other port and back to the first. Now it is ok. but it is now solution!
    What is Parallels saying to this problem? It is known?
     
    LarryR3 likes this.
  12. toothache789

    toothache789 Bit Poster

    Messages:
    1
    Just wanted to post and say that the solution suggested by StanislavZ worked for me as well.

    Running a late 2014 iMac (Retina 5K, 27-inch). macOS 10.13.1, Parallels 13.2.0, Windows 7 VM. Graphics set to Scaled.
    Prior to updating to High Sierra and Parallels 13, everything ran flawlessly.
    After the updates, when in coherence mode, things would become laggy within 10 minutes of use. Restarting the VM worked but only for 10 minutes before it happens again.
     
  13. TinoB

    TinoB Bit Poster

    Messages:
    9
    toothache789 I'm running a late 2013 MacBook Pro with a Thunderbolt Display (in my office), macOS 10.13.1, Parallels 13.2.0, windows 10 VM, Graphics set to Scaled, VM in Coherence Mode. Same problem with vm become laggy. Solve: change the thunderbolt port and vm worked without become laggy until next wakeup from standby.
     
    LarryR3 likes this.
  14. waveen

    waveen Bit Poster

    Messages:
    2
    This worked for me,
    thanks!

    Wouter.
     
  15. AshtonM1

    AshtonM1 Bit Poster

    Messages:
    13
    Is there a difference if using Coherence mode with "Best for external displays" selected? I have not seen slowdowns with the best for external display selected, I am being forced to use Coherence because full screen seems to freeze my computer. Late 2014 iMac 27" Retina 5k MacOS 10.13.2
     
  16. BorjaA

    BorjaA Bit Poster

    Messages:
    2
    Do you solve the problem of the vision of the Eclipse IDE ?
     

Share This Page