Big Sur

Discussion in 'Windows Guest OS Discussion' started by anycast, Jun 28, 2020.

  1. anycast

    anycast Bit Poster

    Messages:
    10
    Hi,

    I just installed Big Sur and with a Windows client, keys 1,2, t and y aren't received by the VM.
    When I run prl_perf_ctl -s hidhook -l 1, if I press 1,2, t or y, action.acted becomes different from 0, and keyboard.sent stays at 0:

    hidhook - 19:44:58 +1.10 sec
    action.acted 12
    action.delayed 0
    action.ignored 0
    keyboard.dropped 0
    keyboard.grabbed 1
    keyboard.hooked 0
    keyboard.injected 12
    keyboard.processed 12
    keyboard.sent 0
    mouse.grabbed 0
    mouse.hooked 0

    With a macOS client no problems occur.
    Any idea on a workaround for this?

    Thanks,
    Alex
     
  2. kavyaM

    kavyaM Kilo Poster

    Messages:
    101
    @anycast Please click Parallels Desktop icon || > Preferences > Shortcuts, select a particular virtual machine > click '+' > map they key to itself (From: 1, To: 1) > click "OK" > Repeat for all affected keys.
     
  3. anycast

    anycast Bit Poster

    Messages:
    10
    Thanks, that worked.
     
  4. kavyaM

    kavyaM Kilo Poster

    Messages:
    101
    @anycast Glad to know that the issue is resolved. Please feel free to contact us for further assistance.
     
  5. kavyaM

    kavyaM Kilo Poster

    Messages:
    101
    @anycast Glad to know that the issue is resolved. Please feel free to contact us for further assistance.
     
  6. Tres Finocchiaro

    Tres Finocchiaro Bit Poster

    Messages:
    23
    Same issue, Windows VM's can't use the "T" and "Y" keys after upgrading to macOS 11.0 "Big Sur". "1" and "2" are also broken. The workaround works, but needs to be applied to each VM. I've attempted to reinstall the Parallels tools, remove and reinstall the keyboard driver and disable game mode to no avail.

    Does Parallels have a KB/bug report for this?
     
  7. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    Hello, please try the following workaround:
    From the menu bar click Parallels Desktop icon (II) > Preferences > Shortcuts, then select the VM in question and click the plus button to create the corresponding shortcut for the necessary symbol. Repeat for each symbol that cannot be typed.
    For more information about the known issues with Parallels Desktop and Big Sur please check and subscribe this KB article.
    And let us know if you have any additional questions.
     
  8. GrayMatter

    GrayMatter Bit Poster

    Messages:
    31
    While this is a functional workaround to get those keys working again, it is not a great solution because there is almost always a delay of the system to recognize the next key stroke after typing one of the mapped keys. For example if you an average proficient typer and type faster than about 45-ish wpm, the phrase "test the happy tiger" frequently becomes "tstte happytger." However, this delay does not appear to be consistent.
     
    AB_1 and Tres Finocchiaro like this.
  9. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    Hello, Thank you for sharing your feedback.
    Parallels Engineering Team are working on the resolution of this issue.
    Once we get any news we will update you.
    Also you can subscribe on this KB article and you will be able to find out all the news one of the first
     
  10. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    Hello guys,
    We're happy to inform you that Parallels Desktop 16 is finally here.
    Please install, test and check the issue.

    Share with us your results please and check this thread for more information.
     
    Tres Finocchiaro likes this.

Share This Page