Black Tabs in Mojave Guest VM

Discussion in 'Mac OS X Guest OS Discussion' started by Neilwhit, Dec 7, 2018.

  1. Neilwhit

    Neilwhit Bit Poster

    Messages:
    34
    Parallels 14.1.0
    Main MacOS - Latest High Sierra
    iMac Late 2014 27"
    Guest OS Mojave (latest)
    ----------------
    Anyone have the issue where the tabs in Finder and Safari windows are blacked out (using Light theme), flicker and are basically unreadable? I've updated Parallels, reinstalled Parallels Tools, updated Mojave but still have the same issue. This is preventing us from trying Mojave since we can't see where we are in either the finder or Safari.

    Also have massive issues with scrolling, the mouse-click sticking and very slow overall performance. Very disappointed. Any ideas appreciated.
     
  2. KebhaK@Parallels

    KebhaK@Parallels Parallels Support

    Messages:
    122
    Hi @Neilwhit , Please go to Finder> Applications> Parallels Tools right click, move it to trash and empty trash. Then reinstall again by following steps in this article
     
  3. Neilwhit

    Neilwhit Bit Poster

    Messages:
    34
    I appreciate the reply. You may have forgotten that there is no Parallels Tools app in the Applications folder any longer (there is a Parallels Toolbox app, but that was removed/trashed previously). And as per my initial post, I had already deleted and reinstalled Tools with no remedy to the black tabs problem.

    Despite that, I did once again use the Actions/Reinstall Parallels Tools to reinstall. I also twice used the Parallels Tools volume and its Uninstall app to uninstall Tools, then restart and Install Tools again.

    But as per my original post, this did not resolve the issue. In the Light mode in Mojave, the tabs remain mostly blacked out and unreadable, changing only briefly if you move the window around, but reverting to blacked out when trying to use the tabs. Works find in Dark mode, but need it to work in Light mode.

    I have also changed the Hardware/Graphics settings to each setting with no remedy to the problem. Thus looking for other ideas.

    Thanks.
     
  4. MichaelO12

    MichaelO12

    Messages:
    1
    I can confirm that I have exact same problem (identical) as described by Neilwhit re black and flickering tabs in finder.

    [In addition using Launchpad in guest OS very problamatic: Cannot move (reposition) app icons in Launchpad view ; opening folder in Launchpad view takes +30seconds ; Launchpad hangs (cannot escape back to desktop) - only recovery is to suspend VM and then run again.]
    Main = Mojave 10.14.2 Guest = Mojave 10.14.2 Parallels = 14.1.0 (45387)
     
  5. KebhaK@Parallels

    KebhaK@Parallels Parallels Support

    Messages:
    122
    Please reproduce the issue and send us a technical report ID by following steps in this article for investigating the issue.
     
  6. Neilwhit

    Neilwhit Bit Poster

    Messages:
    34
    Done. Report ID 288961786
     
  7. Ajith@Parallels

    Ajith@Parallels Parallels Support

    Messages:
    1,993
    Hi MichaelO12,
    We request you to reply directly on the thread instead of replying to email notifications.
    -----
    As per below, here are the technical report IDs

    288959922 : after opening Finder, tabs, do technical report - the screenshots actually shows the blacked-out tabs

    288960640 : after going Launchpad, moving icons delayed action, open 'other' folder delayed , hang, eventually open, move delay, cannot go back to desktop (mouse clicks no effect) - do technical report
     
  8. ChrisOB

    ChrisOB Bit Poster

    Messages:
    3
    I appear to be having the same issue. Host is MacBook Pro running MacOS 10.14.2 running Parallel Desktop 14, version 14.1.0 (45387).

    I have a Mojave VM for development and Safari tabs are black, the first tab will flicker when I hove the mouse over it. In addition, the VM will occasionally freeze and not respond to any input. I have to either pause / shutdown the VM and then restart it for the VM to respond to input. I have also tried to remove and reinstall Parallel Tools as suggested in an earlier post, doing this did NOT resolve the issue.

    Is there any technical information you need from me to help resolve this issue?
     
  9. ChrisOB

    ChrisOB Bit Poster

    Messages:
    3
    Per above instructions, I generated a report id. I am also experiencing UI issues running Visual Studio Code in a MacOS 10.14.2 VM as well as a 10.13 VM. This is going to cause problems as I have client work that needs to be done and their dev environment is configured for VS Code. This is actually the first time I've run into an issue with an application not being able to run on Parallels.

    291805613 : Running MS Visual Studio Code. Screen is not readable as UI elements keep redrawing.

    Update: I created a 10.13 MacOS VM and there are still some UI glitching issues in the Safari tabs, just not as pronounced. I'm also having the same issue with Visual Studio Code. Any updates on what would be causing this?

    Update 2: I contacted Parallels support and reported the issue with VS Code not working in either a 10.14 or 10.13 VM and that there is UI artifacts in Safari tabs in both VMs as well. I have a ticket number and will hopefully get a response from them shortly with a resolution.
     
    Last edited: Jan 1, 2019
  10. ChrisOB

    ChrisOB Bit Poster

    Messages:
    3
    I received a response from Parallels support:
    https://kb.parallels.com/124095
    Apparently, Parallels doesn't support acceleration in a MacOS guest because Apple doesn't provide an API to create an accelerated video driver. So this isn't a Parallels issue, it's an Apple issue. I submitted a bug report, ID number is 47028582.
     
    Last edited: Jan 3, 2019
    Maria@Parallels likes this.
  11. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,023
    Any reply and info about the submitted bug will be very appreciated. Thank you in advance.
     

Share This Page