Build 1970 - Shared Networking option greyed out

Discussion in 'Parallels Desktop for Mac' started by rsanheim, Nov 2, 2006.

  1. serv

    serv Parallels Developers

    Messages:
    809
    MacUser,

    Just do the following:
    1. Click "Start" button on the Taskbar.
    2. Click "Run..." in the menu that appear.
    3. Type in "cmd" and click "OK".

    You are in the terminal. Well... It's not how exactly this thing is called, but anyway.
     
  2. John Booty

    John Booty

    Messages:
    2

    This worked for me BUT I think you're missing a step or two. Here's what I did:

    1. Followed the directions above... at this point, Shared Networking was selectable.
    2. Started up VM
    3. Installed latest Parallel Tools
    4. Rebooted VM

    At this point... I still had no network connectivity in the VM. Untill....

    5. In Mac System Preferences, I enabled Internet Sharing for en3 and restarted Internet Sharing

    Now things work okay. Perhaps step 5 should be obvious, but it wasn't obvious to me, and it took me a little while to figure out. I hope this helps others.

    Thanks for a great product. These bugs or quirks are a little frustrating, but it's the price we pay for rapid releases and development so I don't mind. (If I was using Parallels for something critical, I would stick to stable versions...)
     
  3. Mahko

    Mahko

    Messages:
    7
    ifconfig:

    lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    inet 127.0.0.1 netmask 0xff000000
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
    gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
    stf0: flags=0<> mtu 1280
    en0: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    inet6 fe80::217:f2ff:fe01:7b14%en0 prefixlen 64 scopeid 0x4
    inet 10.42.100.121 netmask 0xfffffe00 broadcast 10.42.101.255
    inet 192.168.2.1 netmask 0xffffff00 broadcast 192.168.2.255
    ether 00:17:f2:01:7b:14
    media: autoselect (100baseTX <full-duplex,flow-control>) status: active
    supported media: autoselect 10baseT/UTP <half-duplex> 10baseT/UTP <full-duplex> 10baseT/UTP <full-duplex,hw-loopback> 10baseT/UTP <full-duplex,flow-control> 100baseTX <half-duplex> 100baseTX <full-duplex> 100baseTX <full-duplex,hw-loopback> 100baseTX <full-duplex,flow-control> 1000baseT <full-duplex> 1000baseT <full-duplex,hw-loopback> 1000baseT <full-duplex,flow-control>
    en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    inet 192.168.3.1 netmask 0xffffff00 broadcast 192.168.3.255
    ether 00:17:f2:01:7b:15
    media: autoselect status: inactive
    supported media: autoselect 10baseT/UTP <half-duplex> 10baseT/UTP <full-duplex> 10baseT/UTP <full-duplex,hw-loopback> 10baseT/UTP <full-duplex,flow-control> 100baseTX <half-duplex> 100baseTX <full-duplex> 100baseTX <full-duplex,hw-loopback> 100baseTX <full-duplex,flow-control> 1000baseT <full-duplex> 1000baseT <full-duplex,hw-loopback> 1000baseT <full-duplex,flow-control>
    fw0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 4078
    inet 192.168.4.1 netmask 0xffffff00 broadcast 192.168.4.255
    lladdr 00:16:cb:ff:fe:6d:4c:96
    media: autoselect <full-duplex> status: inactive
    supported media: autoselect <full-duplex>
    en2: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    inet6 fe80::201:23ff:fe45:6789%en2 prefixlen 64 scopeid 0x7
    inet 10.37.129.2 netmask 0xffffff00 broadcast 10.37.129.255
    inet 192.168.5.1 netmask 0xffffff00 broadcast 192.168.5.255
    ether 00:01:23:45:67:89
    media: autoselect status: active
    supported media: autoselect
    en3: flags=8822<BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500
    ether 00:10:32:54:76:98
    media: <unknown type>
    supported media: autoselect

    tail output:

    Nov 3 15:16:40 Plenum kernel[0]: in_delmulti - ignorning invalid inm (0x35d654)
    Nov 3 15:16:53 Plenum sudo: mahko : TTY=ttyp1 ; PWD=/Users/mahko ; USER=root ; COMMAND=/usr/bin/killall -HUP pvsnatd
    Nov 3 15:16:53 Plenum pvsnatd[274]: Reloading configuration...
    Nov 3 15:16:53 Plenum pvsnatd[274]: en2: DHCP for 10.37.129.2-10.37.129.254 netmask 255.255.255.0
    Nov 3 15:17:01 Plenum sudo: mahko : TTY=ttyp1 ; PWD=/Users/mahko ; USER=root ; COMMAND=/usr/bin/killall -HUP pvsnatd
    Nov 3 15:17:01 Plenum pvsnatd[274]: Reloading configuration...
    Nov 3 15:17:01 Plenum pvsnatd[274]: en2: DHCP for 10.37.129.2-10.37.129.254 netmask 255.255.255.0
    Nov 3 15:17:22 Plenum sudo: mahko : TTY=ttyp1 ; PWD=/Users/mahko ; USER=root ; COMMAND=/usr/bin/killall -HUP pvsnatd
    Nov 3 15:17:22 Plenum pvsnatd[274]: Reloading configuration...
    Nov 3 15:17:22 Plenum pvsnatd[274]: en2: DHCP for 10.37.129.2-10.37.129.254 netmask 255.255.255.0

    thanks for looking into this...
     
  4. serv

    serv Parallels Developers

    Messages:
    809
    A quick note first: Shared Network mode does not require Mac Internet Sharing. Moreover its primary purpose is to replace IS. Unfortunately we have been recommending Internet Sharing as a backup solution for quite some time and now we have to fight the confusion.


    Mahko,

    it appears that en3 is not configured on your Mac (we will be improving our installer). There are two ways to fix it:
    1. Open Mac System Preferences / Network. If a prompt about new en3 interface does not appear you should manually add configuration for it: select the bottom option from the "Show" dropdown then click "Add" and select en3. Leave all settings as defaults. Click "Apply". Then from OSX Terminal 'sudo killall -HUP pvsnatd'.
    2. Uninstall Parallels using Uninstaller from the dmg. Reboot your Mac. Install Parallels again. This will not touch your VMs, and you won't need to reinstall tools afterwards.
     
  5. MacUser

    MacUser

    Messages:
    43
    @ serv

    Thanks for your support.

    After I changed the scoop of the DHCP setting to the range of my fixed IP numbers I had no problems anymore. The reason is obvious, then there was no conflict with the fixed IP number in XP.

    When I changed the setting in XP from fixed to the default dhcp and changed the scoop of Parallels back to the default settings Shared networking was still fine.

    So from the start of the problems it had all to do with the fixed IP number of XP.

    I hope this info is of some use for others.

    Regards Wim.
     
  6. Mahko

    Mahko

    Messages:
    7
    YES!!! that did it! :)

    i now have the option, it works, and network connectivity is much improved over using Internet Sharing (i used to lose my connection after a bit and have to stop and re-start Sharing)

    thanks, Serv!
     

Share This Page