Camera and Microphone not appearing under Security & Privacy

Discussion in 'Installation and Configuration' started by JaumeV, Sep 12, 2018.

  1. ivahost

    ivahost Bit Poster

    Messages:
    60
    After you press close in the dialog box that is popping up incorrectly for many of us parallels disables sharing of a camera and mute the audio inputs. So you do not get the same dialog box the next time you start the vm.
     
  2. TonyC2

    TonyC2 Bit Poster

    Messages:
    26
    Report ID 278003671
     
  3. RobertD19

    RobertD19 Bit Poster

    Messages:
    1
    Hi Gents I have the same issue please see below Parallels reply to me

    Hello Robert,
    Thank you for your reply.
    We have escalated the issue you reported to the Development Team and they are working to address it in one of the future builds of Parallels Desktop for Mac.
    To enable automatic updates, from Parallels Desktop Menu, select Preferences > General > Download Updates Automatically.
    While we do not have ETA for the fix, it has been prioritised appropriately and you can track the changes in the product at the corresponding knowledge base article page:
    - Parallels Desktop 14 for Mac updates summary: http://kb.parallels.com/en/124521
     
  4. ColtonN

    ColtonN Bit Poster

    Messages:
    1
    Same issue here... MacOS Mojave GM -- Report ID 278247477
     
  5. AJ@Parallels

    AJ@Parallels Staff Member

    Messages:
    753
    Hi All, Please follow the below mentioned steps.
    1. Please start the virtual machine, select Actions (from the Mac menu bar) > Configure > Options > Startup and Shutdown change to Start up and shut down manually, then shut down the VM.
    2. Restart the Mac.
    3. Start the VM and then add Parallels Desktop in the System Preferences after the pop-up appears.
    4. Change start up settings back to the required values.
     
    JaumeV likes this.
  6. ivahost

    ivahost Bit Poster

    Messages:
    60
    This did not help. Still not getting the permission popups
     
    AaronN1 likes this.
  7. AJ@Parallels

    AJ@Parallels Staff Member

    Messages:
    753
    Hello ivahost, Kindly follow the instructions from this link and check if it helps.
     
  8. ivahost

    ivahost Bit Poster

    Messages:
    60
    In my previous posts in this thread I described 2 problems. my initial problem was that I would not get the allow parallels access to the camera/microphone and that when I checked in the privacy part of system settings parallels was not listed there. Then after a clean reinstall of macos it appeared to work for a day before suddenly stopping to work again. Now parallels is listed in the system settings (and selected) but I still am being told it has no access to the camera / microphone.

    There is clearly a bug here as no other programs I have (and that is using the camera / microphone) has a similar program. Also the number of posts in this thread should show that something is wrong with parallels and permissions for the camera and microphone.
     
    AaronN1 likes this.
  9. GordonN2

    GordonN2 Bit Poster

    Messages:
    5
    Hi All - Following AJ@Parallels instructions... my microphone access appears to be working correctly! Thanks AJ and hope you all have good luck with this!
    -GN

    Hi All, Please follow the below mentioned steps.
    1. Please start the virtual machine, select Actions (from the Mac menu bar) > Configure > Options > Startup and Shutdown change to Start up and shut down manually, then shut down the VM.
    2. Restart the Mac.
    3. Start the VM and then add Parallels Desktop in the System Preferences after the pop-up appears.
    4. Change start up settings back to the required values.[/QUOTE]
     
  10. AJ@Parallels

    AJ@Parallels Staff Member

    Messages:
    753
    [/QUOTE]
    Hello GordonN2! Thank you, Please feel free to reach us any time for any queries regarding Parallels.
     
  11. AlbertH2

    AlbertH2 Bit Poster

    Messages:
    11
    Thanks Aj! Finally my Mic is working in PD14 now. BTW, I suggest to rephrase step 3 as:

    3a. Start the VM and then change Parallel Desktop Configuration -> Hardware -> Sound -> Input -> MacBook Pro's Mic. Click [OK] in the pop-up message that request for access.
    3b. Go to macOS's system preference -> Security and Privacy -> Microphone to enable Parallel Desktop.
     
    Last edited: Oct 11, 2018
  12. IvanD@Parallels

    IvanD@Parallels Parallels Support

    Messages:
    14
    Hi guys! A workaround has been found for the issue duscussed here.
    Change configuration of all available virtual machines in Options > 'Startup and Shutdown' to 'Start up and shut down manually'

    [​IMG] upload_2018-10-11_11-50-19.gif

    Then restart the Mac and after the restart start Parallels Desktop again. After granting the access it's possible to change Startup and Shutdown settings to the previous values.
     
    AaronN1 likes this.
  13. GordonN2

    GordonN2 Bit Poster

    Messages:
    5
    Hello GordonN2! Thank you, Please feel free to reach us any time for any queries regarding Parallels.[/QUOTE]
    Uh oh! There was a Parallels update made over the weekend (saw it Sunday, 14 Oct)... and the microphone is no longer working. Same exact symptoms as before. Version 14.0.1 (45154) is now the current version running on my Mac.
     
  14. strells

    strells Product Expert

    Messages:
    567
    This worked for me in 14.0.1. I already had it set to "Start up and shut down manually", but rebooting my Mac and restarting the VM gave me the option to give permission to PD to use the microphone.
     
  15. GordonN2

    GordonN2 Bit Poster

    Messages:
    5
    Is now working for me again as well. Thanks All!
     
  16. HeikoE

    HeikoE Bit Poster

    Messages:
    1
    any new to the escalated issue? I still can not use the mic
     
  17. AJ@Parallels

    AJ@Parallels Staff Member

    Messages:
    753
    Hello HeikoE, Kindly follow the instructions from this link and enable Microphone for Parallels Desktop in Accessibility.
     
  18. AlbertH2

    AlbertH2 Bit Poster

    Messages:
    11
    Hi ivahost,

    After applying the workaround mentioned in above replies(set start up and shutdown manually), my mic has been working for two weeks. But today I entered a state similar to yours, i.e., I have Parallel Desktop listed and checked in MacOS's mic security setting, but I'm still getting the pop up saying parallel cannot access the mic. I have struggled for a while and finally make the mic work again. Not sure which of the following really fixed the problem. You may try if any of below helps for your case.

    1. Set Parallel to be start and shutdown manually
    2. Exit Full Screen Mode (my original problem started with strange graphics in full screen mode and cannot exit full screen mode)
    3. Select "Shutdown" from parallel desktop (instead of selecting shutdown from guest Windows)
    4. Exit Parallel Desktop completely (there is no small dot below the parallel desktop icon in dock). In some of the attempts, sometimes Parallel refused to be completely closed.
    5. Reboot MacOS
    5. Set the Mic in Parallel again.
     
  19. Sathiya@Parallels

    Sathiya@Parallels Staff Member

    Messages:
    733
    Hi AlbertH2. Nice to know the it works and thanks for sharing the steps that fixed the issue for you. Please post again for additional queries.
     
  20. StevenP13

    StevenP13 Bit Poster

    Messages:
    1
    I have the same issue. I am using latest Mojave
    My Privacy setting are set to ALL my Microphone to Parallels Desktop.
    In my Configuration of my VM under the sound tab, I see both my input and output set to my proper Audio source.
    When change from Mute to my source, I get the image show above and it resets it to MUTE.
    I sent a report to Parallels.

    A technical report with the ID number 284490492 has been sent to Parallels.
     

Share This Page