Can I Disable Mac Volume Keys for Windows 11?

Discussion in 'Windows Virtual Machine' started by MattA7, Jun 17, 2023.

  1. MattA7

    MattA7 Bit poster

    Messages:
    2
    I am running the Windows 11 ARM preview on an M1 Max MBP. When I press the Mac volume keys while Windows 11 is my active window, both the Mac system volume and Windows sound volume adjust. Is it possible to change this so the VM volume isn't affected by the Mac volume keys? This used to be the case with older versions of Windows on my previous Mac.

    These are the only relevant settings I could find:
    • In Parallels preferences, Send macOS system shortcuts is set to Never
    • In the VM configuration, Sync volume with Mac is unchecked
     

    Attached Files:

    MatthewR20 likes this.
  2. ZacharyB6

    ZacharyB6 Bit poster

    Messages:
    7
    I am using a Mac M2 and had not problems with the On Screen Popup in windows until about a week ago. I can't seem to find if it's a Windows 11 update that is causing a constant popup of the OSD Volume alert or if it's a Parallels update - but something happened. Currently I am using the HideVolumeOSD utility (available on GitHub) and it's working well. I, like you would like to stop sending MacOS shortcut keys to the Windows ARM OS too.
     
  3. ZacharyB6

    ZacharyB6 Bit poster

    Messages:
    7
    Oh, and just so others see what we're experiencing....I've attached an image. This OSD pops up over and over and you can see the volume bar go from mute to active, to mute to active repeatedly - like it's a stuck key.
     

    Attached Files:

  4. RobertP5

    RobertP5 Bit poster

    Messages:
    3
    I have this exact same issue.

    Windows 11 ARM Preview, on a M1 Max MBP. I just tried updating today to Parallels v19 to see if it has fixed this long outstanding issue for me, and it has not.
    All F1-F9 Fucntion keys work as expected, EXCEPT F10-F12 in Windows, which controls both Mac volume, and Windows volume, at the same time.

    I generally leave Windows at 100% and just control my Mac volume on my previous laptops running Parallels, but cannot get it to function correctly on the M1 MBP, across now 2 major versions of Parallels.
     
  5. MattA7

    MattA7 Bit poster

    Messages:
    2
    I found a workaround using AutoHotKey. When this script is triggered, the app runs in the background and prevents the volume keys from doing anything. I also have it launch on startup.
    Here are the contents the script file:

    #Requires AutoHotkey v2.0
    Volume_Up::return
    Volume_Down::return
    Volume_Mute::return


    upload_2023-8-25_22-32-57.png
     
  6. ZacharyB6

    ZacharyB6 Bit poster

    Messages:
    7
    Thanks Matt - I'll have to try that out.
    I did have an issue with HideVolumeOSD in that it must be having to deal with so many Windows keys/events that is causes task switching and all kinds of other oddities. I'll see if AutoHotKey solves that issue.

    As a side note - I believe this has something to do my Bluetooth speakers. If I have Mac Speaker as the default, Windows behaves fine. Once I turn on Bluetooth headphones, Windows goes bonkers. I have to shut the VM down. Set Mac Speakers as the default and then restart the machine. Then things are happy again (until I turn on my Bluetooth headphones again). I doesn't matter if you turn on the headphones, and try to set the speakers as default to stop the madness. You just have to do the shutdown procedures as I laid out.
     
  7. VictorN6

    VictorN6 Bit poster

    Messages:
    4
    I think that you can solve that in the Virtual machine settings, in the sound and camera section, you can synchronize or not the Windows volume with the Mac.
     
  8. RobertP5

    RobertP5 Bit poster

    Messages:
    3
    I finally found someone who knows what they are doing via Parallels Support and they gave me these instructions. This totally fixed the issue for me!

    Regarding the issue, as was mentioned by my colleagues earlier, it's currently on the review of the Development Team, and as of, yet we do not possess new input, however, we will let you know immediately once it is available.​

    We do have two notes to add on the subject, however:​

    1. The buttons appear to only affect sound level in Windows when it's at the front as a focused window. When the virtual machine is minimized or another macOS application is in the front, function keys would only affect the Mac.
    2. There is a possible workaround, which however involves disabling all special key functionality in Windows via the registry key value that would essentially block the functionality in Windows and seems to stop influence of the volume keys in Windows altogether.​

    We cannot say for certain if this fit your scenario, since as mentioned it would disable all the special keys input service in Windows, but we can offer you to try using it, and in case it's not acceptable, revert the changes:​

    1. Start your virtual machine.
    2. Create a Snapshot of the virtual machine before proceeding by clicking on Actions -> Take a Snapshot.
    Note: This will allow to effortlessly roll back impending changes, should they introduce any undesirable effect.
    3. Press "Command+R" -> In the opened window, type:
    regedit
    And press "Enter".
    4. Registry Editor will open -> navigate to the
    HKLM\SYSTEM\CurrentControlSet\Services\hidserv
    Note: Click on the hidserv parent node, to locate the required value.
    5. Locate the "Start" DWORD value -> Double-click it -> Change the value to 4
    6. Reboot the virtual machine and check if the issue is alleviated, and if there are any ill effects that are not acceptable.
    In case there are, simply roll back to the snapshot taken in step 2, by pressing "Actions" -> "Revert to snapshot".​
     
    DanielR45, Dougrinch and JohnB117 like this.
  9. JohnB117

    JohnB117

    Messages:
    1
    This solved my issue, thank you!
     

Share This Page