Cannot enable TPM, TPM option missing from add hardware menu

Discussion in 'Installation and Configuration' started by KarstenS6, Aug 15, 2019.

  1. mmika

    mmika Kilo Poster

    Messages:
    488
    Most likely your VM is not using UEFI BIOS. Run 'msinfo32', for example, and look for BIOS mode.
     
  2. >>> Message has been deleted by the user <<<
     
  3. >>> Message has been deleted by the user <<<
     
  4. MissyT

    MissyT Bit Poster

    Messages:
    11
    Platform Trust Technology (PTT) is enabled on these systems by default, causing the TPM to be greyed out in the BIOS (Only one of these trust technologies can be enabled at a time). To enable TPM, PTT protection must be removed from the encryption keys.
    To disable the PTT Protection and encrypt the hard drive through TPM:
    1. Suspend BitLocker if it has been initiated.

    2. Restart the system, and enter the BIOS

    3. Disable Secure Boot in the BIOS.

    4. Under Security Settings: Disable PTT, Enable TPM, Activate TPM, then save the changes

    5. Restart to the operating system and enable BitLocker
    BitLocker should be functioning on the TPM once this is complete.
    This configuration is currently seen in the Dell Latitude 10/ST2 and Venue 11 designs. Future systems may also include this technology.
     
  5. >>> Message has been deleted by the user <<<
     
  6. mmika

    mmika Kilo Poster

    Messages:
    488
    Yes. It helped.
    craigmcfly, you have forced TPM for VM via system flags.
    Could you edit VM config.pvs file in VM bundle, and set <EfiEnabled> field to 1.
    I'm sure this solve you problem.
     
    Parallels User likes this.
  7. >>> Message has been deleted by the user <<<
     
  8. mmika

    mmika Kilo Poster

    Messages:
    488
    Sorry, misprint there, should be "forced UEFI".
     
  9. >>> Message has been deleted by the user <<<
     
  10. davide alessio

    davide alessio Bit Poster

    Messages:
    22
    when I set <EfiEnabled> field to 1. my system will not start... any suggestion?
     
  11. mmika

    mmika Kilo Poster

    Messages:
    488
    Why did you set <EfiEnabled> to 1?
    What OS in your VM installed?
    What did you try to achieve?
    And it's better to generate technical data, send it to Parallels and share its ID here.
     
  12. davide alessio

    davide alessio Bit Poster

    Messages:
    22
    my OS is windows 10
    I am trying to upgrade to windows 11 without install another VM
    id 380505147
     
  13. mmika

    mmika Kilo Poster

    Messages:
    488
    I see after you set <EfiEnabled> to 1, and VM still booted into Windows.
    Then you powered off it properly.
    Then you have added TPM into config. And only after this step VM didn't boot.

    I guess you didn't run 'mbr2gpt' in Windows. It should be the first step.
    See excellent post for guidance.
     
  14. davide alessio

    davide alessio Bit Poster

    Messages:
    22
    it works!!!! thanks!!!
     
  15. DebasmitaM@Parallels

    DebasmitaM@Parallels Staff Member

    Messages:
    1,148
    Hello, kindly update to Parallels Desktop for Mac 17.1.0 for resolving the issue. Thanks, Parallels Team.
     
  16. BRIANM32

    BRIANM32

    Messages:
    1
    I'm using the trial version of parallels 17.1.0 and I have no TPM option. bios is EFI. Am I missing something here?
     
  17. mmika

    mmika Kilo Poster

    Messages:
    488
    BRIANM32, what type of guest OS is set on "General" tab of VM configuration editor. It should be set to Windows 10 or Windows 11.
    Also, TPM in not available for Bootcamp based VMs. How did you set bios type to EFI? If you set it via boot flags of Advanced windows it won't work.
     

Share This Page