Can't install Parallels Tools on RHEL 8.4

Discussion in 'Linux Guest OS Discussion' started by GjorgiV, May 25, 2021.

  1. GjorgiV

    GjorgiV Bit Poster

    Messages:
    24
    After successfully upgrading Parallels Desktop to 16.5 and the RHEL 8 guest to RHEL 8.4, trying to reinstall Parallels Tools remains unsuccessful. Despite having installed the latest kernel-devels, headers, gcc, dkms and epels.
    The bottom of the /var/log/parallels-tools-install.log file lists, beside a lot of other "fail" messages, inability to build kernel modules. prl_fs is mentioned a lot.
    There's partial functionality still on, like the mouse integration. Resizing after exiting from full screen mode and integration with the host file system aren't working.
     
  2. (GalaxyMaster)

    (GalaxyMaster) Kilo Poster

    Messages:
    90
    When you have an issue with the Parallel Tools the most important bit of info is to provide the kernel version and the version of the tools. Without this nobody could help you, most of the time.
     
  3. GjorgiV

    GjorgiV Bit Poster

    Messages:
    24
    Kernel version 4.18.0-305.el8.x86_64
    Unsuccesful installation of Parallels Tools version 16.5.0.49183
     
  4. HenryF4

    HenryF4

    Messages:
    1
    I am having a similar issue, except for me the virtual-DVD only contains a file labeled in chinese (which when I cat it is binary):
     
  5. rlangbehn

    rlangbehn Bit Poster

    Messages:
    3
    I have exactly the same issue. Any help with this issue will be very welcome. Following my system informations:
    Parallels Desktop 16 for Mac Pro Edition Version 16.5.0 (49183)
    Parallels Tools Version 16.5.0.49183
    RedHat Guest Version RHEL 8.4
    Kernel Version 4.18.0-305.el8.x86_64

    Regards
    rainer
     
  6. rlangbehn

    rlangbehn Bit Poster

    Messages:
    3
    I opened a support ticket for this issue: #2975080
     
  7. rlangbehn

    rlangbehn Bit Poster

    Messages:
    3
    Further information: The RHEL 8.4 distribution is NOT the Beta but the GA version.
     
  8. WarrenY

    WarrenY Bit Poster

    Messages:
    2
    I also had a Parallels Tools upgrade failure with the latest CentOS 8 Stream version, which should be roughly equivalent to RHEL 8.4. I found that this old solution now applies, even though RHEL 8 doesn't run kernel 5.0.anything but instead 4.18.

    Wild guess: Red Hat back-ported something from Kernel 5.x to this 4.18 kernel that affects this, and the ifdefs in the Parallels Tools code doesn't catch this.

    I manually hacked all the MB_* → SB_* in prl_fs/.../super.c as in the other thread, and my CentOS 8 VM is up and running again, with networking and /media/psf working.
     
    (GalaxyMaster) likes this.
  9. JohnL52

    JohnL52 Bit Poster

    Messages:
    1
    Like WarrenY above, I too followed the old solution link and made a copy of the installer, however my build errors were a little different using Parallels Version 16.5.1 (49187) and RHEL8 guest with kernel 4.18.0-305.12.1.el8_4.x86_64. Pay attention to the make errors listed in /var/log/parallels-tools-install.log and fix those which come up in super.c.
     
    (GalaxyMaster) likes this.

Share This Page