Cisco IPSec vpn disconnects upon guest windos with "shared network" startup

Discussion in 'General Questions' started by ViktorR, Jan 9, 2021.

  1. ViktorR

    ViktorR Bit Poster

    Messages:
    12
    Hello,

    Today my clients asked me to connect remotely to their site to do some tasks. They have some asus gt-ax11000 router with ipsec vpn server configured on it. I set up a vpn connection on my mac and connected there. They have some specific devices that could be configured from windos only, so I ran my parallels win10 installation. Long story short: with guest windos 10, network configured as "shared". Macos 11.1 (20C69), also tried latest Catalina. Cisco ipsec vpn to the remote site. Vpn connection works fine just till windos guest os starts. After it starts, vpn immediately stop working, i. e. there's no pings to the internal peer's address from macos anymore. I observed it first on my mbp: MacBook Pro (13-inch, 2018, Four Thunderbolt 3 Ports), then tried it on the earlier macbook and then on other of my macs, and found it 100% reproducible.

    How to reproduce:
    1) configure cisco ipsec vpn on mac
    2) connect this vpn to the remote peer (vpn server)
    3) start ping to the internal peer's vpn address (i.e. 192.168.1.1 in my case)
    4) observe ping is receiving icmp echo replies
    5) configure guest windos 10 with "shared network"
    6) wait arbitrary amount of time watching ping is still working ok ( I tried many times with intervals from 10 seconds to several minutes)
    6) start this win10 in the parallels
    7) observe no ping replies anymore and vpn disconnects a bit later (10-30 seconds actually)

    Any ideas about that? Could anyone else check it please?
     
  2. ViktorR

    ViktorR Bit Poster

    Messages:
    12
    A brief update - the same behaviour observed with Centos Linux I have installed for testing. And with "Shared network" only, as well.
     

Share This Page