Cmd-Tab app switching focus problem

Discussion in 'Windows Virtual Machine' started by BrianB10, Sep 6, 2017.

  1. BrianB10

    BrianB10 Bit poster

    I am having a problem with your new release, version 13.0.0 (42936) which I did not have with previous versions.

    I always use Parallels in Coherence mode. When using Cmd-Tab to switch between applications (which I do constantly all day long) here's what frequently (but not always) happens:

    The focus is on a Windows app, in which I am typing. Then I Cmd-Tab switch to a Mac app, in which I type or click the mouse. Then, when I Cmd-Tab back to the Windows app, instead of that app getting the focus, the virtual machine gets the focus. Then I have to take extra steps to put the focus back on the Windows app itself. This is very frustrating and driving me crazy! It is definitely reducing my productivity.

    The weird part is (besides this mis-focus problem) is that it doesn't happen all the time, and I have not been able to determine the circumstances under which it does occur. But it happens often enough that it is a real problem.

    I would be very happy if this bug could be fixed, so that Parallels works like it used to for Cmd-Tab app switching.

    I would be even happier if there was a setting in Parallels so that the virtual machine icon would not even appear in the list of apps when Cmd-Tab switching.
  2. BrianB10

    BrianB10 Bit poster

    Here are some additional details:

    This problem occurs even when I use the mouse to switch apps instead of Cmd-Tab. If I am in a Windows app, and click over to a Mac app, and then click back to the Windows app, the focus goes to the virtual machine instead of the Windows app.
  3. DenisO

    DenisO Parallels Developers

    Please, reproduce this problem, then send Report a problem from Parallels Desktop (, and provide the number.
  4. MortenT1

    MortenT1 Bit poster

    I sent one now, ID is 224785191. Happens every time i switch between app in Win 10 VM and OS X app.

    EDIT: Like the gentleman above, it actually doesn't happen all the time. I was away from the computer for 10 minutes and it worked when i came back.
    Last edited: Nov 13, 2017
  5. lithe951

    lithe951 Member

    FWIW I just did a clean install of Version 13.1.1 (43120) and a brand new install of Windows 10. I use it in coherence mode all the time, and I am having the same issue. This didn't occur in my prior install of v11 with Windows 7. I also notice a few other hitches - seems like coherence in v13 isn't quite as stable as it used to be.
  6. PaulChristopher@Parallels

    PaulChristopher@Parallels Product Expert Staff Member

    Hi @lithe951, please try the following steps to fix the issue:
    1. Click on the Parallels menu on Mac menu bar > Preferences...
    2. Switch to Shortcuts tab > Application Shortcuts.
    3. Scroll down and disable Show Next Tab keyboard shortcut.
    4. Now Ctrl+Tab keyboard shortcut will work in the virtual machine.
    feinberj likes this.
  7. feinberj

    feinberj Bit poster

    Hi Paul Chris - thank you for this suggestion. I too was unable to use control-tab to switch from one tab to another within Windows programs. Your suggestion solved the problem! I am using Parallels 17 with Windows 10. I recently switched from VMware Fusion. I switched because Parallels will allow me to continue to use my 2010 Mac Pro once I upgrade it to Big Sur. I am on Catalina now, but VMWare Fusion will not emulate Intel VMs with Big Sur on my Mac Pro. I switched to ensure future compatiblity, but I also see that the Windows UI is so much faster so that part is really, really nice.

    John Feinberg
    Montclair, NJ

Share This Page