Connected Android via USB to Windows VM, doesn't detect and has gone missing.

Discussion in 'Windows Guest OS Discussion' started by JoeB15, Apr 18, 2018.

  1. JoeB15

    JoeB15 Bit Poster

    Messages:
    4
    As question says.
    I connected my Android to my Windows VM and a prompt to connect to Mac or Windows came up, and I chose Windows.
    Parallels successfully disconnects the android device but then does nothing to it? It does not appear in USB connections nor in the Windows VM. I try to open Android File Transfer on my mac in attempt to reconnect it, seeing if it is still connected, but it doesn't detect it. My android device has been stuck on charging mode and cannot detect my mac anymore.

    I've tried to reset the USB connects by going into USB Devices in Parallels settings and selecting "Restore Defaults" but it does nothing.

    I am very confused and worried. Have I lost my android phone connection to my mac forever?
     
  2. Arun@Parallels

    Arun@Parallels Parallels Support

    Messages:
    1,359
    Hi @JoeB15 , please click on Device on the mac menu bar > USB > Select the Android device and check if that helps.
     
  3. JoeB15

    JoeB15 Bit Poster

    Messages:
    4
    I cannot see the android device? Like I said it seems to have disappeared entirely. It used to work on mac but since attempting to connect it to parallels it disappeared.

    [​IMG]

    The USB Receiver is the Logitech Unifying usb reciever that is currently plugged in.
     
  4. JoeB15

    JoeB15 Bit Poster

    Messages:
    4
    Is there a way to reset all remembered device connections? Maybe this might let the host mac detect the android again.
     
  5. Ajith1

    Ajith1 Parallels Support

    Messages:
    2,720
    If a USB device is permanently assigned then we have an option to remove it. We suggest you check in System Report (Apple Logo > About this Mac > Overview > System Report) if the USB device is detected by the Mac. If it is not detected then the issue might be with the cable or Android device. You can also quit Parallels Desktop and check System Report if the USB is detected or not.
     
  6. JoeB15

    JoeB15 Bit Poster

    Messages:
    4
    Thanks, I've checked and it seems my mac couldn't detect it. I have tried with another cable and seems to be the same result. Seems that my android was the problem.
    It's weird because I did restart it before but now when I try it does work now. Maybe it is because I restarted first (did not work) then selected "Revoke USB debugging authorizations" but I didn't think to restart again (til now!).
    Thanks for your patience @Ajith@Parallels , seems the problem is solved!
     
  7. Ajith1

    Ajith1 Parallels Support

    Messages:
    2,720
    We are happy to hear that the issue is resolved. You can reach out to us anytime for support.
     

Share This Page