Credentials not stored under ivanti/appsense

Discussion in 'Parallels Client for Windows' started by RuudH, Dec 4, 2017.

  1. RuudH

    RuudH Bit Poster

    Messages:
    7
    Hi,
    We are using the Parallel client version 16.0.18343.0 on xenapp 2012R2 servers with appsense (ivanti) HkCu>Software>Parallels is included and so is the folder appdata>roaming>2xclient.
    After logging in i can see that the registry keys and appdata files are imported. (Autostart on windows startup is disabled) When i start the client there is no password available and after closing the client without logging in all settings are back to default. What am i missing here???
    Kind regards,
    Ruud.
     
  2. RuudH

    RuudH Bit Poster

    Messages:
    7
    I know what i am missing.... replies :)
     
  3. RuudH

    RuudH Bit Poster

    Messages:
    7
    Noticed writing to
    HKCU\ Software\Microsoft\Windows\CurrentVersion\Explorer\GlobalAssocChangeCounter ... no clue why....
     
  4. jpc

    jpc Kilo Poster

    Messages:
    333
    @RuudH The change in GlobalAssocChangedCounter could be due to file association changes (for its own internal formats e.g. 2xa) or for some association pushed by the server (e.g. forcing a specific (set of) file to open with a server-side published application).
    Other programs exhibit the same behaviour e.g. browsers (ref: https://social.technet.microsoft.co...y-for-default-browser?forum=ieitprocurrentver)

    As for your problem with ivanti, could it be you need some other key (like the HKLM\Sofware\Parallels or the Wow64 subset of HKCU)?
    Also, by "all settings are back to default", do you mean that you lose all connections and the client starts up just as if it was recently installed?
     
  5. RuudH

    RuudH Bit Poster

    Messages:
    7
    @jpc Thanks for replying. HKLM\Software\Parallels stays unchanged. HkCu>Software>Parallels is included in the ivanti setings. The Wow64 subset seems not to be used by Parallels.
    All setting back to default refers to the options. All changes are overwritten by the default values.
     
  6. jpc

    jpc Kilo Poster

    Messages:
    333
    If it was only a problem of the password not being saved, I would have told you to check that the "Save Password" checkbox is ticked.
    However since you are having problems with the retaining of all the settings, all I can suggest is to:
    1. upgrade to the latest client version (v16.2), maybe this fixes your issue
    2. re-generate your ivanti profile, maybe something was not saved properly
    3. if all else fails, contact parallels support so that they can help you investigate this issue deeper
     
  7. RuudH

    RuudH Bit Poster

    Messages:
    7
    Thank you for replying. Save password was the first thing i did when i installed this application. Ivanti profile reset was done several times. Upgrade: will do asap!
    Ivanti is looking at the problem too now. They do not have any experience with the Parallels client so its is new to them too.
     
  8. Rolandv

    Rolandv Bit Poster

    Messages:
    1
    I experience the same issue. Did you fix it in the meantime? Did the upgrade help?
     
  9. RuudH

    RuudH Bit Poster

    Messages:
    7
    I fixed it. The original policy import included all default registry keys. That caused the reset Because the name that was given by the engineer to that node did not include the word Parallels it was a bit hard to find for a morlal soul like me :)
    Application personalisation: Appserverclient.exe
    Include register: HKEY_CURRENT_USER\Software\Parallels
    IncludeFoldeer: {CSIDL_APPDATA}\2XClient\
     
    jpc likes this.

Share This Page