Disable Apple Menu & Dock In Lion Full Screen?

Discussion in 'Installation and Configuration' started by NathanJ, Nov 3, 2011.

  1. NathanJ

    NathanJ Bit Poster

    Messages:
    25
    It's driving me crazy that the Apple menu and the dock pop-up when in the special Lion style full screen. I keep accidentally clicking out of full screen when I'm trying to close a Window--bye bye window sizes and icon locations. And it's murder competing for pop-down menus when using Terminal services or other Windows apps that have menus at the very top of the screen.

    I already tried using the "password to exit full screen" option which does hide the menu and dock, however, it basically forces you to exit fullscreen to get to your other fullscreen apps or desktops.

    Other than switching back to the old style of fullscreen, does anyone have any ideas? Should I make a feature request?
     
  2. YanaYana

    YanaYana

    Messages:
    1,666
    I suppose there is no option to disable Dock to appear when you move mous down in the full screen apart from what you were saying - I guess it is a good idea to report this behaviour to Apple so that there could be an opportunity to disable dock and apple menu to show in the full screen.
     
  3. NathanJ

    NathanJ Bit Poster

    Messages:
    25
    I don't think its a restriction of Lion though because Parallels does manage to disable them when requiring a password to exit fullscreen mode (in the "Security" section).

    I think maybe it's an option that Parallels should add to the "Full Screen" section as a sub-option of "Use Mac OS X Full Screen".
     
  4. brkirch

    brkirch Kilo Poster

    Messages:
    415
    If you don't want the dock or menu to show up in Mac OS X full screen then you need to turn on active screen corners and then set the screen corners to not have any associated action.
    (From the menu select "Virtual Machine" > "Configure...". Then select "Options" from the toolbar and then "Full Screen" from the list on the left side of the window. Check "Active Screen Corners" and select "-" for each screen corner.)
     
  5. NathanJ

    NathanJ Bit Poster

    Messages:
    25
    Brilliant! That did the trick!
     
  6. LouisG

    LouisG

    Messages:
    1
    Legend! Works like a charm
     
    Last edited: Jan 9, 2012
  7. BrianI

    BrianI

    Messages:
    1
    I was going crazy trying to figure out why this didn't work for me. The problem turned out to be using Cmd-Tab to switch to a Mac application and then back to Windows, something I do frequently.

    When I first start Windows, the Active Screen Corners trick works and I don't get the Menu when mousing over the top of the screen. However, after the first time I use Cmd-Tab and come back, the Menu is permanently active. There doesn't seem to be any way to turn this off.
     
  8. YanaYana

    YanaYana

    Messages:
    1,666
    I sugget you to contact tech support - they will be able to investigate it or forward to product maintenance team
    www.parallels.com/suppurt
     
  9. KendallB

    KendallB Bit Poster

    Messages:
    31
    Oh man, this saved my day! It was driving me nuts that in full screen mode when I went to close another full screen window I would accidentally click the full screen icon in the menu bar as it popped up! Thanks!

    I ended up leaving the top left corner active so I can get to the menu when I need it, as I rarely mouse up to that corner very much, but regularly mouse to the top right corner...

    Now I just need to find a way to turn off fullscreen Cmd-Tab integration, as I prefer to let Windows handle it when in Windows (which works great), but then when I go back to the Mac desktop (with a two finger swipe on my magic mouse - hehe) and use Cmd-Tab all my Windows apps are now in the list! Any way to turn that off?
     
  10. railfan

    railfan

    Messages:
    3
    hmm... this doesn't seem to be working for me using Parallels 9 under Mavericks... or i'm misunderstanding this functionality? i want the dock to stop popping up when in Windows and I go to the bottom of the screen to access the taskbar. i tried the corners thing and it still pops up when i mouse to the bottom of screen... any ideas? thanks!
     
  11. NathanJ

    NathanJ Bit Poster

    Messages:
    25
    This was never fixed in Parallels since they broke it back when I made the original posting, and I'm not sure why. Maybe too many people were getting stuck when they were in full screen without a dock or menu.

    I found I got the best results by unchecking the box entitled "Use Mac OS X Full Screen". Then, create additional desktops in Mission Control and drag your VM window to the desktop where you want it to go full screen. In the future, that VM will show up on that particular desktop when you reopen it (at least in PD 9).

    Hope this helps.
     
  12. railfan

    railfan

    Messages:
    3
    Thanks, Nathan, it does indeed seem to do the trick with the creation of an additional desktop. No real disadvantage other than not being able to access all open windows when using Mission Control, but just need to go to the dedicated OS X desktop to do that. In a way nicer though having the separate workspaces.

    The other alternative was, as I saw mentioned I think on another thread, just mousing straight to the Start Menu or the Show Desktop bar at far right. Both these areas don't activate the dock and then you can slide over to whatever in your taskbar you want to click on...

    Thanks again, that's a great solution!
     
  13. sinsro

    sinsro Bit Poster

    Messages:
    12
    Did not work for me. Maverick / Windows 7. Its especially annoying if you use self hiding taskbar in Windows because the gesture to show it is the same as the gesture to show the mac os bar. The result is very ugly, with both bars poppung up at the same time, but the big ugly osx one is blocking the Windows one.

    Please address this issue, Parallels team, if you are monitoring the forums for user feedback.
     
  14. Scavgraphics

    Scavgraphics

    Messages:
    1

    Ok, I got this to work in Mavericks with Parallels Desktop 8 (Don't know about 9)

    Follow the above instructions AND the Additional bit: Checkmark "Use all displays in full screen."

    Screenshot 2013-12-24 15.42.36.png

    Works like a charm! Thanks for the above hints with which I'd never have figured out that.
     

Share This Page