Disable "Dynamic Resolution"?

Discussion in 'General Questions' started by IanL1, Jun 21, 2015.

  1. IanL1

    IanL1 Bit Poster

    Messages:
    13
    Is it possible? I know I can prevent guest OS resolution from changing when I go to full screen mode, but that's not what I'm after. I want to have a fixed Guest OS resolution (in this case Windows7), regardless of the Parallels window size in OS X. The specific problem in my case is that my guest OS requires a higher resolution than my host has. I can set this manually just fine, but every time I restart/resize/touch Parallels, it resets the window size to fit in the host desktop, and that resizes the guest resolution.

    All I've found so far is that it should be possible by uninstalling Parallels Tools, but does anyone know of another way to do it? For example in Fusion I found you can add commands to the preferences file (reference)
     
  2. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
  3. IanL1

    IanL1 Bit Poster

    Messages:
    13
    Hi Maria,

    Thanks for the input. The article does show which service is responsible for dynamic resolution, which would allow me to disable it. However unfortunately that only works for an OS X guest, I have a Win7 guest. I can't see a separate dynres process in Windows, only the following Parallels services:
    • coherence.exe
    • prl_cc.exe
    • prl_tools.exe
    • prl_tools_service.exe
    It doesn't appear I can selectively disable dynamic resolution without disabling the entire Parallels Tools suite.
     
  4. brkirch

    brkirch Kilo Poster

    Messages:
    415
    Try Modality (in the menu select "View" > "Enter Modality"). You then may also want to adjust the settings for Modality (to make the window not transparent and/or not display on top of other windows when in the background) by going to the VM configuration (either by clicking the gear in the upper right corner of the window or selecting "Actions" > "Configure..." from the menu) and then selecting "Options" > "Modality". If you later have the issue that the VM doesn't start in Modality then go to "Options" > "Startup and Shutdown" in the VM configuration and set "Startup View" to "Modality".
     
    Last edited: Jul 6, 2015
  5. IanL1

    IanL1 Bit Poster

    Messages:
    13
    That's an excellent solution, thinking outside the box a little. Thanks brkirch. I actually didn't know what modality mode did until you pointed it out.
     

Share This Page