Disk Clean: No space freed despite 10 GB estimate

Discussion in 'Parallels Toolbox for Mac' started by David Esp, Aug 25, 2021.

  1. David Esp

    David Esp Member

    Just now I ran Parallels (latest) Toolbox's Disk Clean on my Mac but it appeared not to live up to its promise.
    Despite its initial and scanned estimates of ~10 to 11 GB being free-able, according to Get Info of Mac's Finder, free disk space was unchanged.
    Is there an explanation for this?

    In greater detail...
    I have Parallels Toolbox 5.0.1 on macOS 10.15.7 (Catalina)
    This morning it ran, initially estimating (according to the pop-up prompt) 10 GB free-able
    Before running it, I checked system disk free space via macOS Finder: ~50 GB
    On running it, the scan estimated 11.23 GB "Ready for Cleanup"
    However on completion, the amount of free disk space, according to Finder's Get Info, was unchanged. (~50 GB)
    I got that same result immediately and also after waiting a while and rebooting.
    Intriguingly, when I ran Disk Clean a second time, it estimated only 0.5 GB free-able.
    So something's changed, but what? And why can't Finder's (System Disk) Get Info see that?
  2. David Esp

    David Esp Member

    For unknown reason, the "missing" 10 GB of expected free system drive/storage space is now present.

    Possible explanation? Anyone know?
    • While manually decluttering my system, I noticed a Desktop folder called "Old Firefox Data", size 0.5 GB. Apparently, that folder gets automatically created when Forefox is "reset". I'm guessing that when Disk Clean deleted Firefox's cache, that triggered Firefox (when next started) to reset. Maybe other apps or parts of macOS react to their files being deleted in a broadly similar way?
  3. sergk

    sergk Parallels Developers


    could you share a screenshot of Clean Drive? It is need to understand what category reports 10 Gb. Also you can click on size of category (except for Trash) and look what files are suggested to be cleared.
  4. JoyJ

    JoyJ Bit poster

    I think you probably have APFS snapshots. Run `tmutil listlocalsnapshots /`?

Share This Page