display/mouse/ Parallel Tools issue after latest Ubuntu 16.04 upgrade

Discussion in 'Linux Guest OS Discussion' started by MarkB30, Mar 18, 2019.

  1. MarkB30

    MarkB30 Bit Poster

    Messages:
    1
    Mac: 10.11.6
    Parallels: 14.1.3

    This morning I installed the latest Ubuntu update. After reboot the Ubuntu desktop reverted to low resolution. I was able to fix this by changing the screen resolution. Also the mouse cursor was not displayed, however if I switch to the MAC screen and then back to Ubuntu, the cursor did show, but disappeared after a mouse click. It did select the item that I was pointing at though.
    I attempted to reinstall Parallel tools, but it aborted saying it could not build a kernel module. Excerpt from install log below.

    make[3]: *** [/usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg/prltg_call.o] Error 1
    make[2]: *** [_module_/usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg] Error 2
    make[1]: *** [prl_tg] Error 2
    make: *** [compile] Error 2
    Error: could not build kernel modules
    Error during report about failed installation of parallels tools.
    Error: failed to install Parallels Guest Tools!
    2019-03-18T09:25:32-0400: execCmd: ./install --install [167]
    2019-03-18T09:25:32-0400: Error: An error occurred when installing Parallels Tools. Please go to /var/log/parallels-tools-install.log for more information.
    2019-03-18T09:25:42-0400: Exiting with code 1

    Any help is appreciated
    Mark
     
    WojciechC likes this.
  2. chienpo

    chienpo Bit Poster

    Messages:
    6
    I am betting/guessing that this is related to my problem:

    I also updated my Ubuntu 16.04 VM today (
    sudo apt-get update && sudo apt-get dist-upgrade -y) . After then (re-)booting my VM my shared host-OS folders weren't available.

    I went and upgraded Parallels Desktop (Business Edition) to the latest version as of today (
    2019-03-18, Monday) so that I'm now running version 14.1.2 (45479). I manually re-mounted the Parallels Tools ISO image provided (prl-tools-lin.iso) just to be sure I wouldn't have an older version mounted (and have confirmed that the "version" file in it is 14.1.2.45479. I then booted my VM back up, mounted the CD drive, became root, ran the "uninstall" command first just to be really sure I could start fresh, and then manually ran the parallels tool installation script.

    $ sudo su
    # mount /dev/cdrom /media/cdrom
    # cat version
    14.1.2.45479
    # ./install --verbose --remove

    Mon Mar 18 13:29:24 MDT 2019
    Start removal of Guest Tools
    new version of parallels tools
    Installed Guest Tools were not found
    Error: failed to remove Parallels Guest Tools!
    dpkg-query: package 'xserver-xorg' is not installed and no information is available
    Use dpkg --info (= dpkg-deb --info) to examine archive files,
    and dpkg --contents (= dpkg-deb --contents) to list their contents.
    /usr/sbin/dpkg-reconfigure: xserver-xorg is not installed

    # ./install --verbose --install
    (output in attached text/log file)

    It failed w/the error in the attached text/log file, but in summary, like the original poster, it failed while trying to compile the prl_tg kernel module, specifically when expanding the prl_get_user_pages macro to the call to get_user_pages, it is now providing too many arguments: get_user_pages(current, current->mm, _1, _2, _3, 0, _4, _5)

    My Parallels version is already listed above.
    My OS version:
    Linux devm 4.4.0-143-generic #169-Ubuntu SMP Thu Feb 7 07:56:38 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
    $ cat /etc/lsb-release
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=16.04
    DISTRIB_CODENAME=xenial
    DISTRIB_DESCRIPTION="Ubuntu 16.04.6 LTS"
     

    Attached Files:

    Last edited: Mar 18, 2019
    WojciechC likes this.
  3. zach5

    zach5 Bit Poster

    Messages:
    1
    I had this same problem but managed to get everything working again by reinstalling Parallels Tools, which required a couple changes to get it to compile and install successfully.

    Actions -> Reinstall Parallels Tools

    Copy contents to desktop, make executable, and extract kmods dir

    cp -R /media/parallels/Parallels\ Tools/ ~/Desktop/ParallelsTools/
    chmod -R 777 ~/Desktop/ParallelsTools/
    tar -xzf ~/Desktop/ParallelsTools/kmods/prl_mod.tar.gz -C ~/Desktop/ParallelsTools/kmods/


    open up file ~/Desktop/ParallelsTools/installer/install-cli.sh
    comment out line 338
    #tar -xzf "$INSTALL_DIR_KMODS/prl_mod.tar.gz" -C "$INSTALL_DIR_KMODS"
    add this line instead
    cp -Rf "$KMODS_DIR" "$INSTALL_DIR_KMODS"

    open file ~/Desktop/ParallelsTools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg/prltg_compat.h
    change line 193
    get_user_pages(current, current->mm, _1, _2, _3, 0, _4, _5)
    to this
    get_user_pages(current, current->mm, _1, _2, _3, _4, _5)

    cd ~/Desktop/ParallelsTools
    sudo ./install

    Hope this helps
     
    Last edited: Apr 11, 2019
    O_B, AndreaZ2 and RichM3 like this.
  4. AndreaZ2

    AndreaZ2 Bit Poster

    Messages:
    1
    Thank you zach5,
    your procedure worked perfectly fixing the problem in subject.
     
  5. O_B

    O_B Bit Poster

    Messages:
    2
    First - zach5. THANK YOU, THANK YOU, THANK YOU.
    This sounds like a horrible Parallels bug. Everything you perfectly suggested could be programmatically resolved by Parallels, it would seem.
    I also tried this: https://kb.parallels.com/124546 .
    Keyboard and mouse do not work in a Parallels Access remote session after upgrade to macOS 10.14
     
  6. jchapman9

    jchapman9 Bit Poster

    Messages:
    19
    More thanks to zach5 for this fix. It's now towards the end of June and problem still not fixed in latest Parallels release.
     
  7. ParallelsU284

    ParallelsU284 Bit Poster

    Messages:
    1
    I guess its fixed now..Atleast ion my system it has been fixed...And i hope in other users too..
     

Share This Page