Does Sharing option work with WiFi connection?

Discussion in 'Windows Guest OS Discussion' started by NestorH, Sep 19, 2010.

  1. NestorH

    NestorH Bit Poster

    Messages:
    28
    I normally use the default "Bridged" network connection option when using Parallels and am almost always connected via WiFi. I've using the "Shared" network option with the expectation that I would see the same IP address on both the Mac and Windows sides but instead the Windows machine just displays 0.0.0.0 as the address when I do an ipconfig query. Is this the correct way for it to function? Is there some other Windows settings I need to make? I am using Windows XP.
     
  2. Elric

    Elric Parallels Developers

    Messages:
    1,713
    Hi,

    It is actually not quite so. In SharedNetworking mode Parallels acts like a router (to be precise, like Network Address/Port translator, NAPT) between Virtual Machine and real networking. So normally the VM has address like 10.211.55.x

    The fact that Win displays 0.0.0.0 is not normal. Send a problem report using menu of Parallels Desktop "Help" -> "Report a Problem" and post here its ID if you want. We will try to understand why it occurs so.
     
  3. NestorH

    NestorH Bit Poster

    Messages:
    28
    Eric:
    I reported the problem. Problem ID # is 6802320
     
  4. Elric

    Elric Parallels Developers

    Messages:
    1,713
    Ok.. I have some more steps:
    Please switch the VM to Shared Networking and then reboot the VM (by clicking Start -> Restart). Then again -
    click Start -> Run and execute cmd.exe. Type in the appeared window command "ipconfig /all". Then, without closing the window, click Parallels Destkop menu "Help"->"Report a Problem", send a problem report (it is not necessary to provide description) and post here the report ID
     
  5. NestorH

    NestorH Bit Poster

    Messages:
    28
    Elric:
    I did as you requested. The only difference is now instead of all zeroes for an IP address, I get a self-assigned address. Problem remains the same--no Internet access. Support request code is 6802968.
     
  6. Elric

    Elric Parallels Developers

    Messages:
    1,713
    Please start the /Application/Utilities/Terminal and execute in it next two commands (will ask for the password):

    sudo mv /Library/Preferences/Parallels/parallels_dhcp_leases ~/parallels_dhcp_leases
    sudo killall -HUP prl_naptd

    then reboot the VM and check whether it have helped. If it doesn't, I can only suggest a remote session to investigate the problem directly on your computer. I'd appreciate one more problem report before the session.
     
  7. NestorH

    NestorH Bit Poster

    Messages:
    28
    Status on request code 6802968

    Elric:
    Is there anyway to check status on a request to see if it's been addressed or even on the "To Do" list?
    Thanks
    Nestor

     
  8. Elric

    Elric Parallels Developers

    Messages:
    1,713
    NestorH, have you tried steps from the post above?
     
  9. NestorH

    NestorH Bit Poster

    Messages:
    28
    Tried the steps

    Elric:
    Yes, I did and submitted the report after I ran the steps. My reply was logged earlier than the one where you had outlined the steps, so I can see how you might have thought that I hadn't. Other than the creation of a self-assigned IP address, there was no other change.
    Nestor

     
  10. Elric

    Elric Parallels Developers

    Messages:
    1,713
    I meant these steps:
    Anyway, if it will not help, I can suggest a remote session with your compute and looking at issue directly. let me know you email and timeframe if you agree. My timeframe is 8AM-5PM GMT, any working day (including today)
     
  11. NestorH

    NestorH Bit Poster

    Messages:
    28
    OK for remote session

    Elric:
    Those are the steps I ran. I am flexible tomorrow (Friday). My email address is ..... Pick a time. I'm in the US East Coast time zone, so I assume a morning session (my time) would work better for you.
    Nestor


     
    Last edited by a moderator: Oct 14, 2010
  12. NestorH

    NestorH Bit Poster

    Messages:
    28
    I'm delighted to report that Dmitry from Parallels helped me this morning and solved the problem. Turns out that the DHCP wasn't turned on in the Sharing preferences. One click and everything works! Including accessing the Internet from Windows while using an air card with Verizon.
     

Share This Page