Excessive mouse wheel acceleration in Parallels

Discussion in 'Windows Guest OS Discussion' started by tom_seddon, Aug 15, 2016.

  1. tom_seddon

    tom_seddon Bit Poster

    When running in Parallels, mouse wheel scrolling is uncontrollably fast. I've written a program to demonstrate this: https://github.com/tom-seddon/WheelDelta/blob/master/Debug/WheelDelta.exe (might require Windows 10) (source code in the repo too)

    To use, run it and twiddle the mouse wheel - you'll see the delta values being sent by the OS as part of the WM_MOUSEWHEEL message. Click the window to reset the current values.

    When running natively in Boot Camp, if I use the mouse wheel, I get delta values of +/- 120. If I spin the wheel super-quickly, I might get 240 or 360. These values translate into the sort of scrolling I'm used to when using Windows.

    When running in Parallels, on the other hand, if I use the mouse wheel, the first notch gives the expected delta value of +/- 120 - then it rather quickly ramps up to 2520. This translates into excessive amounts of scrolling in many programs. (For example, when using Visual Studio in Parallels, a short roll of the wheel will scroll by a couple of pages; when using it in native Boot Camp, that same roll would scroll just a few lines.)

    I've played with the various options in Actions > Configure, Hardware, Mouse & Keyboard, but to no avail. Whatever settings I choose, the result is always the same, and the scrolling is too fast.

    How do I fix this? I'd like the scrolling to behave the same in Parallels as it does when running natively.



    (OS X El Capitan 10.11.6; Macbook Pro (Retina, 13-inch, Early 2015); Parallels Desktop Version 11.2.1 (32626); Windows 10 Version 1607 Build 14393.51; running the Boot Camp partition. Mouse is a Microsoft Sculpt Ergonomic mouse - haven't tried any others, this is the only one I've got at the moment.)
    Last edited: Aug 16, 2016
  2. Dhana@Parallels

    Dhana@Parallels Parallels Support

    Hi tom_seddon,
    Follow the below steps & let us know how it works.
    * Open virtual machine's configuration: -> Hardware tab -> Mouse & Keyboard -> set SmartMouse to Optimize for games. Do not close configuration window.
    * Set desire mouse sensivity in Windows virtual machine: Control Panel -> Mouse Properties -> Pointer Options tab -> Select a pointer speed
    * Get back to virtual machine's configuration window. Set SmartMouse to Auto-detect for games.

    If the issue still persist, kindly reply us with problem report ID number , we will be happy to provide further assistance.
  3. tom_seddon

    tom_seddon Bit Poster

    Thanks. I followed the steps, but it made no difference. The problem report ID is 112668606.



    P.S. I was testing it today with a different mouse: a Microsoft Wheel Mouse Optical. Same excessive acceleration.
  4. Merguian

    Merguian Bit Poster

    Hello, any progress with this bug?
    I have the same problem.

Share This Page