Fedora 36 ARM on M1 Parallels Tools install fails on Error: could not build kernel modules m

Discussion in 'Linux Guest OS Discussion' started by Tokay, May 14, 2022.

  1. Tokay

    Tokay Bit Poster

    Messages:
    4
    Brand new install of Fedora 36 Workstation from iso. Parallels Desktop Version 17.1.2 (51548)
    1. Completely updated and rebooted:
      1. Linux fedora 5.17.6-300.fc36.aarch64 #1 SMP Mon May 9 15:17:42 UTC 2022 aarch64 aarch64 aarch64 GNU/Linux
    2. Installing Parallels Tools as root from the cli
    3. Fails with:
    make[1]: Leaving directory '/usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg'
    make: *** [Makefile.kmods:47: compile] Error 2
    make: Leaving directory '/usr/lib/parallels-tools/kmods'
    Error: could not build kernel modules
    modprobe: FATAL: Module prl_tg not found in directory /lib/modules/5.17.6-300.fc36.aarch64
    modprobe: FATAL: Module prl_tg not found in directory /lib/modules/5.17.6-300.fc36.aarch64
     
    binbjz likes this.
  2. Asish@Parallels

    Asish@Parallels Staff Member

    Messages:
    162
    Hello, Please refer to this KB article to install Parallels Tools manually on Fedora 36 Virtual Machine.
     
  3. Leonchik1976

    Leonchik1976 Bit Poster

    Messages:
    6
    I have exactly same issue, even if following above KB article
     
  4. Asish@Parallels

    Asish@Parallels Staff Member

    Messages:
    162
    Hello, Kindly help us with the technical report ID of Virtual Machine by referring to this KB article, so that we can instigate the issue.
     
  5. Leonchik1976

    Leonchik1976 Bit Poster

    Messages:
    6
    Report ID = 398301434
     
  6. MathewM1

    MathewM1 Bit Poster

    Messages:
    5
    Parallels Tools 17.1.2 was not compatible with Linux 5.17 kernels. An update to 17.1.3 was just released and that appears to work fine.
     
  7. Leonchik1976

    Leonchik1976 Bit Poster

    Messages:
    6
    н
    yes, worked for me also after upgrading to 17.1.3
     
  8. Asish@Parallels

    Asish@Parallels Staff Member

    Messages:
    162
    Hello guys, We are glad to hear that the issue got resolved after updating the Parallels Desktop v 17.1.3.
     
  9. JohnB101

    JohnB101 Bit Poster

    Messages:
    1
    Hi, this worked for me as well. I'm a bit of a newb so it wasn't the easiest thing to do, but https://kb.parallels.com/en/121370 worked. Step 4: Right-click and show package contents. Step 5: Received an error that I didn't have permissions to mount even with Sudo, but I proceeded anyhow. Step 6b: did not display items with "*". Step 7: Still proceeded with the above issues and it worked! Thanks to all above!
     
  10. Marcelv9

    Marcelv9

    Messages:
    1
    Hello, I have the same error codes as reported by TonyK9 above. Running Fedora 36 arm on Apple M1 Ultra. I tried installing according to KB article (except selected the arm .iso file as the x64 version of course doesn't work). Also had Parallels 17.1.3 installed which I have now upgraded to 17.1.4 without any change. It just comes back with a log file which has loads of errors ending with the ones Tony listed above. Any help would be much appreciated
     
  11. TaoW

    TaoW Bit Poster

    Messages:
    1
    fatal error when install parallels tools to Fedora 36, linux kernal version 5.18
    Parallels desktop Version 17.1.4 (51567)
     
    binbjz likes this.
  12. Leonchik1976

    Leonchik1976 Bit Poster

    Messages:
    6
    Yes, the same
     
  13. ChadH5

    ChadH5 Bit Poster

    Messages:
    1
    Same issue - Parallels desktop Version 17.1.4 (51567) with Fedora 36.
     
    HaziqueQ and binbjz like this.
  14. binbjz

    binbjz Bit Poster

    Messages:
    3
    Same issue - Parallels desktop Version 17.1.4 (51567) with Fedora 36. Please fix this issue asap, thanks.
     
    HaziqueQ likes this.
  15. VolkerH5

    VolkerH5 Bit Poster

    Messages:
    1
    Same issue - Parallels desktop Version 17.1.4 (51567) with Fedora 36. Please fix this issue, thanks.
     
    HaziqueQ likes this.
  16. binbjz

    binbjz Bit Poster

    Messages:
    3
    Same issue - Parallels desktop Version 17.1.4 (51567) with Fedora 36.
     
  17. jklepach

    jklepach Bit Poster

    Messages:
    3
    Same here. Please fix
     
  18. lavandula

    lavandula Bit Poster

    Messages:
    1
    Same issue here with Parallels Desktop Version 17.1.4 (51567) on Kali 2022.2 Kernel 5.18.0-kali5-arm64
     
  19. MatteoCorti

    MatteoCorti Bit Poster

    Messages:
    6
    Same here (also for Centos Stream 9)
     
  20. HaziqueQ

    HaziqueQ

    Messages:
    1
    Same issue - Parallels desktop Version 17.1.4 (51567) with Fedora 36
     

Share This Page