Gaming with Parallels Desktop in macOS Sonoma and AirPods Pro

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by CarstenK7, Nov 17, 2023.

  1. CarstenK7

    CarstenK7 Bit poster

    Hello everyone :)
    I use a 21 14" MBP with M1 Pro and like to play with it via Parallels Desktop.
    I always had an annoying audio delay with my AirPods Pro (2nd Gen), which no longer occurs in in-house games thanks to Game Mode in Sonoma.
    Unfortunately, Parallels Desktop does not trigger Game Mode and it cannot be activated manually.

    Does anyone know a workaround how I can trick the system into thinking that it sees Parallels as a game and activates game mode?
    I've tried running a low-resource Mac game in the background, but Game Mode always "pauses" as soon as the game is no longer in the foreground.

    Can someone help?? :)
    MatthewR20 likes this.
  2. JoannaM


    Have you sought any ways to trigger Game Mode within Windows 10? I'm having a similar problem but need to switch Game Mode off, but as you say - Game Mode does not appear under the Gaming side bar via Parallels to make a manual change.
    There is a way to add adjust your settings in Window 10 to add a "key" that forces Game Mode on detailed in this page. Good luck!

Share This Page