Google Chrome black screen on ubuntu 18.04

Discussion in 'Linux Guest OS Discussion' started by HannuV, May 13, 2019.

  1. HannuV

    HannuV Bit Poster

    Messages:
    4
    Any ideas how to solve the black window issue? This used to work fine until the most recent Ubuntu/Chrome upgrades about three weeks ago. (parallels 14.1.3, Ubuntu 18.04 all recent patches installed, Google Chrome up to date (74? Cannot see as the window is black).

    When I start Chrome with --no-gpu option, it works fine but is ridiculously slow.

    How do I resolve this?
     
    Tres Finocchiaro likes this.
  2. Jabberwacky

    Jabberwacky Bit Poster

    Messages:
    3
    Same here :( I always used Chrome in my Ubuntu in Parallels, but since a couple of days the window is black. Uninstalling and re-installing did not help. Google Chrome.png
     
    Tres Finocchiaro likes this.
  3. MinhN2

    MinhN2 Bit Poster

    Messages:
    1
    Run Chrome with --use-gl=angle fix for me.
     
    Tres Finocchiaro likes this.
  4. HannuV

    HannuV Bit Poster

    Messages:
    4
    --use-gl=angle does fix the problem but it also makes Chrome ridiculously slow. In the log messages I can see it then fails to initialise 3d acceleration.

    It has now been awhile. New Ubuntu versions, new Chrome versions but the problem still persists. It seems like Parallels related to me.
     
    Tres Finocchiaro and PaulS42 like this.
  5. HiroakiS1

    HiroakiS1

    Messages:
    1
    Set 3D acceleration off fix for me. It's located under located under Graphics Settings in Parallels configuration.
     
    Tres Finocchiaro likes this.
  6. PaulS42

    PaulS42 Bit Poster

    Messages:
    2
    The problem is that it not only happens with Chrome, it happens with VS Code as well. Also I used 3D accelerated apps so cannot turn this off as a fix.
     
    Tres Finocchiaro likes this.
  7. MarkC35

    MarkC35

    Messages:
    1
    Chrome and VS Code worked on 18.04 for me yesterday. Did not work after upgrading to 19.10 today. Workaround was to disable 3D acceleration, but I'd rather not do that.
     
    Tres Finocchiaro likes this.
  8. Tres Finocchiaro

    Tres Finocchiaro Bit Poster

    Messages:
    21
    The following seems to work on Parallels + Ubuntu 18.04:


    Code:
    google-chrome --use-gl=swiftshader
    
    Note, this also fixes an identical issue with Microsoft Edge Beta Channel for Linux:

    Code:
    microsoft-edge --use-gl=swiftshader
    
     
  9. Tres Finocchiaro

    Tres Finocchiaro Bit Poster

    Messages:
    21
    Turns out, --disable-gpu is better, you can get to menus and stuff...
    Code:
    google-chrome --disable-gpu
    
    Code:
    microsoft-edge --disable-gpu
    
     
  10. Tres Finocchiaro

    Tres Finocchiaro Bit Poster

    Messages:
    21
    Then, once loaded, go into Settings, search for "Hardware acceleration" and toggle it off.
     

Share This Page