Hide Menu not working - Multiple Monitors

Discussion in 'Parallels Toolbox for Mac' started by TimothyC7, Dec 29, 2020.

  1. TimothyC7

    TimothyC7 Bit Poster

    Messages:
    4
    Glad to see that Hide Menu is supposed to now be working under Big Sur, but it's not working with my monitor setup. I used it a lot before Big Sur.

    I have two large monitors side by side with a MacBook Pro 2018 monitor centered below them. The system menu bar is on the laptop screen, so there's no "edge" above it which may have something to do with the issue.

    With the 4.1.1 update, Hide menu will now show up in the menu bar when opened, but won't show the "hidden" menu bar. Preferences work fine for configuration, but I can't use Hide Menu in my normal configuration. It does work (albeit with a lag - it's slow) if I relocate the system menu bar to one of the upper monitors so that there is an "edge" above it. Hide Menu used to work fine with the system menu on the laptop under Catalina and earlier versions of Parallel Tools.
     
    ChrisM49 likes this.
  2. ChrisM49

    ChrisM49 Bit Poster

    Messages:
    1
    I was also huge fan of this tool before Big Sur, so I was excited when Parallels rolled out the update that was supposed to make it work in Big Sur. Unfortunately, I don't think it's ready for primetime!

    In my setup, the Hide Menu Icons button is displayed in my primary Visible Icons menu bar, but once I press it to reveal my hidden icons, there's no way to dismiss them; it makes my primary menu bar icons inaccessible (which is kind of a big deal!). The revealed hidden icons don't dismiss as they're configured to in the Hide Menu Icons configuration and the Hide Menu Icons button is not visible when the hidden icons are revealed, so I'm just stuck with my secondary icons.

    Setup: MacBook Pro in clamshell mode with an ultrawide monitor next to a pair of cloned 1080p monitors.
    upload_2020-12-31_9-16-20.png
     
  3. Alex Patsay

    Alex Patsay Parallels Team

    Messages:
    216
    Hi all,
    Thank you for your feedback. Yes, Apple changed a lot in a way how Mac menu bar works, and we had to rewrite Hide Menu Icons tool from scratch, so there might be some issues caused by that. Can you both generate technical data report and post report IDs here, so we can take a look at these issues? I have an external display connected to my MacBook Pro, but couldn't reproduce the issue. Thanks!
     
  4. TimothyC7

    TimothyC7 Bit Poster

    Messages:
    4
    See Report ID 358685666
     
    ChrisM49 likes this.
  5. Alex Patsay

    Alex Patsay Parallels Team

    Messages:
    216
    Thank you, I filed the issue for the team to investigate.
     
  6. TimothyC7

    TimothyC7 Bit Poster

    Messages:
    4
    Any updates on this issue?
     
  7. sergk

    sergk Parallels Developers

    Messages:
    502
    We're still working on it.
     
  8. TimothyC7

    TimothyC7 Bit Poster

    Messages:
    4
    Unfortunately, the Parallels Toolbox 4.5 update did not fix this problem for me. :(
     
  9. sergk

    sergk Parallels Developers

    Messages:
    502
    Yes, 4.5 doesn't contain fix for Hide Menu Icons issues. The problem is quite complex and we're continue working on it.
     
  10. PengH1

    PengH1 Bit Poster

    Messages:
    3
    See Report ID 367996002
     
  11. Doug Starkey

    Doug Starkey Bit Poster

    Messages:
    1
    See Report ID 370089242
    Just upgraded to OS X 11.4 and, like other have mentioned, Hide Menu Icons is not working for me. Really miss it because I have a LOT of menu icons, many of which I only use occasionally but when I need them, I need them. Plus, my menu bar fills up and many of the icons are totally unavailable with out Hide Menu Icons. So, here's hoping you get this fixed soon!
     

Share This Page