Host keyboard not working after resuming from sleep

Discussion in 'Windows Guest OS Discussion' started by NathanaelB1, Dec 27, 2016.

  1. NathanaelB1

    NathanaelB1 Bit Poster

    Messages:
    6
    I have a MacBook Pro running El Capitan as a host OS and Windows 8 as a guest OS under Parallels 12. After the most recent update (Parallels 12.1.1 41491), I've been having a small but frustrating issue. I use Parallels in Full Screen mode.

    Anytime I wake my laptop from standby or sleep, the keyboard does not work in OS X until I switch over to my VM desktop and switch back. This only happens when Parallels is running.

    Any suggestions on how to fix this?
     
  2. Raj@Parallels

    Raj@Parallels Guest

    Messages:
    467
    Is it internal Mac or any external keyboard?
    Please check whether keyboard layout mapped correctly in Windows virtual machine.
    And try reinstalling Parallels Tools http://bit.ly/1cZWAa3 and keep us posted, how it works.
     
  3. NathanaelB1

    NathanaelB1 Bit Poster

    Messages:
    6
    This problem occurs with both an external keyboard and the built-in keyboard. When resuming from sleep, no keyboard input works until I switch over to my VM and then back to OS X.

    I checked the keyboard layout and removed everything except the default US input method. I also tried reinstalling Parallels Tools, but the problem still exists.
     
  4. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,682
    Hi, and which keyboard are you using? USB or magic keyboard?
     
  5. NathanaelB1

    NathanaelB1 Bit Poster

    Messages:
    6
  6. MarkL10

    MarkL10

    Messages:
    1
    I have this exact issue. Glad to learn that switching to my VM and back fixes it - better than suspending and restarting. When it doesn't work, it does not matter if I'm using the built-in keyboard of my external one (Microsoft Natural Keyboard 4000 USB). I usually find out it's to working by starting the Launcher and the search not doing anything, or trying to enter an address in Safari.
    • Parallels Version 12.1.3 (41532)
    • macOS 10.12.3 (16D32) on MacBookPro11,3
    • Windows 10 Pro 1607 14393.693.
    I'd love to see this fixed.
     
  7. NathanaelB1

    NathanaelB1 Bit Poster

    Messages:
    6
    Yep, before I figured it out I spent a lot of time wondering why Chrome wasn't responding to my typing. Pretty frustrating.

    I forgot to include my detailed specs in my original message, so here they are:
    • Parallels Pro 12.1.3 (41532)
    • macOS El Capitan 10.11.6
    • Windows 8.1 Pro
     
  8. MichaelF13

    MichaelF13

    Messages:
    1
    I just wanted to add to this thread that I also have this problem. I had figured out the switch to the vm and switch back but it is still frustrating.
    • Parallels Pro 12.1.3 (41532)
    • macOS El Capitan 10.11.6
    • Windows Server 2012 R2 Standard
     
  9. DenisS3

    DenisS3 Bit Poster

    Messages:
    17
    I'm also having this problem now.
     
  10. Hemnath@Parallels

    Hemnath@Parallels Parallels Support

    Messages:
    1,128
    @NathanaelB1, @MarkL10, @MichaelF13 and @DenisS3, please reproduce the issue and, while the issue is present, generate a Problem Report ID and include the same in your replies. We'll then investigate the issue further.
     
  11. RobS7

    RobS7 Bit Poster

    Messages:
    6
    I'm having the same issue. Was this ever solved?
     
  12. Hemnath@Parallels

    Hemnath@Parallels Parallels Support

    Messages:
    1,128
    Hello @RobS7, the said issue is still under investigation. Have you already attempted the troubleshooting steps mentioned in this thread? If yes and if the issue persists still, then please reproduce it and, while it's present, generate a Problem Report ID and include the same in your reply. This will be very useful for us to be able to investigate the problem further.
     
  13. RobS7

    RobS7 Bit Poster

    Messages:
    6
    i don't have toolbox installed and i don't have the "US" option shown in the keyboard layouts link (running windows 10) so I cannot remove the United States (Apple)-Parallels language option as shown

     
  14. RobS7

    RobS7 Bit Poster

    Messages:
    6
    any movement on this issue?
     
  15. Hemnath@Parallels

    Hemnath@Parallels Parallels Support

    Messages:
    1,128
    This issue doesn't concern Parallels Toolbox (which is different from Parallels Tools).
    Please share a screenshot of this scenario.
     
  16. OlofS

    OlofS Bit Poster

    Messages:
    2
    I have the same issue, running Mac OS Mojave and parallels version 14.1.3. Have to unplug keyboard and plug it back in to get it to work. Any solutions?
     
  17. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,682
    Hi, when this issue reoccurs, maybe when you work with specific application?
     
  18. OlofS

    OlofS Bit Poster

    Messages:
    2
    Well, I work with very basic applications, such as outlook, excel, chrome etc. At least one is almost always open.
     

Share This Page