Host-Only Adapter refuse to accept 172.23.255.0/24

Mathias_Klette

Bit poster
Hi,
I'm currently struggling with host-only network configuration for Parallels 10: We used to use network 172.23.255.0/24 for our Vagrant based development vm's. This is running totally fine with VirtualBox provider. However, trying to setup host-only networking with the same data in Parallels results in an error stating my DHCP range would be invalid. 172.23.254.0/24 works perfectly. I don't think it's a conflict with VirtualBox' network, as even 192.168.255.0/24 fails with the same error. All those ranges are valid choices for a private network according to what I understand from RFC 1918. Further, VirtualBox accepts it, so I'd assume it's neither a general or MAC specific issue..

Does anyone else encounter such an issue, too? Or, does anyone has a clue what error I miss or what to look for to enable that particular network?

Thanks in advance!
Mathias
 
Hi, Mathias!
trying to setup host-only networking with the same data in Parallels results in an error stating my DHCP range would be invalid.
Thanks for reporting this problem, but could you please provide an error message you have (and "private_network" configuration from Vagrantfile if possible)?

I've just reproduced it in this way:
Code:
$ prlsrvctl net add vagrant-vnet1 --ip 192.168.255.1/255.255.255.0
Failed to add Virtual Network vagrant-vnet1: The server IP address is invalid. Make sure that the IP address assigned to the Parallels server adapter is correct and try again. If the error persists, contact the Parallels support team for assistance.
 
Back
Top