how to disable secure boot in windows 11

Discussion in 'Windows Virtual Machine' started by SriramM, Sep 8, 2023.

  1. SriramM

    SriramM Bit poster

    Messages:
    1
    hello

    i am using Macbook pro running ventura 13.5 , using parralles desktop for mac with windows 11. i need to test with some apps and drivers. i need to disable secure boot. i enter the settings at startup, i cant change enable to disable. Attempt secure boot cant be changed. please help me how to change it
     
    TimB30 likes this.
  2. TimB30

    TimB30 Bit poster

    Messages:
    1
    I have same problem
     
  3. RobertoB15

    RobertoB15 Bit poster

    Messages:
    6
    I've the same problem.
     
  4. PedroG10

    PedroG10 Bit poster

    Messages:
    1
    I have the same problem, any update on this ?
     
  5. Mikhail Ushakov

    Mikhail Ushakov Parallels Team

    Messages:
    471
    Hello!
    To disable Secure Boot, perform the steps below:
    1. Shut down the virtual machine (Actions > Shut down).
    2. Open its preferences as per https://kb.parallels.com/117287 > Hardware > Boot Order > Advanced Settings.
    3. Paste the following system flag:
    vm.efi.secureboot=0
    4. Start the virtual machine.
     
    Larbac likes this.
  6. Larbac

    Larbac Bit poster

    Messages:
    3
    Thank you. This worked. This disabled secure boot in Win11 and let me run kdnet.
     
    Mikhail Ushakov likes this.
  7. LeRoi

    LeRoi Member

    Messages:
    61
    2. Open CONFIGURE
    Select Hardware > Boot Order > Advanced Settings.
    You can save a bit of time by shutting down the virtual machine, open Control Center, right click on the machine you want to change. Select Configure and then follow the above steps. You will need your Security Recovery Key which you can find at aka.ms/myrecoverykey. When the VM restarts, you will need to input the recovery key to activate Secure Boot.
     

Share This Page