How to open internet links in Mac?

Discussion in 'Windows Virtual Machine' started by LaurentP1, Sep 9, 2023.

  1. LaurentP1

    LaurentP1 Bit poster

    Messages:
    3
    Hi,
    I would like to open internet links from my Win11 virtual machine on Chrome which is my default browser in Mac.
    I searched and found the following instructions
    Set Windows to Always Open Links in macOS
    To set all links that you click in Windows to always open in macOS, do the following:
    In Windows, click the Start button > Settings > Apps > Default apps.
    In search bar type Safari or any macOS browser:
    But neither Safari nor Chrome Mac are showing. Only Windows browsers are showing.
    Any idea why they are not recognized ?
    Thx !
     
  2. LaurentP1

    LaurentP1 Bit poster

    Messages:
    3
    BTW I'm running Parallels Desktop 16 on Mac Mini 2018
     
  3. Ashley Chumun

    Ashley Chumun Staff Member

    Messages:
    129
    Hello Laurent,
    Thank you for your feedback.
    To let us better understand the situation, please perform the following steps:
    1. Reproduce the issue.
    2. Collect a technical report (click Parallels icon on top of the mac menu bar > Help > Send technical data > check "Attach screenshots..." > press Send Report) and send the report's 9-digit ID in a reply to this message.
    3. Reinstall Parallels Tools (While the virtual machine is running > click on "Actions" menu on top of the Mac menu bar > Select "Reinstall Parallels Tools"
    4. Restart the virtual machine > try to search "Google Chrome (Mac)" in the Defaults apps menu and set is as default.
    Please let us know the results.
    Thanks!
     
    NormanO1 likes this.
  4. LaurentP1

    LaurentP1 Bit poster

    Messages:
    3
    Thank you !
    report ID : 435850185
    I did 3 & 4 but that didn't change anything
     
  5. Ashley Chumun

    Ashley Chumun Staff Member

    Messages:
    129
    Hello Laurent,
    Thank you for your feedback.
    From the Technical report we noticed that "Share Host Apps" is disabled and this is the main cause of your issue.
    Please follow the steps below to enable it:
    1. Shutdown your Virtual Machine (Click "Actions" Menu on top of the Mac menu bar > Select "Shutdown")
    2. Click on the Parallels Icon on top of the Mac menu bar > Select "Control Center"
    3. Right-Click on your "Windows 11" virtual machine > Select "Configure"
    4. Navigate to the "Options" tab > Select "Applications" > Tick "Share Mac applications with Windows" > Close the configuration window.
    5. Launch the Windows 11 virtual machine > Try to reproduce the issue.
    6. If the issue still persists > Reinstall Parallels Tools (While the virtual machine is running > click on "Actions" menu on top of the Mac menu bar > Select "Reinstall Parallels Tools" > Restart the virtual machine.
    In case the above didn't solved your issue > Please generate an additional technical report.
    Thank you!
     

Share This Page