How to share files between MacOS and guest Linux OS in Parallels WITHOUT Parallels tools?

Discussion in 'Linux Guest OS Discussion' started by JeremyW11, Dec 8, 2021.

  1. JeremyW11

    JeremyW11 Bit Poster

    Messages:
    1
    Hello! I have Linux installed as a guest operating system in Parallels, and I would like to be able to mount my MacOS user home directory (or parts of it) within Linux. The catch is I need to do it WITHOUT using Parallels Tools because I can't get Parallels Tools to install successfully. (mostly due to non-standard Linux distros like Void or NixOS)

    The things I have tried so far, but haven't worked the way I want are:
    • mounting my MacOS home directory with cifs/smb. The problem here is that I lose individual file/directory permissions, and instead everything gets the blanket setting used by the mount command. (read/write/execute for everything) I need things like executable bits on shell scripts to be correctly updated in MacOS when I change them from Linux
    • mounting my MacOS home directory with sshfs. Here the problem seems to be that certain directories aren't mountable by my regular linux user, or I can't seem to be able to mount more than 2 directories, and the 3rd one just hangs. (example, if I mount my Documents and Downloads MacOS directories to equivalent directories in Linux, they may work just fine, but when I try a third, such as my MacOS ~/bin directory, that one hangs up and won't mount unless I do it as root. But if I change the order and mount bin and Documents first, then Downloads won't mount without root.)
    If anyone knows how to solve the problems with either of the above two methods, or has good information on a different method, I'd love to hear it. Thanks!
     

Share This Page