Installation Agent error "update is not required" appears every time VM resumes

Discussion in 'Mac OS X Guest OS Discussion' started by whitedb, Nov 28, 2020.

  1. whitedb

    whitedb Bit Poster

    Messages:
    4
    Hi I have just upgraded to Parallels 16.1.1 from V15, did the tools updates etc. Now every time I start/resume my Snow Leopard Server VM, a window appears as below - "Parallels Tools update is not required".
    Under Version 15 I did not have the problem and I don't get it with Sierra, High Sierra or Windows 10 VM's. I tried re-installing Parallels tools but it made no difference. Any suggestions on how to get rid of it?
    Thanks.
    Screen shot 2020-11-28 at 23.16.53.png
     
  2. RobertaL

    RobertaL Bit Poster

    Messages:
    2
    Did you ever find a solution to this problem? I have exactly the same problem, also running Snow Leopard Server VM in the most recent Paralllels.
     
  3. whitedb

    whitedb Bit Poster

    Messages:
    4
    Not yet. I and working with Parallels technical support and have just sent them the problematic VM for their developers to look at it. I will post back what I hear from them.
     
  4. RobertaL

    RobertaL Bit Poster

    Messages:
    2
    Thank you!
     
  5. warnergt

    warnergt Bit Poster

    Messages:
    44
    I get this too with Parallels 16.1.3.
     
  6. whitedb

    whitedb Bit Poster

    Messages:
    4
    OK so for those who have the same problem, I finally got a fix from Parallels support just this week. The solution is as follows:
    1. In the virtual machine, open Terminal (Applications > Utilities > Terminal) and execute the following command:
    sudo rm -rf ~/Library/Preferences/com.parallels.iagent.plist
    (You will need to enter your Mac password to run the command. No symbols will be shown due to security measures, so just hit the keys and use Return/Enter.)
    2. Restart the virtual machine
    This worked for me and continued to work after the latest Parallels update to Version 16.1.3 (49160)
    I hope it solves your problems to.
     
  7. JosephA9

    JosephA9 Bit Poster

    Messages:
    1
    Thank you so much for working this issue AND posting the fix! I think it might only be and issue for us Snow Leopard users, but whatever it is, the fix worked!
     

Share This Page