Installation BUG "Could not access VBScript run time..."

Discussion in 'Installation and Configuration in Windows and Linux' started by mikebridge, Dec 15, 2011.

  1. mikebridge

    mikebridge

    Messages:
    3
    I'm getting an error "Error 2738.Could not access VBScript run time for custom action ." when trying to install Parallels 6 on a Windows 7 64 bit machine.

    Looks like this has been a problem for several years with no resolution.

    http://forum.parallels.com/showthread.php?t=95469
    http://forum.parallels.com/showthread.php?t=104131&page=4

    Neither of the KB articles appear to address this on Windows 7:

    http://kb.parallels.com/en/5736
    http://kb.parallels.com/en/6891

    I tried this (similar to KB) but I don't have that registry key:

    http://blogs.msdn.com/b/astebner/archive/2007/06/07/3151752.aspx

    Anyway, I HAVE VBScript installed on my machine, and I don't feel comfortable changing the registry in order to work around what appears to be a longstanding bug in Parallels.

    I don't seem to be able to contact support without being a customer first. Sorry, but day one with Parallels has been a pretty negative experience. Any idea what to do?

    EDIT:

    I am installing as Administrator, as per the documentation.
     
    Last edited: Dec 15, 2011
  2. brmovem

    brmovem

    Messages:
    23
  3. mikebridge

    mikebridge

    Messages:
    3
    Thanks, but a) that advice clearly applies to Windows XP, and as I mentioned I'm running Windows 7, and b) VBScript is already installed correctly on my Windows 7 system, as I also mentioned.

    Have you actually tried doing this, or do you know of a reason why this is the correct answer for Windows 7? I'm worried that reinstalling VBScript for the wrong version of Windows could make things worse.

    Like I say, VBScript runs fine on my machine. It appears to me to be a bug in the Parallels installation.

    Thanks,

    -Mike
     
  4. TrevorJ

    TrevorJ

    Messages:
    1
    I had the same issue, but resolved it..

    Same kind of set up - Workstation 6 on Windows 7 (32bit)
    This is what I did.. essentially re-registering vbscript.

    (after much hunting in the FAQ's / Forums, the steps below taken from another users post and renumbered)
    I did not download anything.

    1. Hit -> Start -> Type in Run box: regedit hit ENTER

    2. This opens up the registry editor. You are going to look for the following:
    For 32 bit Windows 7 HKEY_CURRENT_USER -> CLASSES -> CLSID -> { B54F3741-5B07-11CF-A4B0-00AA004A55E8}.
    For 64 bit Windows 7 HKEY_CURRENT_USER -> CLASSES -> Wow6432Node -> CLSID -> { B54F3741-5B07-11CF-A4B0-00AA004A55E8}.

    3. Right Click on { B54F3741-5B07-11CF-A4B0-00AA004A55E8} and hit DELETE. Confirm this delete by hitting Okay.

    4. Now go to Start -> Type in the Run box: cmd

    5. A command console will come up. Type in: regsvr32 vbscript.dll and hit ENTER

    6. A box will come up saying DLL was registered. Click Okay.

    7. In the Command Window type exit hit ENTER

    8. Re-try installing the application on Win7.

    Hope this helps..
     
  5. mikebridge

    mikebridge

    Messages:
    3
    Hi Trevor,

    Thanks for the response, but I have long given up on Parallels. Unfortunately, they refused to answer my installation support requests until I purchased---which I didn't want to do until I could see if it was going to work on my machine.

    On principle, I don't particularly feel comfortable paying a company to fix its own bugs so I can evaluate their software. I had to move on to the competition.

    Thanks anyway though---hope it helps someone else.

    -Mike
     
  6. MLittleR

    MLittleR

    Messages:
    37
    Greetings all,

    This issue has nothing to do with Parallels, something inside Windows screwed up your system, might be antivirus
    (please use google if you do not believe me).
    You need to do the following:

    1. Open Registry Editor (Start -> regedit)
    2. Need to verify key values: where @ - the default value:
    For 32bit:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{3F4DACA4-160D-11D2-A8E9-00104B365C9F}\InprocServer32] @="C:\\Windows\\system32\\vbscript.dll"
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{B54F3741-5B07-11cf-A4B0-00AA004A55E8}\InprocServer32] @="C:\\Windows\\system32\\vbscript.dll"
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{B54F3742-5B07-11cf-A4B0-00AA004A55E8}\InprocServer32] @="C:\\Windows\\system32\\vbscript.dll"
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{B54F3743-5B07-11cf-A4B0-00AA004A55E8}\InprocServer32] @="C:\\Windows\\system32\\vbscript.dll"

    For 64bit
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Classes\CLSID\{3F4DACA4-160D-11D2-A8E9-00104B365C9F}\InprocServer32] @="C:\\Windows\\SysWOW64\\vbscript.dll"
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Classes\CLSID\{B54F3741-5B07-11cf-A4B0-00AA004A55E8}\InprocServer32] @="C:\\Windows\\SysWOW64\\vbscript.dll"
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Classes\CLSID\{B54F3742-5B07-11cf-A4B0-00AA004A55E8}\InprocServer32] @="C:\\Windows\\SysWOW64\\vbscript.dll"
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Wow6432Node\CLSID\{B54F3743-5B07-11cf-A4B0-00AA004A55E8}\InprocServer32] @="C:\\Windows\\SysWOW64\\vbscript.dll"

    If the values ​​are different, then you need to edit them, you will likely need to change the permissions first.

    3. Check the same in HKEY_CURRENT_USER.

    Once again this is Windows issue!
     
  7. Frames

    Frames

    Messages:
    3
    Error 2738 could not access VBScript ....

    I DO NOT AGREE.

    Exactly same thing happened on me yesterday. I'm on Parallels Desktop v7 and Windows7Pro.
    My Parallels Desktop was working fine. No errors whatsoever until I accept an automate update.
    After update installed, every time I started Parallels Desktop I got this error, Error 2738 could not access VBScript ....

    I emailed support team and received a response which leads no fixes.
    Only one solution to fix this is, uninstall the whole Parallels Desktop and reinstall.
    This is only fix.

    This is real pain. Every time update something, exactly same thing happens.
     
  8. MLittleR

    MLittleR

    Messages:
    37
    I bet reinstalling Parallels Desktop will not help. The VBScrip-error means that some of your Windows registry entries were corrupted, so reinstalling PD will no do the trick!
    You can perform Windows 7 Repair Install: http://www.sevenforums.com/tutorials/3413-repair-install.html
    this will help.
     
  9. Frames

    Frames

    Messages:
    3
    You lost.
    Read my previous post. My machine worked fine until I accepted the automatic updating and installed.
    Last night, I uninstalled whole of Parallels Desktop and reinstalled. Now, Working perfectly fine.

    Nowadays I don't use Parallels Desktop not that often but use a proper PC notebook.
    So for many you out there who uses Parallels Desktop as a main PC, my suggestion won't be practical.

    Good luck!!
     
  10. aharonm

    aharonm

    Messages:
    1
    MLittleR thanks!
    That solved my problem!!!
     
  11. Barticus62

    Barticus62

    Messages:
    1
    MLittleR - after hours of frustration, following your instructions solved the problem - thank you! [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{B54F374 1-5B07-11cf-A4B0-00AA004A55E8}\InprocServer32] was the problem in my case, the default value containing the string "mcafee" before I edited it as per your instructions. I've never been in the registry before and hope never to have to again, being a novice who just wants the kit he buys to work as described on the box.

    A plea to Parallels: MLittleR may well be spot on that this is a problem with Windows, but I for one came within a hair's breadth of taking my software back to the shop for a refund. Given that it's a common, known problem with a known solution that is WAY beyond the capabilities of a typical user to understand and fix, surely it would make sense for you to be up-front about it and even provide a patch/fix or whatever you call it to save other hapless novices having to go through the same grief. Otherwise, your product looks amazing and I'm now looking forward to being able to get the full benefit of it.
     
  12. KimHuff

    KimHuff

    Messages:
    1
    MLittleR,

    I hope you can help me. I am not actually using Parallels, but trying to install software on my computer and I am getting the same VBScript error 2738. I know it is some issue with the Windows Reg file, but I am unable to edit or delet the registry edit file in question. Do you have any suggestions that can help me.

    Thank you,

    Kim
     

Share This Page