Internal dummy connection

Discussion in 'Installation and Configuration in Windows and Linux' started by MarekStejskal.cz, Nov 28, 2011.

  1. MarekStejskal.cz

    MarekStejskal.cz

    Messages:
    1
    How to disable "dummy internal connection" requests ?

    Apache2 - how to disable "dummy internal connection" requests ?


    /var/log/apache2/access.log
     
    Last edited: Nov 30, 2011
  2. shanjoyb

    shanjoyb

    Messages:
    48
  3. RonaldBarlowR

    RonaldBarlowR

    Messages:
    1
  4. samanp

    samanp

    Messages:
    1
    Not without changing mpms. But they are there for a good reason and
    they do no harm, so why bother? (If this is causing problems for your
    log analysis tools, then you have lousy log analysis tools



    http://www.irandream.com
     
  5. andrewthomus

    andrewthomus Banned

    Messages:
    1
    thank you!!

    thank you for your suggestion. "Internal dummy connection" problem was also threatening me a lot.I have tried a lot for it . and i got the enough detail on this here.
     
  6. VikArgoo

    VikArgoo

    Messages:
    1
    I personally would be great to change, the same data error. I'm working on outsourcing software development, and for me this is very critical. Thanks for the link, I'll see its.
     
  7. FutureW2

    FutureW2 Bit Poster

    Messages:
    1
    Please help me to cop up with the same. 'How to disable "dummy internal connection" requests ?' .
    I am frustrated with the same. Please help me. Thanks in advance.
    https://futureworktechnologies.com/

     
    Last edited: May 23, 2018
  8. TorahB

    TorahB Bit Poster

    Messages:
    2
    hank you so much for these tips and links. I found really useful information there.
     
  9. TorahB

    TorahB Bit Poster

    Messages:
    2
    This post is from 2011, but it still has merit.
     
  10. MayG

    MayG Bit Poster

    Messages:
    1
    I'm unfamiliar with what MPM is doing this,

    Every MPM using POD (pipe of death). It's defined in /server/mpm_common.c:

    | This function connects to the server, then immediately closes the
    | connection.
    | This permits the MPM to skip the poll when there is only one listening
    | socket, because it provides a alternate way to unblock an accept()
    | when the pod is used.


    BTW to OP: No, downgrading to 2.0 won't help; the function dummy_connection exists in the 2.0 branch, too. The only difference is that it is not logged as "internal dummy connection".
     
    Last edited by a moderator: Nov 25, 2020
  11. johnsciflare

    johnsciflare Bit Poster

    Messages:
    1
    It seems this feature exists in the whole 2.x series so a downgrade to 2.0 would not solve this issue. It's just in versions prior to 2.2.0 there was no indication of such internal requests. People proposed switching to Worker MPM. However, some claim on 2.6.x boxes (my case) Prefork MPM runs faster. Additionally, PHP is not thread-safe by default (Worker MPM is thread based) and it should be compiled with Zend Thread Safety libraries (-enable-experimental-zts). I don't think it's worth... It would be great if there was a way to switch back to the old behaviour on platforms that support it... it's odd otherwise. Now I've disabled the logging for the default website and I've left mod_redirect (as I don't think Apache would follow redirects internally).

    Other than this I Have No idea about this error.
     
    Last edited by a moderator: Mar 23, 2021
  12. Idea Usher

    Idea Usher

    Messages:
    1

Share This Page