Keyboard layout problem with 2X/ChromeOS

Discussion in 'Parallels Client for Google Chrome' started by thargon, Feb 28, 2014.

  1. thargon

    thargon

    Messages:
    1
    Hello! I think there is a problem with keyboar layout switching in remote session:
    After connect to remote computer, I can switch layout (from english to russian and vise versa), keyboard indicator in remote session shows correct layout. But symbols which I type on keyboard are displayed in layout set on chromebook -- ingoring state of keyboard layout indicator in remote session.
    So, to really switch keyboard layout, I must minimize remote session, switch layout on chromebook, switch back to remote session (because it seems that chromeos layout switching keys are ignored in full screen session).
    It is real problem when typing text on mixed languages in remote session (i.e., programming with localized messages).
    BTW, as far as I remember, keyboard layoyt switching in Android or Windows 2X client works correct.
    Can you fix this issue, please?
     
  2. andrews8

    andrews8

    Messages:
    166
    Hi,

    Please try the following and see if it helps.

    On the terminal server, click Start, click Run, type regedit, and then click OK.
    Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout

    On the Edit menu, click Add Value, and then add the following registry information: Value name: IgnoreRemoteKeyboardLayout Data type: REG_DWORD Value data: 1
    When the IgnoreRemoteKeyboardLayout entry is set to 1, new user profiles inherit the Default input language setting from the default user profile that the user account uses.
     

Share This Page