Keyboard SHIFT keys not working after upgrade to Parallels 6

Discussion in 'Windows Guest OS Discussion' started by jamiedaniel, Sep 15, 2010.

  1. jamiedaniel

    jamiedaniel Bit Poster

    Messages:
    34
    I upgraded to Parallels 6.

    I use guest OS as Windows 7.
    While using REMOTE DESKTOP CONNECTION (mstsc from RUN command) to connect to my remote station, here is what I observed:

    The caps lock etc works when local; however when I am trying to type my username and password or anything else on the REMOTE COMPUTER THROUGH MSTSC (RDC) here is what I get

    TYPED ACTIONS
    <shift>a<RELEASE SHIFT>bcde ---> result abcde

    <shift>aA<release shift>bcde

    It appears that the first character typed after the shift is pressed gets the uppercase attribute.

    This might be a deeper issue since I expect all actions may be suffering a "one off" such as NUMLOCK etc etc.

    Please look into this and let me know if anyone else is having the same kind of issues.

    This should be something simple to solve with a update patch. Check keyboard translation...

    Thanks,
    Jamie
     
  2. STim

    STim Super Moderator

    Messages:
    942
    This setting should help workaround the issue while we are working on a fix: Virtual Machine -> Configure -> Options -> Advanced -> Optimize modifier keys for games
     
  3. jamiedaniel

    jamiedaniel Bit Poster

    Messages:
    34
    Works like a charm.

    As always, thanks for such a fast response!
     
  4. Phillip

    Phillip

    Messages:
    1
    This was driving me NUTS! I do IT support from home occasionally and it took me 15 minutes to figure out that I could not login to some of my remote systems because of this problem. I'm glad the workaround works! And I'm sorry that I upgraded to Parallels 6 so soon. I guess that teaches me to let other people work out the kinks in the future!

    Thanks for the workaround!
     
  5. Scrutch2001

    Scrutch2001 Bit Poster

    Messages:
    17
    I too had this problem. I use Mac at home, but need to use Windows to access my office PC through Remote Desktop Connection. When I upgraded to V6, I discovered this shifting key problem as well. It appeared in both Windows XP and Windows 7. The workaround solved my problem.

    This is a good thing, because the new Parallels iPhone App will now allow me to access my office PC with my iPad. :)
     
  6. Marseille55

    Marseille55

    Messages:
    1
    Same problem - fix worked fine.
    Thanks
     
  7. nekcihn

    nekcihn

    Messages:
    1
    Fixed

    Thank you! Totally saved my ability to work from home. As a programmer I use the modifier keys all day long and this was killing me.

    Parallels is freakin' awesome!
     
  8. Martin Widmann

    Martin Widmann

    Messages:
    3
    Thanks for this!

    It was exactly what I was looking for!
     
  9. Robert Garcia

    Robert Garcia

    Messages:
    3
    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.
     
  10. Robert Garcia

    Robert Garcia

    Messages:
    3
    While this solves the immediate problem of logging on using Remote Desktop Connection, it is only a temporary fix. After connecting I find that switching to Full Screen view cuts the top AND bottom screen by over 1". We need that space that's why we're using "full screen".
    PLEASE FIX ASAP.
     
  11. joevt

    joevt Kilo Poster

    Messages:
    1,202
    There is an option "Adjust Mac resolution in full screen". When you switch to Full Screen, the Mac resolution is changed to the minimum resolution that will fit the current Window size. Usually this is larger than the window size (because the Window has title bar and status bar and Parallels has a menu bar) so you see black bars. After switching to Full Screen mode from Window Mode, Parallels does not automatically change the Windows resolution to match the Full Screen resolution. I think Parallels should do this automatically if the Dynamic Resolution Tool (part of Parallels Tools) is running or there should be an option to set this behaviour.

    Anyway, change the resolution manually in Windows to match the Full Screen resolution to remove the black bars.
     
  12. Robert Garcia

    Robert Garcia

    Messages:
    3
    Excellent. Thank You very much.
    Love this forum.
     
  13. Peter100

    Peter100

    Messages:
    1
    I have the same keyboard problem and the workaround appears to have worked for me also.

    Any idea when the real fix might happen?
     
  14. Alan Morris

    Alan Morris

    Messages:
    2
    Works form Me

    Thanks. I wonder why this hasn't been resolved before. When I did a google search, I found similar issues going back several years.
     
  15. True fix for this issue has been made. It will be included into next update of Parallels. The problem is a bit strange behavior of Remote Desktop which eats some keys if they are sending without delay in between them.

    PD delays shift until other key is pressed as it is a part of some shortcut which should not go to VM. Optimize mouse for games just disables this behavior.

    Sorry for inconvenience.
     
  16. Cheebs

    Cheebs

    Messages:
    1
    Thanks you for this work-around. I thought I was going nutz. I noticed even with the work-around that using the Ctl key does not work as it should. For example using Ctl+START should let me get the pop-up for Open, Explore, Search...etc. I found that Ctl+Shift+START works.
     
  17. Mike Lazarus

    Mike Lazarus

    Messages:
    1
    The shift key fix workaround is good (thanks), but the problem also extends to the apple command key. Is there a fix there? Coding in VS2008 on remote desktop connection is painful when you have to use the mouse to cut, paste, save, etc.
     
  18. joevt

    joevt Kilo Poster

    Messages:
    1,202
    The apple key is set as the Windows key. Try using the control key instead.
     
  19. cyclops

    cyclops Bit Poster

    Messages:
    23
    Has this been resolved yet?

    I've got the latest Parallels 6.0, and the shift and control key behavior is still be exhibited. I'm using Windows 7 and RDP.
     
  20. could you please send a problem report? It works just fine in all local test cases
     

Share This Page