Keyboard Shortcut Issues (Mostly Excel)

Discussion in 'Windows Guest OS Discussion' started by suenification, Sep 4, 2012.

  1. suenification

    suenification

    Messages:
    1
    I just installed Parallels 8 from using Parallels 7, and I'm having serious difficult a few excel keyboard shortcuts.

    In particular, "CTRL+SHIFT+ARROW" is not working. Would really appreciate help!
     
  2. YanaYana

    YanaYana

    Messages:
    1,666
    Open Parallels Desktop Preferences --> Shortcuts and try to assign a particular shortcut to VM
     
  3. CodeSurfer

    CodeSurfer

    Messages:
    2
    Excel shortcuts revisited

    That was helpful information, however:
    (1) I can set up short cuts like CTRL+SHIFT+END, CTRL+SHIFT+DOWN, CTRL+Right, if I go to Virtual Machine/Preferences and select "Shortcuts" and add them (per previous). They work as I would want. However, CTRL+Left and CTRL+Up, both send me to Mac OS, even though I tried to set them up as Excel short cut keys, can I override this behavior?
    (2) In Excel, I can select a column using CTRL+Shift-Down after setting up the shortcut. However, if I want to select the next column(s) over also, in non-VM Windows Excel, I can hit Shift-Right. However, when using Excel in Parallels, even after setting up "Shift+Right", it doesnt have this behavior (it just moves the focus to the next cell on the right and unselects the column).

    These may seem like minor nuances, but they make a big difference in my productivity.

    Thanks in advance for any help. I am using Parallels 8, Windows 7 and Excel 2010.
     
  4. CodeSurfer

    CodeSurfer

    Messages:
    2
    Figured out #2

    2) is OK, but I guess for multiple-key function sequences like CTRL+down, followed by CTRL+right, you cannot as in non-VM Windows, hold the CTRL down hit down then right, you have to first CTRL+down, lift up on CTRL, then hit CTRL+right.
     
  5. MLittleR

    MLittleR

    Messages:
    37
    2 CodeSurfer

    regarding the first question you had (CTRL+Left and CTRL+Up shortcuts).
    Please go to the Parallels Desktop menu -> Preferences... -> Shortcuts tab ->System shortcuts -> set 'send system shortcuts' option to 'Always'.
     
  6. pragan

    pragan

    Messages:
    1
    Excellent suggestion. This worked for me in combination with setting just two keyboard shortcut mappings in Parallels preferences: Command = Ctrl and Ctrl = Windows.

    I can now get work done in Excel again :)
     
    RobertH20 likes this.
  7. KayokoL

    KayokoL

    Messages:
    1
    wondering if you all feel as though you are able to operate at full productivity using Windows Excel keyboard shortcuts while using a Mac + Parallels + Windows Excel?

    would like to get another Mac, but need to have full functionality using keyboard shortcuts from Windows Excel and unfortunately do not have much time to program and fix ones here and there that are not exactly the same.

    thank you.
     
  8. TrishaT

    TrishaT

    Messages:
    4
    It is really very helpful to me, Thank you so much.
     
  9. Glen_Parallels

    Glen_Parallels Bit Poster

    Messages:
    15
    I'm a few days into using my first Mac with Excel in Parallels. Its been a lot of trial and error and gritting teeth but after regaining a number of shortcuts by modifying Mac System Preferences I'd say I'm almost back to using Excel as if I was on a PC.

    On thing unexpected though is that the 27" iMac screen resolution has only 3 options, all in 16:9 ratio, compared to 10 options in different ratios I was used to on the Dell so I ended up losing some rows and gaining some columns in order to get a font I could actually read. :-(
     
  10. ahoefer3rd

    ahoefer3rd

    Messages:
    2
    Still not getting this

    Hi,

    I"m trying to make the changes in Paralells 8 => Parallels Desktop to Preferences to Virtual Machine (W7) and the Shortcut tab to clicking on the plus (+) icon to add a shortcut.

    That's were I stall - can't figure out what to put on the 2 lines to make the Ctrl+Shift+DnArrow work.

    Any clarification is appreciated,
    AH3
     
  11. Ram@Parallels

    Ram@Parallels Parallels Support

    Messages:
    768
    Hi ahoefer3rd,

    Please refer to http://download.parallels.com/desktop/v9/ga/docs/pt_BR/Parallels Desktop User's Guide/32884.htm for more information on Customizing Keyboard Shortcuts.
     
  12. ahoefer3rd

    ahoefer3rd

    Messages:
    2
    Hi,

    Thanks for the quick response - I understand that help document, but I don't know the specific items to check off and enter to make the keystrokes Ctrl + Shift + DownArrow work to highlight contiguous cells.

    AH3
     
  13. Ram@Parallels

    Ram@Parallels Parallels Support

    Messages:
    768
    Hi ahoefer3rd,

    If you want to use keystrokes Ctrl + Shift + DownArrow to highlight contiguous cells in Excel in Parallels, Go to the Parallels Desktop menu > Preferences > Shortcuts tab > System Shortcuts > set 'Send System Shortcuts' option to 'Always'.

    Restart Virtual Machine and use Ctrl + Shift + DownArrow to highlight contiguous cells.
     
  14. Hi, I am running Parallels 10 runs Windows 8.1 on my a MacBook Air 10.10.1.
    Does anyone know the equivalent keystrokes for the native Windows Home, Page Up and Page Down buttons? On that note, what is the shortcut to move between sheets on the same Workbook?
    Other than that everything thing else seems to work like Windows.
    Thank you!
     
  15. Adam_B

    Adam_B Bit Poster

    Messages:
    2
    I had an issue with this in OS X 10.9.5, Parallels 10, Win 7, Excel 2010. My issue was only with Ctrl-Shift-RIGHT ARROW and Ctrl-Shift-LEFT ARROW. The UP and DOWN combos worked fine the entire time. After muddling around, I found that I had to do as noted above:
    Go to the Parallels Desktop menu > Preferences > Shortcuts tab > System Shortcuts > set 'Send System Shortcuts' option to 'Always'.
    This entailed also giving Parallels permission to control my Mac in a different System Preferences menus.
    I also manually mapped the keystrokes to the VM, but that didn't seem to do anything. Once I did as above, the issue seems to have been resolved. This kind of glitch is precisely why I dread version upgrades in Parallels and in OS X.
     
  16. QammarI

    QammarI Bit Poster

    Messages:
    1
  17. ThomasC15

    ThomasC15 Bit Poster

    Messages:
    1
    I got the same problem. The solution is turn off the mission control shortcut on the system preference, mission control, change the Mission Control and Application Windows to - (instead of CTRL Down, CTRL Up).
     
    Last edited by a moderator: Apr 15, 2018

Share This Page