Known Issues and Workarounds for Parallels Desktop with Leopard

Discussion in 'General Questions' started by spectre, Oct 31, 2007.

Thread Status:
Not open for further replies.
  1. ljplatt

    ljplatt

    Messages:
    46
    Since issues regarding Parallels Tools have arisen, may I add one more? Whenever I start Tools, it launches and works just fine, but it simultaneously launches the Parallels Tools installation program. I simply cancel the installation and go on about business. However, I am wondering if there is a simple fix that will stop the installation program from launching so that i don't have to cancel it?
    ljplatt
     
  2. eddieb

    eddieb

    Messages:
    4
    Windows program randomly becomes active window

    In coherence mode, if I have an OS X window (active window) immediately in front of a Parallels Window, with my cursor on the OS X window, and I move the cursor onto the Parallels window and back to the OS X window, the OS X window disappears and the Parallels window becomes the active window as if I clicked on it - but I didn't. This doesn't happen all the time, maybe about 35% of the time.

    I discovered this because I would try to do something on the OS X window where I would move the cursor near the edge, and it would go off the edge. When I would bring it back and try to click the mouse, the Parallels window would already be active and I would end up clicking it instead. I KNOW I'm not clicking the mouse by mistake to cause this to happen. This never happened before OS X 10.5 and Parallels 3.0 Build 5160. I upgraded to both virtually at the same time, so I'm not sure which may have caused the problem or if it's both.

    I'm not using Spaces and the only program I am using in Parallels is Quicken. But I did bring up Internet Explorer in Windows to test the problem and it also has the same issue.

    I have a MacBook Pro connected to an external display and Bluetooth keyboard and mouse.
     
  3. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    Hello,

    ljplatt please go to Configuration Editor -> CD/DVD-Rom, put a check at Use CD/DVD-Rom and choose Default CD/DVD-Rom. This should help.

    eddieb, could you give more details for we could reproduce this issue and put it in the queue of bugs to fix? We'd appreciate you describing step by step, what you do before encountering the problem, beginning from the moment you start your Mac. I'd be glad to get this as Private Message. Thank you so much.

    Best regards,
    Xenos
     
  4. ljplatt

    ljplatt

    Messages:
    46
    Xenos:

    Thanks very much for the suggestion. Unfortunately, I had already had CD/DVD Rom checked and selected as the default and for some reason, the installation starts when Parallels starts. Is there a file somewhere that should be deleted?
     
  5. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    ljplatt, could you try the following:

    Boot Windows in Safe Mode by hitting F8 (Fn+F8) when you see the boot screen.
    Go to "My Computer" - "C" Drive - "Program Files" - "Parallels" folder and delete the "Parallels Tools " folder. Reinstall Parallels Tools.

    Best regards,
    Xenos
     
  6. ljplatt

    ljplatt

    Messages:
    46
    thank you , Xenos, for the suggestion. I did as instructed; as the installation was completing, Parallels suddenly stopped and the VM shut down before the installation ended. When I restarted the VM and opened Tools it says coherence is disabled and the check box for enabling it is grayed out. Also, though i have chosen to open Parallels tools on startup, it doesnt start up by itself, I have to click on it. The good news is that it no longer tries to re-install itself.

    I have the feeling that simply deleting the folder in safe mode was a good start but not enough.
     
  7. ljplatt

    ljplatt

    Messages:
    46
    In addition to new problems noted in post 46 of this thread, I cannot link to my browser from Outlook, instead receiving a message that this isnt allowed on this computer. I also can't cut and paste from a program to this message i am sending from my browser.
    ljplatt
     
  8. ljplatt

    ljplatt

    Messages:
    46
    solved the problem with browser connection; the coherence being disabled is still a problem - ie, tools says it is disabled though it seems to be working ok
    ljplatt
     
  9. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    ljplatt, please in Safe Mode go to Windows "Start" - "Control Panel" - "Add or Remove Programs" list and remove Parallels Tools. Try reinstalling Tools than.

    Best regards,
    Xenos
     
  10. No icons for Windows apps

    As reported in previous post, I get no icons on the Mac dock for Windows apps (http://forum.parallels.com/showpost.php?p=87327&postcount=9)

    MacBook Pro 15" Intel Core Duo 2.16 GHz
    Memory: 2 GB
    Parallels Desktop 3.0 for Mac Build 5160

    Anyone knows if there have been updates to this issue?

    Thanks!
     
  11. adric

    adric

    Messages:
    1
    Bridged Networking, Leopard, Parallels 3 5160

    I'm also experiencing trouble with shared networking on Leopard (10.5.1, 9B18). This is on a 17" Mac Book Pro Core Duo 2.16 with full 2GB RAM, Parallels 3 build 5160.

    I used the sudo script above, and it seem to help, as both of my Parallels network interfaces went green for the first time in awhile (both have 10.x.x.x addresses?), but bridged networking is still not working (clicking over to shared restarts the network and works fine.)

    More specifically with ISC dhclient v3.05-RedHat (from Fedora 7) and bridged networking to my Airport I get :
    DHCPREQUEST on eth0 [broadcast]
    DCHPNAK from 192.168.1.1
    DHCPDISCOVER on eth0 [broadcast]
    send_packet: Network is down
    [keeps trying, times out]

    As noted, clicking over to Shared Networking works, and a get a lease to a 10.x.x.x network quickly. (this complicates some network software I'm troubleshooting a fair bit, adding a second layer of NAT...) I'd be happy to provide more data, or try this in some other guest OS, or even a debugging image if it would help you track it down.

    Thanks!
     
  12. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    Hello,

    jcmendez@alum.mit.edu, please go to Configuration Editor (your VM is on but Windows not launched) -> Shared Applications. Check the settings at "Show in Dock". You should choose "Always" if you'd like to see Windows applications' icons on the Mac dock.

    adric, we do not provide drivers for Airport in Linux (however we do get drivers for Airport in Windows, from Boot Camp). So you will not have Bridged Ethernet working in Fedora. Why don't you use Shared networking?

    Best regards,
    Xenos
     
  13. soleil

    soleil

    Messages:
    4
    still doesn't work, didn't hear from tech support

    Despite following these instructions, parallels still quits unexpectedly every time I try to launch it. I've tried a bunch of things, I sent a support request to tech support detailing everything I did, but I haven't heard from anyone yet.
    I followed the instructions #5 several times, also followed the ones listed here: http://kb.parallels.com/entry/21/235/

    I have the error reports files available if necessary.

    I would really appreciate if someone could try to point me to the right direction, as right now I have an entire system that is useless.

    Thanks!
     
  14. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    soleil, could you send me the error report you get at unexpected quit? You can attach it to your post.
    Could you also let me know by PM the e-mail address you used to send us a request ticket? Did you get the letter conforming we had received your request?

    Best regards,
    Xenos
     
  15. soleil

    soleil

    Messages:
    4
    Hi Xenos,

    Thanks for the quick reply! No i never got a confirmation letter from my request. I will PM you the email address. I'm attaching the error report and the log file.
     

    Attached Files:

  16. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    soleil, you'd better update to 5160. Could you let me know your Mac type and if you use an external monitor?
    Got your addresses, thanks!

    Best regards,
    Xenos
     
  17. soleil

    soleil

    Messages:
    4
    Hi Xenos,

    macbook pro, no external monitor. OMG, I'm so sorry, I thought I was using 5160! downloading it now, will keep you posted.
     
  18. soleil

    soleil

    Messages:
    4
    Hi Xenos,

    5160 now installed, it works. So far, so good. I can't believe I missed the old version, oh well...Thank you so much for pointing me to the right direction!
     
  19. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    Glad to know it's ok now.
    If you have any other questions, please feel free to ask.

    Best regards,
    Xenos
     
  20. CaiusAérobus

    CaiusAérobus

    Messages:
    3
    How to get the Configuration Editor?

    Hello,
    the Parallels guide says "Open the VM configuration page and click any link to open the Configuration Editor" BUT if I click on any item I get a message "impossible to configure the VM while it is running". Ok but if I stop the VM I do no longer hve any access to its menus and especially on the cpnfiguration page... How to do it?
     
Thread Status:
Not open for further replies.

Share This Page