Known Parallels NAT & NFS issue?

dnewman

Bit poster
Parallels Desktop 3.0 for Mac, Build 4128.

Am wondering if there is a known issue with the Parallels NAT interface as
regards handling of NFS. If I use bridged ethernet mode, then from within
the virtual machine (Solaris 11 sxde), I can mount an NFS share just fine
from the OS X host. However, if I'm running in NAT mode I get the error
"client credential too weak" when attempting to mount the NFS share. I
find that I have to run mountd with the -n switch on the OS X host.... It's
as if the NAT translation of the NFS client request is slightly off and it no
longer appears as a NFS mount request from the root user. (I suppose I
could do some tcp packet dumps to confirm.)

So is this a known issue? FWIW, all mounts are done as root from the
virtual machine. In each case I am using the correct IP address for the
OS X host (the "real" IP in bridged mode, and the Parallels Guest-Host IP
when running in NAT mode). And the behavior is independent of whether
I use NFS over TCP or UDP. Am not running the firewall on the OS X client
and as such blockage of port 2049 is not an issue.

Dan
 
dnewman said:
... I can mount an NFS share just fine
from the OS X host.
Dan

To clarify: the OS X host is the NFS server; the NFS client is the Parallels
virtual machine. The virtual machine is mounting an NFS share served
by the OS X host.

Dan
 
The NATing in Parallels seems to only map ports above 1024 (non-privileged ports).
When connecting from a SuSE VM to an NFS Server the mount will fail. This is due to the fact that the NFS server requires a source port 111 as a privilged port for security reasons.

Parallels NAT seems to map the source port above 1024 and therefore the connection fails.

A workaround could be to reconfigure the NFS Server and to allow unprivileged ports with the insecure option.
 
Back
Top