Lion PD6 All VM start Automatically

Discussion in 'Installation and Configuration' started by Mel A, Jul 22, 2011.

  1. Mel A

    Mel A

    Messages:
    12
    I just installed lion after PD6 was updated to build 6.0.12094. Initially PD6 worked normally. Now every time I start PD6, both my virtual machines (XP and W7 32 bit) start automatically. I have both of the VM configured to never start automatically. I have tried closing one VM and then removing it from the VM list, starting up PD6 and then opening manually. The next time I started PD6 it started up automatically again even though configured to never start automatically. I need to stop this because when both start up together it takes 20 minutes to load.
     
  2. backflip

    backflip

    Messages:
    4
    I'm having the same problem.


    (OS X Lion, Parallels 6. VMs with either Windows 7 or XP.)
     
  3. lehmachr

    lehmachr

    Messages:
    9
    I have the same issue with automatic start. It seems a little unstable.
     
  4. Vaj

    Vaj

    Messages:
    8
    I'm having the exact same problem. I did a fresh install of XP and it's much, much faster now, but I didn't note if the automatic launch was still occuring or not. I'll check when I get home.

    One things for certain, a fresh install rendered a blazingly fast VM.
     
  5. IvoryC

    IvoryC

    Messages:
    25
    I used to start up PD6 and then open manually. However, it won't work anymore.
     
  6. Vaj

    Vaj

    Messages:
    8
    Even with a clean install, my VM starts automatically every time.
     
  7. DeShawnB

    DeShawnB

    Messages:
    116
    Hey everyone. Multiple VMs starting on launch is a known issue between the latest version of Parallels Desktop 6 and Lion. Our Engineering team is hard at work on this.

    For a list of other known issues between Parallels Desktop 6 and Lion please see this KB article here: http://kb.parallels.com/en/111614
     
  8. CMiyamoto

    CMiyamoto

    Messages:
    1
    Turned off "parallels" auto load

    My brand new MBP started crashing on startup with Lion installed when Parallels started up automatically and tried to start win7 at the same time. I would constantly have to force quit the computer. I think it has something to do with both the MAC and VM fighting for hardware at bootup. Lion has slowed the bootup and shutdown time considerably.

    Whenever I forced Parallels to quit before it got too far loading windows, the laptop worked fine. I just waited about a minute before launching Parallels to allow the Lion OS to settle down.

    I went to the MAC's system preferences and under "Users & Groups", clicked on the "Login Items" and REMOVED parallels from the list. (NOTE*: do not just check the Hide column box, you need to remove the program from the list by selecting it and clicking on the - (minus) symbol at the bottom of the list)

    After I see that a fix has been made, I may add it back in to launch automatically.
     
  9. asoehn

    asoehn Bit Poster

    Messages:
    10
    This works for me:

    I found a solution for me to prevent parallels from starting multiple machines at startup.
    In terminal type:
    defaults write com.parallels.desktop.console NSQuitAlwaysKeepsWindows -bool false

    After that start parallels, quit it and start again.
    Since I did this, parallels starts always with only the VM I just doubleclicked to start it ;-)

    I hope this helps somebody.
     
  10. Tom Collignon

    Tom Collignon

    Messages:
    39
    Just turn of "use animations" in parallels preferences (not in vm preferences). Then for some reason the problem is gone. Also the people with crashes are helped with this.
     
  11. man02195

    man02195

    Messages:
    2
    turning off animations worked for me, thanks, both vm's starting up was taking a lot of time and battery.
     
  12. JBuehl

    JBuehl

    Messages:
    1
    Turning off animations had no effect for me, however changing the setting that asoehn suggested did prevent the VMs from starting up.

    Parallels 6.0.12094
    OS X 10.7
     
    Last edited: Aug 14, 2011
  13. dialafc

    dialafc

    Messages:
    5
    None of the solutions works for me. Still when I click a .pvm to open av VM, one of the others tries to fires.

    I reported this weeks ago. I am surprised that the developers at Parallels have not managed to fix this by now.
     
  14. GraemeB

    GraemeB Bit Poster

    Messages:
    2
    This tip contains the information on how to stop individual apps auto resuming without cancelling the whole feature:

    http://hints.macworld.com/article.php?story=20110724223238674

    I disabled Parallels with the specific command:

    defaults write com.parallels.Parallels ApplePersistenceIgnoreState YES

    I've also had to disable Excel (2008) which basically crashes on startup as it tries to open multiple copies of the same file and generally misbehaves.
     

Share This Page