Long hangs and unresponsiveness in guest OS after last 2 PD14 updates prior to PD 14.1.2

Discussion in 'Windows Guest OS Discussion' started by KorkyPlunger, Mar 6, 2019.

  1. KorkyPlunger

    KorkyPlunger Kilo Poster

    Messages:
    130
    I am currently on PD version 14.1.2 (45479).

    Prior to the last two PD14 updates, performance was great and I had nothing to complain about. However, since those updates (particularly the most recent one), I've been experiencing constant periods of unresponsiveness in the guest Win10 VM.

    Anecdotally, this seems to be related to disk access. I experience it:
    • during startup, when it can sometimes take up to 1 minute after seeing the Windows start screen before it becomes responsive and allows me to enter my password (see Technical Data Report 301783727)
    • when performing seemingly innocuous actions in windows apps, like clicking on a "help" button to open a documentation page (see Technical Data Report 301912178) or just clicking on the Windows start menu.
    • When changing resolutions (VM hanging with black screen for 20-60 seconds before becoming responsive again)
    • launching applications
    • etc
    This is occurring on the fastest available production 2018 MacBook Pro (32GB ram, 2TB SSD, 2.9 ghz i9 processor, 6 cores) when the host OS is idle and the guest OS is often idle as well.

    I have erased all other copies of the VM from the SSD and purged any local time machine snapshots using "sudo tmutil thinLocalSnapshots / 10000000000 4" to reduce the possibility of this being an APFS snapshot-related issue.

    My VM is large -- 375 GB -- and set as a non-expanding disk. My SSD has > 1TB of space free.

    Can anyone from Parallels help with this issue? I've already uploaded several Technical Data captures and I can make more if needed.

    If it's a known issue that's being worked on, that's fine, just please let me know.

    Thank you,
    Chris
     
  2. KorkyPlunger

    KorkyPlunger Kilo Poster

    Messages:
    130
    Another set of Technical Data from another hang: Report ID is 301917428

    This time I tried to open an XML file and nothing happened; after 15 seconds or so I then opened the Task Manager and clicked the "CPU" column to sort processes by CPU usage, and task manager became unresponsive. I then gathered technical data and eventually the XML file opened and the task manager became responsive again.
     
  3. Maria@Parallels

    Maria@Parallels Kilo Poster

    Messages:
    8,694
    Hi, did you try this KB article https://kb.parallels.com/112091 ?
    Also please try the selective startup option for Windows

    However, please start Windows and execute the sfc /scannow command in command prompt.
    Then provide us with the results.
     
  4. DanielK20

    DanielK20 Bit Poster

    Messages:
    2
    Same issue here. I did not change the VM settings. Same even if I switch back to an clean install snapshot. Since the Parallels Update it is broken. :(
    Also using it on an MacBook Pro (with Touch Bar). Never had any issues before.

    Windows is so laggy that you can hardly do something...
     
  5. W.I

    W.I Bit Poster

    Messages:
    21
    I have an older iMac (late 2012) and have had the same performance problems as KorkyPlunger and many others ( unresponsive task manager, etc.).
    In my case, setting the resolution to "recommended" (1419x853 on my Mac) worked wonders. The display is smaller than I want, but at least I can use windows.
     
  6. KorkyPlunger

    KorkyPlunger Kilo Poster

    Messages:
    130
    I have filed yet another Technical Data report for another application hang: #302233041
     
  7. KorkyPlunger

    KorkyPlunger Kilo Poster

    Messages:
    130
    Yes, I have tried the KB article. It is not a system resources issue as this is the fastest available 2018 MBP you can purchase, as described in the original post. The VM is not using all cores on the host (its using 4 of the available 6 cores), nor is it using all the RAM (18 out of 32GB). And I am using the parallels hypervisor.

    Selective startup is not the issue, because this problem persists throughout the entire day. It is not solely a startup issue.

    Here's the output of the sfc /scannow command:

    C:\Windows\system32>sfc /scannow

    Beginning system scan. This process will take some time.

    Beginning verification phase of system scan.
    Verification 100% complete.

    Windows Resource Protection did not find any integrity violations.
     
  8. KorkyPlunger

    KorkyPlunger Kilo Poster

    Messages:
    130
    Ok, I believe I found the solution to my problem.

    The hitches/hangs always seemed to be during disk access by the guest OS. So I had a suspicion that this might be due to some kind of fragmentation of either the files within the .pvm file (most likely), or perhaps that this giant 375GB VM was parceled up all over the SSD by the APFS file system in such a way that access was very inefficient.

    On a hunch, I attempted to "repack" everything by:
    1. Opening the Parallels Control Center
    2. Right-clicking on the VM
    3. Choosing "Clone" to create new copy of the 375GB VM
    4. Launching cloned VM and (after verifying the clone worked!) deleting the original VM

    I'm happy to report that this seems to have fixed it. The copy boots to Windows 10 in about 5 seconds instead of 60+ seconds, and logs in immediately. Since cloning and switching to the clone I've experienced none of the hitches and hangs I had before.

    I'm still not sure if the problem was within the PVM file or if it was an APFS-induced issue, but this seems to have fixed it.
     
    DanielK20 likes this.
  9. DanielK20

    DanielK20 Bit Poster

    Messages:
    2
    @KorkyPlunger: I just made a short test and it seems that your tipp indeed fixes the problems. Thank you very much for sharing that. You made my day! :)
     
    Last edited: Mar 11, 2019
    KorkyPlunger likes this.
  10. eduardo5

    eduardo5 Bit Poster

    Messages:
    2
    I followed your instructions but the cloned Vm did not fix the problem. the parallels desktop tells me that the license is active
     
  11. KorkyPlunger

    KorkyPlunger Kilo Poster

    Messages:
    130
    For what it's worth, in the two months since I reported that cloning fixed my issue, my 375GB VM has degraded in performance to the point where I got frustrated enough to clone it again. After cloning, works perfectly and performance is back to normal.

    So that's 2 out of 2 successes with cloning for me. Granted this is on the fastest 2018 MBP you can buy, using SSDs and not spinning disks. But at least the issue and the solution appear to be reproducible.
     

Share This Page