macOS guest and host in HiDPI - web browser problems

Discussion in 'Mac OS X Guest OS Discussion' started by Kent_Boortz, Feb 6, 2018.

  1. Kent_Boortz

    Kent_Boortz Bit Poster

    Messages:
    11
    I'm running Parallels Desktop 13 and run "macOS on macOS". My current setup is macOS 10.13.3 host and guest on a MacBook Pro 13" Retina 2016.

    Running "macOS on macOS" works well except that all web browsers I tried have problems. To get a crisp screen I use a "HiDPI" setting in the macOS display control panel.

    Google Chrome has lots of flickering. Tried some other browsers like Opera, Vivaldi and Firefox. Either they has the flickering too or other rendering problems. Not really usable.

    SeaMonkey seems to work ok and Firefox up to version 54.0.1 seems to work if doing a work-around, see

    https://bugzilla.mozilla.org/show_bug.cgi?id=1305656

    Problem is that in my new setup with the latest Parallels Desktop and a newer Safari all works well except searhing for text on a web page. Then the whole page gets black except the text I search for that gets a yellow background. See image

    SafariSearchProblems.png

    Note that Parallels Desktop share the above problems with another major virtualization product for macOS. I.e. this might be a general problem with how virtualization is done on macOS. Or possibly a webkit problem.

    Is there any work-around for this? Or something you plean to address in some future release?
     
  2. Kent_Boortz

    Kent_Boortz Bit Poster

    Messages:
    11
    Best Answer
    Just writing down notes if someone else runs into this browser problem.
    I got some help from adding a question in a Firefox bug report
    https://bugzilla.mozilla.org/show_bug.cgi?id=1305656
    To use Firefox in Parallels Desktop 13 maOS High Sierra Guest:
    1. Download Firefox 54.0.1 (later will not work)
    2. Devices -> Network -> Disconnect (else Firefox will quickly update to a later version)
    3. Actions -> Configure... -> Hardware -> Graphics and switch to "Scaled" (so you can access the Firefox settings)
    4. Start Firefox and go to Preferences -> Advanced -> Update and select "Never check for updates"
    5. In the address field to to about:config and click the button "I accept the risk!"
    6. Search: HiDPI and set gfx.hidpi.enabled to 0
    7. Exit Firefox
    8. Devices -> Network -> Shared Network
    9. Actions -> Configure... -> Hardware -> Graphics and switch to "Best for Retina display"
    10. If you started a later version before you need to do in Terminal
      "rm Library/Application\ Support/Firefox/Profiles/*/places.sqlite*"
    11. Start Firefox
    I get the impression that text is not as crisp as in Safari but it works ok. A bit of flickering when scrolling or moving the Firefox windows, tolerable I think. Still the too fast two finger scrolling will make browsing frustrating.

    Unfortunately my trail period is ending today. Parallels is an impressive product and from what I can see the support team seems great (I tested a competitor product at the same time, same problem., and asked the same question in their forum, zero response).

    Just that support for running macOS as both guest and host might have fallen behind a bit.

    Again, thanks!
     
  3. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    526
    Hello @Kent_Boortz, you hit the bull's eye. This is a general virtualization limitation - the is no documentation from Apple for the macOS graphics driver API required to implement OpenGL support in macOS (and Linux) guest systems, meaning that we cannot do 3D acceleration support for macOS/Linux VMs. Without 3D acceleration guest macOS applications (web browsers, video players etc.) will have side-effects like black areas, performance issues. You can try booting guest macOS to safe mode which will help to get rid of visual artefacts, however overall visual performance will be affected. To boot to safe mode press and hold Shift key upon macOS VM restart until you see the gray Apple logo and progress indicator.
     
  4. Kent_Boortz

    Kent_Boortz Bit Poster

    Messages:
    11
    Thank you for the reply.

    I tried now in safe mode. The flickering in Chrome stops and is replaced with incorrect rendering and being extremely slow. Maybe expected if it try use OpenGL acceleration. But the problem in Safari described above is the same as in normal mode.

    Note that the problem with the background getting black when searching on a page is not related to what web page I'm visiting. You still think it is about OpenGL?

    Note that I could not enter the guest into safe mode with holding down the shift key. But Parallels KB told how :)
    http://kb.parallels.com/eu/124181
     
  5. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    526
    Clarified with Engineering Team, they say that to be 100% sure that artefacts are caused by the absence of 3D acceleration, need to boot the entire Mac to safe mode and check wether the same behavior happens on host macOS. Checked your scenario with Safari, the same happens on host Mac in safe mode..
     
  6. Kent_Boortz

    Kent_Boortz Bit Poster

    Messages:
    11
    Ah, verified then. I guess I have to stick with FireFox 54.0.1. Work well except it seems to handle HiDPI a bit worse than Safari, not as crisp text. Well, FireFox will work well once I manage to figure out how to slow down the scrolling. Tried different solutions, not there yet ;)

    This is amazing support, thanks again :)
     
  7. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    526
    Thank you, Kent! Always happy to help. What's up with scrolling, by the way? Too sensitive in virtual macOS?
     
  8. Kent_Boortz

    Kent_Boortz Bit Poster

    Messages:
    11
    Yes, jumps too easily making it almost impossible to use two finger scroll. It feels like even a slight movement makes it accelerate and then jump over the text you try scroll down to. Same in Safari and Firefox.

    In the VM the trackpad system preferences says "No trackpad found" and changing the mouse scroll speed seems to make no difference. I tried Firefox specific hints but seemed to have no effect either.
     
  9. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    526
    Thanks, Kent. I've reproduced the same behavior and reported to Engineering, they will proceed with investigation.
     
  10. Kent_Boortz

    Kent_Boortz Bit Poster

    Messages:
    11
    Best Answer
    Just writing down notes if someone else runs into this browser problem.
    I got some help from adding a question in a Firefox bug report
    https://bugzilla.mozilla.org/show_bug.cgi?id=1305656
    To use Firefox in Parallels Desktop 13 maOS High Sierra Guest:
    1. Download Firefox 54.0.1 (later will not work)
    2. Devices -> Network -> Disconnect (else Firefox will quickly update to a later version)
    3. Actions -> Configure... -> Hardware -> Graphics and switch to "Scaled" (so you can access the Firefox settings)
    4. Start Firefox and go to Preferences -> Advanced -> Update and select "Never check for updates"
    5. In the address field to to about:config and click the button "I accept the risk!"
    6. Search: HiDPI and set gfx.hidpi.enabled to 0
    7. Exit Firefox
    8. Devices -> Network -> Shared Network
    9. Actions -> Configure... -> Hardware -> Graphics and switch to "Best for Retina display"
    10. If you started a later version before you need to do in Terminal
      "rm Library/Application\ Support/Firefox/Profiles/*/places.sqlite*"
    11. Start Firefox
    I get the impression that text is not as crisp as in Safari but it works ok. A bit of flickering when scrolling or moving the Firefox windows, tolerable I think. Still the too fast two finger scrolling will make browsing frustrating.

    Unfortunately my trail period is ending today. Parallels is an impressive product and from what I can see the support team seems great (I tested a competitor product at the same time, same problem., and asked the same question in their forum, zero response).

    Just that support for running macOS as both guest and host might have fallen behind a bit.

    Again, thanks!
     
  11. SergeyA1

    SergeyA1 Bit Poster

    Messages:
    18
    No new solution for this problem?
    It happen with every browser...
    It only works "In low resolution" with retina but quality is very pure.
     
  12. I am sad to say, but the problem still exists. We're now at Parallels Desktop 14.1.3 (april 2019).
    A browser is probably the most used application. Parallels has to do more effort to solve this.
     
  13. MannyM2

    MannyM2

    Messages:
    1
    Parallels Desktop 14 for Mac Pro Edition version 14.1.3, macOS 10.14.3. Issue still not fixed. This is completely unacceptable, the Parallels Team needs to do better than this. I bought version 14 to run Google Chrome specifically, the graphic artifacts make the macOS Mojave VM completely unusable.
     

Share This Page