macOSX - High Sierra Guest graphics issues

Discussion in 'macOS Virtual Machine' started by ThomasH37, May 24, 2018.

  1. ThomasH37

    ThomasH37 Bit poster

    Hi there,

    I am having graphics issues with OSX - High Sierra Guest 10.13.4 on a OSX - High Sierra Guest 10.13.4 host on a MacBook Pro (15-inch, 2016).
    Version 13.3.1 (43365)
    with newest guest tools installed.

    Visual Studio Code has issues displaying correctly. Objects appear and disappear. Same issue for other applications (I can send GIFs?, but they are too large for here)
    I was able to fix the Chrome issue with disabling hardware acceleration (other issue).

    I would bet that there's something wrong going on with graphics acceleration for OSX. My Linux VMs work fine.

    It might be that all applications including VS Code that are based on web-technologies will face the same issue. VS Code is built on Electron ...

    @PaulChris@Parallels - You guys should look into this.
    Last edited: May 24, 2018
  2. Arun@Parallels

    Arun@Parallels Parallels Support

    Hi @ThomasH37 , please help us with screenshots, so that we will check and help you out.
  3. Jay6

    Jay6 Bit poster


    I'm having the same issue, on chrome I was as well able to fix it, yet for native apps such as (Trello / Stride) the application opens, but remains a blank canvas. Yet it's possible to click (If you know where to click) and fill in data (blind) if you have a textbox somewhere.

    I can give you a screenshot, but since the canvas is blanc (white) it's useless :) In some occasions you might see the screen you are supposed to see, but it flickers and then disappears again.

  4. ThomasH37

    ThomasH37 Bit poster

    I made a gif but the size exceeds the limits.... :p

    Agree with @Jay6 , you can blind click and it will show a part sometimes. But this is not really useable.

    + Add Sublime editor to the list. I believe Sublime is however native code and not web. So it must be in the graphics hardware acceleration that is messed up. Might be card specific?

    Mine :
    Intel HD Graphics 530 1536 MB
  5. ThomasH37

    ThomasH37 Bit poster

    @Arun@Parallels In fact I see the similar graphics effects when I run VS Code (or other web based application) on my native OSX and have the Parallels OSX up and running. The UI elements in the native os app start jumping or disappear.
  6. Jay6

    Jay6 Bit poster

    anyone has the same issue or someone that has a solution for this?
    ThomasH37 likes this.
  7. ThomasH37

    ThomasH37 Bit poster

    No solution there yet. Please let us know if you find something...

    And yes, others have this problem. See the last post of this topic
    Last edited: Jun 16, 2018
  8. AlexW8

    AlexW8 Junior Member

    I'm experiencing this as well.
    FYI: I'm currently running a head-to-head evaluation of Parallels 13 and Fusion 10. Up until trying to launch VSCode, they were neck-and-neck, but Fusion is rendering Code just fine, and Parallels is struggling.

    As a workaround, assuming your problem app is Electron-based and switching wholesale to Fusion isn't an option:
    "open /Applications/Visual\ Studio\ --args --disable-gpu"
    will launch VSCode without GPU acceleration, which I've confirmed works.

    Of course, launching all your electron apps from the terminal is a crap workaround, and also, the "code" command doesn't pass these arguments, so that shorthand won't work. I suppose you could always make an alias. But I digress.
    sean121 likes this.
  9. AlexW8

    AlexW8 Junior Member

    On further assessment, I note two things:
    1) Fusion actually struggles as well - everything renders, but it's very sluggish, so elements will flash and pop and do all sorts of annoying things. The interface isn't completely unusable like in the Parallels guest, but it's functionally necessary to --disable-gpu in Fusion as well. EDIT: In fact, Fusion struggles with UI flashing whether or not --disable-gpu is passed. So Parallels without workaround loses here as unusable, but Parallels WITH workaround wins as the best UX between the two.
    2) Parallels seems to benchmark higher than Fusion for my macOS guest, which jives with subjective user experience. They are also still quite close to each other, which also jives with the subjective experience.

    EDIT: an additional note about the workaround - the "code" terminal command actually will take the argument. So if your typical workflow is to launch VS Code with "code ." at the terminal, as mine is, you can simply add

    alias code="code --disable-gpu"
    alias code='function __code() { code $* --disable-gpu; unset -f __code; }; __code'

    to your .bash_profile, and the code command will always launch a good working GUI.

    EDIT: sorry that alias is so goofy, but it makes sure 'code .' and 'code myfile' turn into 'code . --disable-gpu' and 'code myfile --disable-gpu' respectively. The other way around doesn't work.
    Last edited: Aug 8, 2018
  10. Jeremy4

    Jeremy4 Bit poster

    Anymore traction on these display issues? I had these in Parallels 13 and hoped Parallels 14 would help but its just as glitchy.

    I'm running 10.13.3 as the native MacOS version on 2017 15" Mac Pro Touch Bar, 10,13.6 through Parallels 14. I've seen the behavior on several applications, most recently on Etcher 1.4.4. Parts of the interface never draw. You seem to be able to click them, but they're invisible, blank/white whatever.

    I tried changing the "graphics' from scaled, to best for retina display, to more space. Set memory up to 512MB from default. Tried enabling automatic graphics switching, nothing seems to help.

    Very disappointing that this behavior is so prevalent, it has made the MacOS in Parallels virtually useless. Glitches aside, the basic UI performance is almost unbearably slow.

    Would appreciate any feedback or tips to get this running properly. Thank you.
  11. jasimon9

    jasimon9 Member

    I just created a Parallels VM for macOS and upgraded it to Mojave. At first I found that Chrome did not work. Main things that fail:

    1. Significant parts of web pages on any web site do not display.
    2. Cannot enter into fields. In particular cannot enter into the address bar. What seems to happen is that text gets entered in "white on white". As soon as a character is entered, it seems to insert space for about 5 characters and a large, empty drop down appears, where normally suggestions appear.
    3. Most of the controls at the top of the browser window do not appear either.

    If you just keep entering characters in the address bar, you can get to a website. But significant parts of the page to not display. If you point to where elements should be on the page, portions of that content may show up.

    The result is a completely unusable browser.

    Please consider the following points regarding the configuration:

    1. Safari works perfectly.
    2. Firefox works perfectly.
    3. I have attempted to clear cache, but going into the Chrome Settings section hardly works either.
    4. I have uninstalled and reinstalled Chrome numerous times, with no improvement.

    I finally found a fix by mucking around in the Chrome settings: you have to disable hardware acceleration. I had seen that as a suggestion in connection with El Capitan and on this page above, but the setting function worked so poorly that I could not navigate to it. With some patience, I finally did get to it, and it solves the problem.

    I am thinking that it is probably not actually a Mojave issue after all, but a Parallels 14/Chrome issue.
  12. Paya

    Paya Junior Member

    I run macOS 10.14.1 host and macOS 10.14.1 on Parallels 14.0.1 and I experience the same issue. Sadly the terminal command workaround for Visual Studio Code did not work for me. Still the same glitches.
  13. cdubois

    cdubois Junior Member

    Sadly, this issue continues with Parallels 14.1.0 with a macOS 10.14.2 VM and Visual Studio Code (Electron / Chromium based). This (and the solvable macOS VM pausing issue) make using a macOS VM with Parallels almost useless for my current development efforts. Are there any better suggestions or fixes for this from @Arun@Parallels ?
  14. DriesD

    DriesD Bit poster

    Same issue here with Skype and Microsoft Teams. The company I work for has a policy that every customer implementation is done in its own Parallels VM to avoid VPN clashes (happens frequently otherwise) and to keep customer data segregated (in case a customer's IT scans the VM).
    If this issue has been pending for so long, I would expect a fix from Parallels. I have had to run all of these apps from the terminal as suggested above. I will look at the other suggestions in this thread next.
  15. DriesD

    DriesD Bit poster

  16. prenez

    prenez Member

    open "Visual Studio Code".app --args -disable-gpu
    does not work. The app bounces a bit, the black 'on' dot under the icon comes up, then the bouncing stop, the dot goes away, the app does not start at all. This DOES work with Slack, however.
    (In Catalina on Catalina host and Mojave Host).

    NOTE this command does work for Visual Studio Code in a terminal that's run in the host operating system.
  17. CarlosR14

    CarlosR14 Bit poster

    For chrome browser, go to settings and advanced, do not use hardware acceleration. The browser will work flawlessly.

    For others that use here is command line workaround:
    Open TextEdit and make a new text file. Make sure you are in plain text mode. (replace "nameofapp" with whatever your app is)

    enter the following:

    #! /bin/bash
    /Applications/ --disable-gpu  
    save file as nameofapp.command wherever you like. But make sure the extension is .command not .txt

    Go to terminal cd to the folder where you have made the .command text file, and type chmod 755 nameofapp.command

    Make an alias on your desktop or dock for nameofapp.command for easy access.

    If it says "no such file", navigate to the app in the application folder and right click "show package contents", go to Contents, then MacOS. In there will be the name of the file that needs to be executed. However in my experience, it's always named the same as the app.

    The terminal window will stay open. If you close the terminal window it will close the app. It's crude but it works.
  18. AlexAlexAlex

    AlexAlexAlex Junior Member

    Posting to report the same issue. The command line fix works for me, but it's pretty tedious. It would be better if there was no rendering bug in the first place
  19. CarlosR14

    CarlosR14 Bit poster

    There are a bunch of posts here about that. So the fix to this issue may just be low on the totem pole of upcoming changes for them as we represent a small group of users compared to those fo Windows.

    There are performance issues all around. I have a new Mac Pro and even with the massive power of that machine there is lag on a lot of things. Try hitting the Launchpad on the dock and see how it can't deal with the animation. I've tried more processors, more video ram; nothing works to smooth that out. There is something missing related to video and I hope it gets fixed, I enjoy using Parallels.

Share This Page