Message at login about airplane mode

Discussion in 'Parallels Toolbox for Mac' started by OweA, Feb 4, 2019.

  1. OweA

    OweA Bit Poster

    Messages:
    4
    When I login to my mac I always get a message (se attached image) that there is a wireless mouse connetced and if I really want to enable Airplane Mode.
    Why does the system think I want Airplane Mode when I login?
     

    Attached Files:

  2. sergk

    sergk Parallels Developers

    Messages:
    194
    Hello, OweA,

    please check if "Airplane Mode" tool is added to your Login Items: open System Preference application --> Users & Groups --> Login Items. If Airplane Mode is here then remove it.
    Otherwise we need report with technical details: https://kb.parallels.com/en/124107
     
  3. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    2,874
    @OweA, we've recieved your reply "I have sent the tech data report but missed making a note of the ID"
     
  4. OweA

    OweA Bit Poster

    Messages:
    4
    But did you also receive the tech data report even though I missed out on the ID?
     
  5. sergk

    sergk Parallels Developers

    Messages:
    194
    Yep, we found it. ID = 297121673

    Btw, have you checked Airplane Mode in macOS Startup Items?
     
    Last edited: Feb 14, 2019
  6. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    2,874
    @OweA, we've received your reply:
    "Any news about this problem??"
     
  7. OweA

    OweA Bit Poster

    Messages:
    4
    I forgot to answer your question about airplane mode in startup items and yes I have and it is not in there

    Owe
     
  8. sergk

    sergk Parallels Developers

    Messages:
    194
    Owe,

    we need another technical details reports with extended product logging turned ON:
    - quit from Parallels Toolbox
    - in Terminal application please run this command
    Code:
    defaults write com.parallels.toolbox ExtendedLogging 1
    - launch Parallels Toolbox and reproduce the issue (log out and log in again or just restart macOS)
    - send another one technical details report and post it's ID here (https://kb.parallels.com/en/124107)
     
  9. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    2,874
    Reply from @OweA :
    The ID is 298711862 and I ran the command in terminal, after that I logged out and back in. Then I did the techreport
    Hope this was right
     
  10. sergk

    sergk Parallels Developers

    Messages:
    194
    Owe,

    I think we caught it!

    Sometime ago you probably turned "Airplane Mode" ON. After this "Airplane Mode" should be started on every logon. To stop this behaviour the tools had to be stopped manually.
    While starting on logon Airplane Mode checks existence of bluetooth devices and asks for confirmation to avoid disconnecting you from keyboard/mouse.
    And if you say "No" then tool is not started. But because of the bug "Airplane Mode" doesn't remove itself from autostart in this case. And will be started again on next logon.

    You have two ways to fix the issue.
    1) Simple, but you must have non-bluetooth mouse or keyboard connected to you Mac mini:
    - Just launch Airplane Mode, agree to disable bluetooth devices and then disable Airplane Mode again. After this the tool will not be started on logon

    2) If you have only bluetooth mouse and keyboard or the first way haven't helped then write about it here and our support will send you full instruction privately

    Anyway, thanks for reporting this bug, we'll fix it in the nearest release.
     
  11. OweA

    OweA Bit Poster

    Messages:
    4
    It looks like that did the trick - thank you.
    One other thing, I did not get a mail saying there was a solution in the forums to read. It took me sometime before I took a look.
     
  12. sergk

    sergk Parallels Developers

    Messages:
    194
    We are glad to hear that your problem is fixed!
     

Share This Page