Monterey Private Relay and Mail Privacy Protection turned off when Parallels starts

Discussion in 'Installation and Configuration' started by SteveL1, Nov 17, 2021.

  1. SteveL1

    SteveL1 Bit Poster

    Messages:
    3
    Anybody else notice that in Monterey when you start Parallels 17 Private Relay and Mail Privacy Protection are turned off?

    For Private Relay I actually get a popup notification saying Private Relay is turned off right when Parallels starts. Mail adds a banner to my emails saying "Your network preferences prevent content from loading privately."

    Even when I quit Parallels Private Relay and Mail Privacy Protection doesn't turn back on. In fact if I run Parallels then start Private Relay afterwards, it looks like it starts, but it doesn't work, giving you a false sense of security.

    Only a full reboot of Monterey allow Private Relay and Mail Privacy Protection to work again.
     
  2. GampaA@Parallels

    GampaA@Parallels Staff Member

    Messages:
    416
    Hello @SteveL1 , please provide when it will ask to allow Private Relay and Mail Privacy Protection , then click on allow to run Parallels . Thanks, Parallels Team.
     
  3. SteveL1

    SteveL1 Bit Poster

    Messages:
    3
    Not quite sure what you are asking, but if I have Private Relay turned on in macOS Monterey, I get the message in the attached screen shot as soon as I start up Parallels 17. Just a notice, nothing to click on to allow Parallels to run. In fact Parallels runs fine, it just turns off Private Relay. Screen Shot 2021-11-18 at 3.04.55 PM.jpg
     
  4. BlairBold

    BlairBold Bit Poster

    Messages:
    2
    I'm having the same problem. Can Parallels staff clarify what they meant in the post above? Was it a suggestion for a fix, or a request for more info?
     

Share This Page