Mouse cursor is HUGE

Discussion in 'Installation and Configuration' started by seand2, Oct 12, 2015.

  1. seand2

    seand2 Bit Poster

    Messages:
    4
    Hello, i am displaying parallels on an external monitor with Windows 10, and my mouse cursor is gigantic.
    I cant seem to find a way around this except for opting for the "optimize for retina display" when configuring the VM; however, shouldn't I be running on "scaled" since i am displaying on a non retina external monitor?
    Also when I do run on "optimize for retina" Cad programs show small test in some dialogues and bigger in others that is quite discouraging to use.

    Any help or advice would be great!
     
  2. StarShot

    StarShot Bit Poster

    Messages:
    95
    I had the same problem and after loading Windows10, I clicked on Settings (above the start button) and the typed "mouse" in the search block in the upper right. Several mouse options appeared and I believe I selected "size" or something like that. Now my mouse arrow is small, maybe smaller than I like. I also selected "mouse trails".
     
  3. seand2

    seand2 Bit Poster

    Messages:
    4
    yeah i thought i could getter smaller there, but it already at the smallest size....
    I think the resolution is the problem, i cant figure this out, i'm back to using it on optimized for retina display even though its displaying on a low pixel external monitor..
     
  4. StarShot

    StarShot Bit Poster

    Messages:
    95
    That's strange. The large size of my mouse annoyed me, but I had other fish to fry. After seeing your complaint, I went into Setting, found the mouse setting, selected the smallest size and to be truthful, I think it's a bit too small for my 13" MBA. Without "trails", I probably would go for the next bigger option.

    What size computer do you have?
     
  5. seand2

    seand2 Bit Poster

    Messages:
    4
    Im on a 2014 15" Retina MacBook Pro with dedicated graphics, but as i mentioned earlier, I run parallels (windows 10) on an external monitor. So, I opted for the "scaled" version found in the graphics section in parallels settings. When i do that the VM show a huge mouse cursor already at the smallest setting found in the windows option.
     
  6. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,549
    Hi could you please provide us with the screenshot of the issue and also with the problem report? You can generate the Problem report using this KB
    Please reply us back with the report ID.
     
  7. BobP1

    BobP1

    Messages:
    1
    Hi,
    Was this mouse cursor problem ever sorted out, as I have the same problem?
     
  8. Dhana@Parallels

    Dhana@Parallels Parallels Support

    Messages:
    187
    Hello BobP1,
    Could you please share few screenshots of the issue along with a problem report number using this link ?
     
  9. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,549
    @BobP1 you can make a screenshot using this combination: cmd +shift+4
     
  10. sjc

    sjc Bit Poster

    Messages:
    4
    @maria you can't take a screenshot with the cursor visible, especially with cmd + Shift + 4 as that is the one to clip, naturally involving the cursor to make the clipping rectangle.
    I can usually fix the problem by resizing the Windows window as I run in a windowed mode.
     
  11. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,549
    Please check this article and try to change the cursor size.
     
  12. JasonM16

    JasonM16 Bit Poster

    Messages:
    1
    This fixed the huge mouse pointer problem for me: enter Coherence mode, and then exit Coherence mode.
    Note that in general, if I move between using my Thunderbolt display and my Macbook's retina display, I try to shut down my Parallels VM first, and restart it once the monitor change has been made. In the case of the big mouse pointer, I failed to follow said protocol.

    Parallels folks, here is more info:
    As far as I can tell, this issue is due to switching monitors, which in my case, involves either using my Macbook's integrated retina display, or my Apple Thunderbolt display. So, the following scenario lead to the giant mouse pointer:
    * Running Windows 10 in non-coherence mode on the retina display.
    * Sleep machine.
    * Attach Thunderbolt monitor, and wake machine.
    * Try to put the Mac to sleep (with Parallels VM still running). Sleep failed. Windows or Parallels crashed, and I needed to do a force quit, which took a long time to complete.
    * Restarted, launched Parallels, and mouse pointer was huge. Restarted the machine multiple times, but this did not fix the issue.

    In looking at Windows display settings, it appeared that the Win 10 VM believed that it was running on a monitor with the resolution of my retina laptop's display. Various attempts at restarting with the Thunderbolt display attached, detached, etc, had no effect.
     
    Last edited: Aug 18, 2017
  13. Arun@Parallels

    Arun@Parallels Parallels Support

    Messages:
    1,361
    Hi @JasonM16 , thank you for sharing this with us. We will reproduce the issue from our side and will try to provide a permanent fix for this issue.
     
  14. EdwardB3

    EdwardB3

    Messages:
    1
    HI @Arun@Parallels, I have exactly the same issue. I upgraded to windows 10 (I had been waiting to make sure that parallels had time to fix their issues) and now have the issue detailed here. I'm on the latest version of windows 10, latest version of parallels (Version 14.1.0 (45387)). @JasonM16's solution does solve this, but this should be fixed. This is what we pay for.
     
  15. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,549
    @EdwardB3 could you provide us with more info about the issue please? When the cursor became huge? When you start VM? May be when you're using specific application? Just please give us step-by-step instructions how to reproduce this issue. Thanks in advance.
     
  16. buckZor

    buckZor Bit Poster

    Messages:
    29
    This issue continues, easiest fix is just to slightly resize the VM window, that fixes it everytime for me. Annoying, but easily corrected.
     
    Maria@Parallels likes this.
  17. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,549
    Also you can use this article in order to change the mouse size.
     
  18. AlSt

    AlSt Bit Poster

    Messages:
    2
    I've found this occurs when running Windows 10 on an external 4K display, set to display at 3840x2160, and Windows' magnification of text and other window elements to 200%. The pointer is included in that magnification.
     

Share This Page