Mouse not working properly with Dual Screen using Maverick/Win 8.1

Discussion in 'Windows Guest OS Discussion' started by 902crew, Oct 24, 2013.

  1. 902crew

    902crew

    Messages:
    2
    When using all screens in full screen mode (Win 8.1, Maverick, Paralells 9, which are all fully updated) my mouse behaves strangely. Visually everything looks like its supposed to, however the clicks all register on my main screen despite the cursor moving between the two screens.

    For example, with the cursor on the futhest right hand side of the the main screen (second monitor to the left of the main screen) the click from the cursor registers in the same place I click. However when I click on the furthest left hand point (on second screen) it registers on the left hand side of my first screen.

    Basically no matter where I click on either screen it registers on my main screen (making it next to impossible to accurately click on anything in my main screen, and completely impossible on my second screen when using both screens in full screen).

    My workflow is pretty messed up now, not the end of the world, but I would REALLY love to get back to my old set up I used to use!

    Some additional info: Its a fresh install of Windows 8, which I upgraded to 8.1 through the windows store and it is not running through bootcamp. I have also reinstalled parallel tools twice with no change. When using a single screen in full screen mode, there is no problem with using the mouse, the issue only appears when using "Use all displays in full screen mode." I also already submitted a "Report a problem..." and it gave me an error code of 30172738 and a support code of 287113-65647.
     
    Last edited: Oct 24, 2013
  2. ClaudeC

    ClaudeC Bit Poster

    Messages:
    2
    I have the same problem, only icons click and right-click is working (Win 8.1, Maverick, Paralells 9, all fully updated)
     
  3. ClaudeC

    ClaudeC Bit Poster

    Messages:
    2
    Resolution of the problem : Delete the pointing devices in the device manager of Windows 8.1 and reboot after

    Full resolution problem from Parallels technical staff:
    >Create a Snapshot (Virtual Machine -> Take Snapshot).
    >
    >1. Open Registry Editor (In the Windows 8 search box type "regedit" and
    >open the app).
    >
    >Locate and select
    >HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E96F-E325
    >-11 CE-BFC1-08002BE10318} branch (you can use keyboard keys) In the
    >right panel under column "Name" look for "LowerFilters" and delete them
    >Expand this branch and select the subbranches (0000, 0001, 0002 etc.)
    >one by one looking at the "Provider Name" value in the right panel
    >under the "Name" column. If the Provider name is not Parallels or
    >Microsoft then delete this subbranch.
    >
    >1. Start -> in the search box type Device Manager -> Open it -> Expand
    >"Mice and other pointing devices" -> Delete them.
    >
    >2. Restart your virtual machine (Virtual Machine -> Shut Down)
    >
    >If you find it difficult to follow the troubleshooting steps, kindly
    >reply back to this email.
    >
    >Based on the resolution that has been sent to you, this case will be
    >placed in the "Pending Confirmation by Customer" status.
    >If this ticket has not been resolved to your satisfaction, please feel
    >free to reply to this email within the next 14 days and we will contact
    >you to continue working on the case.
    >
    >Your opinion is valuable to us, please fill in the survey which will be
    >sent to you automatically as I change the status of your ticket.
    >Parallels takes your feedback very seriously and each survey is
    >reviewed carefully to identify and act on opportunities for improvement.
    >
    >We appreciate your time and consideration.
     
  4. 902crew

    902crew

    Messages:
    2
    Thanks so much ClaudeC!! I didn't have any lower filter registry entries but once I deleted all the mouse entries from device manger and restarted, the mouse behave like it was supposed to in using dual full screen!
     

Share This Page