Mouse wheel scrolling problem

Discussion in 'Windows Guest OS Discussion' started by ChrisS6, Apr 3, 2017.

  1. ChrisS6

    ChrisS6 Bit Poster

    Messages:
    8
    I have recently purchased Parallels Desktop 12, and I am using it with a Win XP Pro guest OS and MacOS Sierra host OS.

    All seems to work well, except for one problem with the mouse wheel scrolling. If I scroll the contents of a Windows folder (eg. set to list view), the movement is far too much, to the extent that some of the columns are missed completely. Changing the number of lines per wheel click in the Windows mouse control panel makes no difference. What could be causing this, and is there a solution ?

    I have tried using the same guest OS under VMWare Fusion, and that doesn't exhibit the same issue, so it isn't a Windows bug.
     
  2. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    2,833
    Hi @ChrisS6, please follow the steps suggested below:
    1. Open virtual machine's configuration: -> Hardware tab -> Mouse & Keyboard -> set SmartMouse to Optimize for games. Do not close configuration window.
    2. Set desire mouse sensitivity in Windows virtual machine: Control Panel -> Mouse Properties -> Pointer Options tab -> Select a pointer speed
    3. Get back to virtual machine's configuration window. Set SmartMouse to Auto-detect for games.

    If the issue persists, please do the following steps to resolve the issue:
    1. Shut down the virtual machine.
    2. Switch to Hardware tab > Graphics > Extend Advanced Settings.
    3. Make sure that vertical synchronization is enabled.
    4. Start the virtual machine and it should be good.
     
  3. ChrisS6

    ChrisS6 Bit Poster

    Messages:
    8
    Hi Paul,
    Thanks for your reply.
    I tried both of the procedures you described, but there was no change. Vertical sync was already enabled.
    Note that this is the mouse wheel, not the pointer which has the problem.
    Chris.
     
  4. ChrisS6

    ChrisS6 Bit Poster

    Messages:
    8
    It is very disappointing that there is apparently no solution to this, as it makes Parallels pretty much unusable. For example, when navigating within an application for a file, you can't actually use the scroll wheel because whole rafts of files are bypassed with each wheel click. Somehow, Parallels breaks the mouse driver. Worse still, I paid for this product, so it's money down the drain.

    Back to VMWare which behaves perfectly (albeit a bit slower).
     
  5. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    2,261
    Hi @ChrisS6 we are sorry that you're unhappy with the Parallels Desktop, but if you would like to continue investigation please provide us with the following info:
    Do you have this issue with all Windows apps or with the specific one?
     
  6. ChrisS6

    ChrisS6 Bit Poster

    Messages:
    8
    It happens in all Windows apps and within any open Windows folder on the desktop. Changing the wheels settings in the Mouse control panel doesn't do anything.
     
  7. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    2,261
    Please try to reinstall mouse drivers in device manager:

    Device manager -> Mice and other pointing device -> right lick on Parallels mouse synchronization device and choose "scan for hardware changes"
     
  8. ChrisS6

    ChrisS6 Bit Poster

    Messages:
    8
    That has absolutely no effect.
     
  9. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    2,261
    Could you please generate the problem report using this KB article and reply us back with the report number?
     
  10. ChrisS6

    ChrisS6 Bit Poster

    Messages:
    8
    I have logged a problem report, and I posted the report number here yesterday. Unfortunately my post has disappeared.
    How do I find my report number, as there was no email confirmation of the report being logged ?
     
  11. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    2,261
    OK, thanks a lot for the info, I'll try to find your report by email and let you now the results.
     
  12. LeonardoA2

    LeonardoA2 Bit Poster

    Messages:
    1
    Hello!
    I have exactly the same problem with the scrolling of my mouse. It's really frustrating. Moreover, I use CAD software and it is a mess dealing with the zoom when I use the scrolling wheel.
    I have Parallels 13 on a MacBook Pro 15" Touchbar 2016 with Windows 10 and OS High Sierra. Magic Mouse 2, HP mice, Logitech mice.
    I tried everything, from changing the setup of Parallels to using different mice and the issue persists.
    I also believe this is an issue related with the Parallels mouse driver emulation.
    Please I need your support to solve this. I find Parallels software is excellent except for this issue that makes it unusable.
    Regards
     
  13. ChrisS6

    ChrisS6 Bit Poster

    Messages:
    8
    Hi Leonardo,
    Yes it is a very annoying issue, which renders Parallels almost unusable. I've not heard anything back from Parallels about the problem - presumably they have no interest in keeping their customers. I have switched to VMWare Fusion, which doesn't have this problem, and I would advise that you do the same.
    Chris.
     
  14. Arun@Parallels

    Arun@Parallels Parallels Support

    Messages:
    703
    Hi @LeonardoA2 , please take a snapshot of your Windows virtual machine. Actions > Take snapshot and then remove the mouse drivers inside your Windows virtual machine and then try Actions > Reinstall Parallels Tools and check if that helps.
     
  15. DinoV

    DinoV Bit Poster

    Messages:
    4
    Hi! I have the same problem. The scroll is noticeably faster than on the standard windows machine, no matter how much I slow down the scroll speed. I also use a design program that ignores the Windows set scroll speed and it's also MUCH faster. This tells me it must be something on the driver level making the mouse scroll speed faster. Could you really fix this? I need it because it's really hard to work like this.
     
  16. Hemnath@Parallels

    Hemnath@Parallels Parallels Support

    Messages:
    494
    Hi DinoV. Please take a snapshot, shut down Windows, open the virtual machine configuration window, navigate to Hardware -> Mouse & Keyboard, select 'Don't optimize for games' for 'Mouse' and disable 'Mouse pointer sticks at window edges' and 'Smooth scrolling'. Close the window and check for the issue now.
     
  17. DinoV

    DinoV Bit Poster

    Messages:
    4
    That didn't change it. Still the scroll is about 1.5x - 2x faster than normal.
    Maybe include an option in the settings to adjust the size of the individual scrolling step? It's clearly much bigger than it should be.
     
  18. Hemnath@Parallels

    Hemnath@Parallels Parallels Support

    Messages:
    494
    Please confirm if you have tried those steps already, suggested earlier in this thread:
     
  19. DinoV

    DinoV Bit Poster

    Messages:
    4
    Yes, I did it before I answered and I did it now again just in case. The scroll speed I set in Control Panel -> Mouse Properties is at the lowest, and it's still VERY fast.

    Also, the mouse speed increased SIGNIFICANTLY when Optimize for games mode has been enabled. Not a concern for me because I don't use this mode, but maybe it gives you a clue.
     
  20. DinoV

    DinoV Bit Poster

    Messages:
    4
    By mouse speed above, I mean the speed that the cursor moves. The scrolling speed also remained much faster than it should be.
     

Share This Page