New Mac Pro build available for download

Discussion in 'Announcements' started by Ben @ Parallels, Sep 19, 2006.

  1. Ben @ Parallels

    Ben @ Parallels Member

    Hello all -

    We have just made available a new build (1898) for Desktop for Mac that substantially improves Mac Pro and 64-bit iMac performance and eliminates kernel panics and major bugs.

    For those users who have Mac Pros and 64-bit iMacs with more than 2GB of RAM, you've had to manually limit your RAM via the command line in Terminal. In this build, we've included a tool that will help you take this action without any command line coding. With a single click you can limit your RAM and make your Mac Pro fully compatible with this build. You can easily revert your memory back at any time to the full configuration with the same tool.

    NOTE: Its very important to note that limiting your RAM configuration to run Parallels Desktop will NOT prevent you from running any other OS X application (although they may run slightly slower). It simply helps our hypervisor "play nice" with the Mac Pro.

    Originally, I told you that we'd have full PAE support by year's end. Now, I'm pleased to let you know that we are working on a new RC version that will be compatible with ANY Mac with ANY amount of RAM, and will have it much sooner than originally anticipated. The engineering team tells me that this build should be available in a week or two.

    This build also adds support for Windows Vista RC1 as a guest OS, and adds an improved Parallels Tools package for all of the Vista builds that improves mouse movement, and video resolutions, and beefs up networking.

    Thank you again to all of our loyal Desktop users and beta testers. Everyone here appreciates your feedback and your patience.
  2. GregMeach

    GregMeach Bit poster

    Just an update - I installed Vista RC1 on my MacBook without any problems. Haven't done much more than that right now (still at work).

    Thanks guys!

  3. fhx1274

    fhx1274 Bit poster

    Parallels never start, always limits memory


    just installed the new release and was quite happy at having a more stable version since I'm working a lot with parallels at the moment.

    The problem is : Parallels starts, tells me it has limited the available memory to 2GB (thanks guys... really nice to have 3GB sitting here doing nothing... and I was running with 3,5GB almost fine these last few days, so it would have been great to be able to SET the amount of memory instead of forcing it to 2GB) and that I need to restart my mac...

    But it keeps telling me that, even though I have rebooted twice and that the memory is already at 2GB, and refuse to start...
    So I'm sorry to be that cinical, but nice try guys and I guess I'm back a 1884

    Edit: made a final try before scratching back to 1884... I cleared the boot-args before running Parallels. This time Parallels ASKED to change the maxmem instead of SETTING without asking anything. this time it also asked for my admin password before doing anything and sure enough, after a reboot it finally worked.
    Last edited: Sep 19, 2006
  4. Andrew @ Parallels

    Andrew @ Parallels Parallels Team

  5. xylone

    xylone Bit poster

    Just installed the new update and I'm working with it right now.
    Just want to say one word: WOW!
    It seems like it's almost 2 times faster, networking is working out of the box and the video it much better when switching from windows, while booting, to osx.

    Thanks guys!

    Some things to make it even better :rolleyes:
    • It started to say it had limited my memory to 2 GB and had to start my mac. Weird, because I have 'only' 2GB of memory.
    • The other thing is, it also said the VT-x bit was off and I had to put my mac to sleep and wake it up to switch it 'on'.
    • When switching from Windows to OS X, using VirtueDesktop, I always 'loose' my dock and menu bar. I have to click somewhere on my desktop to show it. Maybe it is something with VirtueDesktop in combination with Parallels, because switching from one OS X desktop to an othe OS X desktop does not have this problem
    Last edited: Sep 22, 2006
  6. Pedge

    Pedge Bit poster

    Just installed this new build - went ok and after rebooting into 2gb ram (booo!) it worked a treat (yay!).

    What amazed me is that we have a Canon CLC3220 printer and Comand Workstation only works in 'light' (i.e. features mostly disabled) on the Mac and I was able to install the full version onto Windows XP AND my mac spooled print files over to it first go!

    I'm really pleased with how this is developing and - as I imagine everyone else is shouting - please sort out the ram issues - as I imagine you're already doing!

    Good stuff fellas - keep on it! :D
  7. shuechen

    shuechen Bit poster

    Problem with FX 4500

    Hi guys,

    i am pretty new to parallels Desktop. I am just trying it out on a mac pro with an nvidia quadro fx 4500. XP installation was easy, but now i am looking for a driver for the graphic card. can u guys help me....

  8. Andrew @ Parallels

    Andrew @ Parallels Parallels Team

    Please install Parallels Tools in guest Windows to achive decent video resolutions (menu VM->Install Parallels Tools, guest should be booted).
  9. FikseGTS

    FikseGTS Junior Member

    how do you get to this tool to put the ram back to the original config??
  10. dfp1

    dfp1 Bit poster

    It's under the Help menu bar item.

    Select Help > Revert Memory Back.
  11. DavidO

    DavidO Bit poster

    I have a fresh-from-the-box 20" iMac Core 2 Duo with 2GB of factory RAM. Have tried 1848, 1896, and 1898 and consistently either crash "hard" when starting the VM, or start the VM, only for it to loop endlessly failing to read my XP boot disk (disk tested on a PC, so that's not the issue). I do see an "NTDETECT failed" message on the VM console. Any ideas or help appreciated.
  12. Eric Danno

    Eric Danno Bit poster

    Yeah, I don't own Parallels yet, but I did download the trial. I haven't been able to get it to run on my new 17" iMac Core 2 Duo with 2 Gigs of Ram......exact same errors the above user gets. And then a really nasty Mac crash........
  13. NormRubenstein

    NormRubenstein Bit poster

    I have a 15 day trial on my new Mac Pro with 4GB of ram - and upgraded to the new 1910 build. It has been working perfectly with Win XP along with a number of Windows based software products, and I could not be any happier! I am absolutely purchasing a permanent activation key, as the program is a true winner. The responsiveness is very "peppy" and my Mac programs have NOT slowed to a crawl as with the earlier ram-limited builds of Parallels. In fact, the success of the latest build is convinving reason to actually increase one's system ram to between 6-8GB.

    Thanks to all those involved with Parallels - and keep up the great work!
  14. spetznatz

    spetznatz Hunter

    The internal build linked above by Andrew won't run on My Mac Pro (2.0 GHz, 4GB). 1500 MB given to VM. Was failing on Windows install.

    First time, While setting up the NTFS file system.

    Second, whilst copying installer files (i.e. earlier on in the process) both times 'Fatal internal error"

    Now just hangs when VM starts. Won't even read XP CD. (CD has been used to install under BootCamp).

    Sent crash reports the first two times.

    Am I ever going to get this running on my Mac pro?
  15. danMacPRO

    danMacPRO Bit poster

    MAC PRO and Wireless Keyboard and Mouse

    I was wondering if this build would support my Apple BlueTooth Wireless keyboard and
    Apple wireless mouse. Basically, I want to install Windows XP as a Guest OS and understand
    that there is no good support for wireless keyboard and wireless mouse in Bootcamp at least.
  16. joem

    joem Forum Maven

    The one thing I notice different about what you are trying to do is that you are giving the VM 1.5GB. Maybe if you try 512 as an experiment, with 750 total to Parallels, we'd get some useful data.

Share This Page