Once I turn on the Paralles Desktop , Dns doesn't work.

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by langlang, Oct 21, 2021.

Tags:
  1. langlang

    langlang Bit Poster

    Messages:
    2
    I try the Parallels 17.0, Once I turn on the Parallels Desktop, Macos'Dns does not work。At that time,I can ping dns server successfully, and vm's network is ok. I use wireshark to sniff, and found that i can't catch any dns request . Once I trun off the Parallels Desktop, dns work again.
    In order to resolve this problem,I update to 17.1, but that doesn't work.
     
  2. langlang

    langlang Bit Poster

    Messages:
    2
    Nobody else has the same problem?
     
  3. SeanK8

    SeanK8 Bit Poster

    Messages:
    3
    I upgraded to Parallels 17 today and spun up an Ubuntu Linux VM which worked fine, but then I tried to spin up a Fedora and CentOS Linux VM and neither of them could resolve DNS under some circumstances. Oddly, the dig command worked, but most other things failed.

    I happened to find this KB article about DNS issues with Windows guests and decided to give the solution a try, and it worked like a charm.

    https://kb.parallels.com/en/124502

    In this case, it involved switching from a shared network to a bridged network.

    I have no idea why it appears to only impact certain Linux distributions, but it fixed the issue.
     

Share This Page