OpenGL

Discussion in 'Windows Guest OS Discussion' started by tey, Sep 29, 2011.

  1. Old Dawg

    Old Dawg

    Messages:
    1
    This is my setup and what worked for me:
    iMac, 2.5 GHz Intel Core i5, 16 GB 1600 MHz DDR3, Intel HD Graphics 4000 768 MB, Parallels 8, Windows 7 SP1, SolidWorks 2013.

    I added the folder:
    \HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2011\Performance\Graphics\Hardware\Parallels and Intel Inc.
    and added Workarounds REG_DWORD 0x02000000

    I got the key from Quatro4. I simply put in keys from other folders until I found one that worked.

    I hope that this helps.
     
  2. BrianMcV

    BrianMcV

    Messages:
    1
    Has anyone had any success getting RealView to work on a GTX 675M? I have managed to get hardware openGL to work by adding 4000480 as the value for the parallels & Nvidia entries in the registry, but can't seem to get the gold realview icon to become active. Anyone managed it?
     
  3. nafione

    nafione

    Messages:
    2
    Can anyone tell me for certain which keys I need to mess with for a 15" retina macbook pro base model, with Intel Iris pro graphics only?

    Changing all the Intel keys and adding a Parallels and Intel Inc. key with the workaround values 4000480 allow me to uncheck software GL in solid works, however the performance is less than a macbook pro with a 750m graphics card. Rumor is apparently Iris pro should be better at solid works?!
     
  4. ShervinJ

    ShervinJ

    Messages:
    3
    Any one knows how to get this working with Windows 7 64bit, Parallels 9 and Intel HD3000 on late 2011, 13" MacBook pro. On XP the registry values of 4000480 worked, but since I updated to Win 7 they do not work anymore.
     
  5. ClaudP

    ClaudP Bit Poster

    Messages:
    3
    Try again, i.e. modify the values, the same set up works on my son's with Win 7.. realgraphics never worked though. If anyone knows.. will be good to know.
     
  6. JonG89

    JonG89 Bit Poster

    Messages:
    37
    Last edited: Jun 17, 2014
  7. NikianA

    NikianA

    Messages:
    2
    Hi All,

    I'm running a MacPro (2013 model) (not a macbook pro).

    I was wondering if anyone could instruct me to enable the openGL on (speed up) my Solidworks run on Parallels 9 with Windows 8.1
    I've read the above threads but I am unsure if my MacPro differs from the macbook pro retinas for example and I'm a little scared to edit anything without clear instructions.

    My specs are

    Proccessor: 3.7 GHz Quad-Core Intel Xeon E5
    RAM: 16 GB 1867 MHz DDR3 ECC
    Graphics: AMD FirePro D300 2048 MB (I think there might be two of these)

    I am not tech savvy with windows so if you could be clear I would be elated!
    Thanks a lot!
     
    Last edited: Jul 17, 2014
  8. JonG89

    JonG89 Bit Poster

    Messages:
    37
    If you follow the two-step procedure in my post, it should work for anything. SolidWorks 2014 made things a little easier by adding the "Current" registry branch, so we don't have to guess which video driver entry to edit.
     
  9. NikianA

    NikianA

    Messages:
    2
    Forgive me if I am slow but what is the registry branch? ie how do I get there in Windows 8.1?
     
    Last edited: Jul 18, 2014
  10. cbonsig

    cbonsig Bit Poster

    Messages:
    2
    Solved: SW2014 + 13" Macbook Pro Retnia

    SOLVED: I have a MacBook Pro 13" with integrated Intel Iris graphics ("Retina, 13-inch, Late 2013". MacBookPro11,1) + Parallels 9.0.24237 + Solidworks 2014 + Windows 8.1 Pro. I followed this thread and others, and had many unsuccessful attempts at enabling hardware acceleration before finally getting it to work.

    Two observations from the registry:

    HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2014\Performance\Graphics\Hardware\Current
    * Renderer = Parallels using Intel Iris OpenGL Engine
    * Vendor = Parallels and Intel Inc.

    HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2014\Performance\Graphics\Hardware\Intel\Intel(R) Iris(TM) Pro Graphics\V001_FG_X614105256_V815102256
    * Workaround = 4000480

    The trick to make this work was to create a new key under Hardware for the vendor ("Parallels and Intel Inc.") and then another key under that for the renderer ("Parallels using Intel Iris OpenGL Engine"), and finally set the Workaround for the renderer to 4000480.

    The final key that I created is this:
    HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2014\Performance\Graphics\Hardware\Parallels and Intel Inc.\Parallels using Intel Iris OpenGL Engine

    For what its worth, I have a Workaround of 4000480 set under the vendor key (Parallels and Intel Inc.) and also under the renderer key (Parallels using Intel Iris OpenGL Engine). Finally, the "Use Software OpenGL" option is unchecked, and graphics performance is awesome!

    Hope this helps someone else.
     
  11. abe_villa

    abe_villa Bit Poster

    Messages:
    1
    @cbonsig Wow. I had to login just to say, THANK YOU for this. I too was having a difficult time because of my graphics card.
     

    Attached Files:

  12. cbonsig

    cbonsig Bit Poster

    Messages:
    2
    FYI: At some point, I found that Solidworks 2014 reverted back to the old intolerable Software GL rendering... I'm not sure if this was caused by upgrading Windows, Parallels, or Solidworks to the latest service pack (but Solidworks, I'm looking at YOU here). In any case, I was able to get hardware rendering working again by following the same process. Current config: Yosemite 10.10.3, Parallels 10.2.0 (28956), Solidworks 2014 SP5.0, Windows 8.1 Pro x64 6.3.9600.
     

    Attached Files:

  13. JonG89

    JonG89 Bit Poster

    Messages:
    37
    FWIW, cbonsig's fix (#32 above) also works for SW 2015 in a Win 8.1 64-bit VM in Parallels 10.2.1 (29006) on my mid-2012 13" MacBook Pro running Mac OS X 10.10.4.

    The real question is, when is SolidWorks going to fix this automatically, so we can all stop mucking around in the registry? Given that the registry fix is obviously under the SolidWorks subkey (and not the Parallels subkey), it's obviously a SolidWorks issue.
     
  14. JonG89

    JonG89 Bit Poster

    Messages:
    37
    I've submitted the following enhancement request to SolidWorks via https://customerportal.solidworks.com . Feel free to do the same...if enough of us make noise about this issue, maybe it will make its way to the front burner:

    See https://forum.parallels.com/threads/opengl.114508/ for more details on this issue, specifically entry #32 for the workaround.

    SolidWorks doesn't properly handle the Parallels graphics adapter, and completely disables the "use software OpenGL" option in its system options--it's both enabled and greyed out, so the user can't change it. This causes horrible graphics performance in SolidWorks, even though the Parallels VM supports hardware 3D acceleration (virtualized, of course, but SW doesn't need to know that). A registry hack fixes the problem. I'm tempted to call it a "simple" registry hack, but that really depends on the user--and we really shouldn't have to be editing the registry to make a high-dollar app like SW work properly.

    It would be simple enough for SW to create the necessary registry entries for the detected Parallels graphics adapter, enable 3D acceleration, and leave it to the user to ensure that 3D acceleration support is enabled for the VM. I've attached an annotated screenshot explaining the registry issue.
     
  15. RemyP

    RemyP Bit Poster

    Messages:
    1
    Hey All,

    I've tried everything above and still can't manage to get Realview to work. Software OpenGL is greyed out, but unchecked, and I'm not having any issues in the solidworks environment, but for some reason Photoview 360 won't let me turn off floor shadows since i don't have Realview active.

    I'm running Solidworks 2015 x64 sp 4.0 on a MBP Retina 15 with the GeForce GT 750M (see attached for full specs) and Parallels 11.0.1 with Windows 7
    Anyone had any luck?!
    upload_2015-9-17_15-57-13.png
     
  16. MarcusH1

    MarcusH1 Bit Poster

    Messages:
    3
    Unfortunately I'm too late in learning about this issue. I just got an iMac 5k for use with Solidworks 2016 (via Parallels 11). After a mighty struggle to simply get Windows 8.1 installed with 5k resolution AND install SW 2016, I now hit this wall. Tried the registry patch for SW2015, but the Open GL checkbox (under Tools>Options>Performance) is still checked and greyed out.

    All my 3D solid models are blobs. Is this what everyone else is seeing (pic)?
     

    Attached Files:

  17. MarcusH1

    MarcusH1 Bit Poster

    Messages:
    3
    Just writing to let everyone know that Solidworks 2016 is now up an running on my system. Parallels Support released a patch that let's you uncheck Open GL software acceleration (KB Article ID 122790). It works like a champ. It's still an imperfect solution (aka registry hack), but it's enough to get me going.

    Also - my "parts look like a blob" issue was driven by a setting in Solidworks itself. For some reason, the lighting settings in the default parts file were all turned off. No light means no shading, which means all parts look like blobs. Anyway - it's fixed now.

    Now my only Solidworks problem is that when I press the Command key + middle mouse button (in order to rotate models), the Windows menu always comes up and I have to press the ESC key to get back into Solidworks. Any way to get around that?

    Thanks to the team at Parallels Support for solving this problem!
     
  18. GregorR1

    GregorR1 Bit Poster

    Messages:
    2
    Hi man, just new to this forum and having the same problems. But noticed your middle click problem. Download an app called Magicprefs and you can programme the mouse to have middle click without pressing command. Hope that helps.
     
  19. MattS5

    MattS5

    Messages:
    1
    I have a MBP mid 2012 with an intel HD Graphics 4000. Running Solidworks 2016 with Parallels - the parallels patch worked for me in terms of unchecking open GL software acceleration, but it does not enable RealView. Anyone had any luck with RealView given this graphics card? I followed the instructions on http://www.caddirt.com/blog/2012/9/13/realview-on-a-macsecrets-revealed, and was able to get the RealView icon to show in solidworks (i.e. I can click it on and off), but it doesn't actually work - only give me a little shaddow around the part. I'm guessing I don't have the right hex value for "workaround" (I've tried a couple that were recommended for other graphics cards). How do I find the correct hex value for it?
     
  20. PeterM9

    PeterM9 Bit Poster

    Messages:
    1
    Thanks to all the Advice here, would just like to add for a 2017 MacbookPro Radeon 560 4Gb,. Windows 10 and Parallels 12.

    Workarounds REG_DWORD is 0x04000005, this comes from the Value of the Radeon Pro workarounds under "ATI Technologies" the 0x84000004 and 0x004000480 creates weired geometery in models.

    Be sure to change the Workarounds for the following:
    "Current"
    "GI2Shaders/Other/Parallels using AMD Radeon PRO 560 OpenGL Engine" this one you created yourself.
    "Parallels and ATI Technologies Inc"
    "Parallels Inc and ATI Technologies Inc"

    Thats It.
     

Share This Page